【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=2648
【题目描述】
Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's price after the change of everyday.
【输入格式】
One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.
【输出格式】
Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.
【输入样例】
3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory
【输出样例】
1
2
【算法分析】
注意 mp.clear() 出现的位置,否则在 HDU 上进行测试时会报错。
【算法代码】
cpp
#include <bits/stdc++.h>
using namespace std;
int main() {
map<string,int> mp;
int n,m,price;
while(cin>>n) {
string shop;
for(int i=1; i<=n; i++) cin>>shop;
cin>>m;
while(m--) {
for(int i=1; i<=n; i++) {
cin>>price>>shop;
mp[shop]+=price;
}
int rank=1;
map<string,int>::iterator it;
for(it=mp.begin(); it!=mp.end(); it++) {
if(it->second > mp["memory"]) rank++;
}
cout<<rank<<endl;
}
mp.clear();
}
return 0;
}
/*
in:
3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory
out:
1
2
*/
【参考文献】
https://cplusplus.com/reference/map/
https://cplusplus.com/reference/map/map/
https://cplusplus.com/reference/map/map/lower_bound/
https://cplusplus.com/reference/map/map/upper_bound/
https://cplusplus.com/reference/map/map/begin/
https://cplusplus.com/reference/map/map/end/
https://cplusplus.com/reference/map/map/clear/