docker报错standard init linux.go:228 exec user process caused: exec format error

1、报错

使用Dockerfile自己做的服务镜像,docker run时启动失败,报错如下:

java 复制代码
standard init linux.go:228 exec user process caused: exec format error

2、原因一

当前服务器的CPU架构和构建镜像时的CPU架构不兼容。比如做镜像是在arm机器下构建的,而docker run是在amd架构下执行的。排查:

bash 复制代码
# 镜像信息
docker inspect 镜像ID |grep -i Arch

查看当前服务器的CPU架构信息:

bash 复制代码
# Linux信息
uname -a
# 或
lscpu

此时,可通过docker buildx插件模拟多CPU架构,构建出你需要的镜像,从而解决这个问题。

2、原因二

要是前面的这个问题,那倒是明晰,坑就在你明明用docker buildx构建的,查看两个架构信息也没毛病,但还是报这个错。

此时,考虑你Dockfile里的基础镜像,它的架构也要对应上。不能做amd下的镜像,但基础镜像却是arm下的。比如我之前使用JDK的镜像,Dockerfile共用一个,开头都是:

bash 复制代码
FROM openjdk:11.0.4

这个坑得处理掉,可以通过--platform参数来完成指定架构镜像的拉取:

bash 复制代码
docker pull --platform linux/arm64 openjdk:11.0.4
bash 复制代码
docker pull --platform linux/amd64 openjdk:11.0.4

后面我是通过CICD平台的,对应的打包脚本也就变成了:

问题解决!

相关推荐
Lvan的前端笔记5 小时前
docker:每个前端项目一个 Nginx 容器还是只有一个Nginx容器
前端·nginx·docker
Apipi*6 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
天启HTTP7 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
广州浮点FLOATLIC9 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
BLUcoding10 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK10 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil20810 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)10 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter62510 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
sbjdhjd11 小时前
云安全 | Docker 容器逃逸复盘(三):docker.sock 挂载与 Docker-in-Docker 风险
经验分享·网络安全·docker·云原生·容器·kubernetes·云安全