华为数通---配置Smart Link负载分担案例

定义

Smart Link,又叫做备份链路。一个Smart Link由两个接口组成,其中一个接口作为另一个的备份。Smart Link常用于双上行组网,提供可靠高效的备份和快速的切换机制。

目的

下游设备连接到上游设备,当使用单上行方式时,若出现单点故障,会造成业务中断。若采用双上行方式,将一台下游设备同时连接到两台上游设备,可降低单点故障对网络的影响,提高了可靠性。

组网需求

如下图所示,为了保证网络的可靠性,用户侧网络采用双上行方式组网。由于组网上存在多个VLAN的数据流量,为使链路得到充分利用,用户希望两条上行链路均进行数据流量的转发。组网要求业务中断时间控制在毫秒级。

配置思路

采用如下的思路配置Smart Link功能:

  • 在SwitchA上进行配置,将需要进行负载分担的VLAN 500映射到实例10。
  • 在SwitchA上配置Smart Link组,将对应接口加入Smart Link组中。
  • 在SwitchA上配置负载分担功能,实例10映射的VLAN数据从备份链路进行转发。
  • 在SwitchA上使能回切功能,使得故障恢复后,流量切换到相对稳定的原主链路上。
  • 在SwitchA上使能发送Flush报文功能。
  • 在SwitchB、SwitchC和SwitchD三台设备对应接口上使能Flush报文接收功能。
  • 在SwitchA上使能Smart Link组功能。
操作步骤

(1)配置VLAN信息

在SwitchA上创建VLAN,并配置接口允许相应VLAN通过。SwitchB、SwitchC和SwitchD的配置与SwitchA相似,详见配置文件。

cpp 复制代码
<Huawei>system-view 
[Huawei]sysname SwitchA
[SwitchA]vlan batch 10 100 500
[SwitchA]interface GigabitEthernet 0/0/1
[SwitchA-GigabitEthernet0/0/1]port link-type trunk 
[SwitchA-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 100 500
[SwitchA-GigabitEthernet0/0/1]quit
[SwitchA]interface GigabitEthernet 0/0/2
[SwitchA-GigabitEthernet0/0/2]port link-type trunk 
[SwitchA-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 100 500
[SwitchA-GigabitEthernet0/0/2]quit

(2)在SwitchA上配置VLAN映射

cpp 复制代码
[SwitchA]stp region-configuration 
[SwitchA-mst-region]instance 10 vlan 500
[SwitchA-mst-region]active region-configuration 
[SwitchA-mst-region]quit

(3)将去使能STP功能的上行接口加入Smart Link组并指定为主接口或从接口

配置SwitchA

cpp 复制代码
[SwitchA]interface GigabitEthernet 0/0/1	
[SwitchA-GigabitEthernet0/0/1]stp disable 
[SwitchA-GigabitEthernet0/0/1]quit
[SwitchA]interface GigabitEthernet 0/0/2	
[SwitchA-GigabitEthernet0/0/2]stp disable 
[SwitchA-GigabitEthernet0/0/2]quit
[SwitchA]smart-link group 1
[SwitchA-smlk-group1]port GigabitEthernet 0/0/1 master
[SwitchA-smlk-group1]port GigabitEthernet 0/0/2 slave 

(4)在SwitchA上配置负载分担功能

cpp 复制代码
[SwitchA-smlk-group1]load-balance instance 10 slave

(5)使能回切功能并设置回切时间

配置SwitchA。

cpp 复制代码
[SwitchA-smlk-group1]restore enable 
[SwitchA-smlk-group1]timer wtr 30

(6)使能发送Flush报文功能

配置SwitchA,并指定发送Flush报文的密码为SHA加密方式。

cpp 复制代码
[SwitchA-smlk-group1]flush send control-vlan 10 password simple huawei-123

(7)使能接收Flush报文功能

配置SwitchB,并指定接收Flush报文的密码为SHA加密方式。

cpp 复制代码
[SwitchB]interface GigabitEthernet 0/0/1
[SwitchB-GigabitEthernet0/0/1]smart-link flush receive control-vlan 10 password 
simple huawei-123
[SwitchB-GigabitEthernet0/0/1]stp disable 
[SwitchB-GigabitEthernet0/0/1]quit
[SwitchB]interface GigabitEthernet 0/0/2
[SwitchB-GigabitEthernet0/0/2]smart-link flush receive control-vlan 10 password 
simple huawei-123
[SwitchB-GigabitEthernet0/0/2]stp disable 
[SwitchB-GigabitEthernet0/0/2]quit

配置SwitchC,并指定接收Flush报文的密码为SHA加密方式。

cpp 复制代码
[SwitchC]interface GigabitEthernet 0/0/1
[SwitchC-GigabitEthernet0/0/1]smart-link flush receive control-vlan 10 password 
simple huawei-123
[SwitchC-GigabitEthernet0/0/1]stp disable 
[SwitchC-GigabitEthernet0/0/1]quit
[SwitchC]interface GigabitEthernet 0/0/2
[SwitchC-GigabitEthernet0/0/2]smart-link flush receive control-vlan 10 password 
simple huawei-123	
[SwitchC-GigabitEthernet0/0/2]stp disable 
[SwitchC-GigabitEthernet0/0/2]quit

配置SwitchD,并指定接收Flush报文的密码为SHA加密方式。

cpp 复制代码
[SwitchD]interface GigabitEthernet 0/0/1
[SwitchD-GigabitEthernet0/0/1]smart-link flush receive control-vlan 10 password 
simple huawei-123
[SwitchD-GigabitEthernet0/0/1]stp disable 
[SwitchD-GigabitEthernet0/0/1]quit
[SwitchD]interface GigabitEthernet 0/0/2
[SwitchD-GigabitEthernet0/0/2]smart-link flush receive control-vlan 10 password 
simple huawei-123
[SwitchD-GigabitEthernet0/0/2]stp disable 
[SwitchD-GigabitEthernet0/0/2]quit

(8)在SwitchA使能Smart Link组功能

cpp 复制代码
[SwitchA-smlk-group1]smart-link enable
[SwitchA-smlk-group1]quit

(9)验证配置结果

使用display smart-link group命令查看SwitchA上的Smart Link组信息。如果显示如下信息,则表示配置成功。

  • Smart Link组功能已经使能
  • 回切时间为30秒
  • 控制VLAN编号为10
  • 接口GE0/0/1为主接口且处于Active状态,接口GE0/0/2为从接口且处于Inactive,并且配置了负载分担功能。
cpp 复制代码
[SwitchA]display smart-link group 1
Smart Link group 1 information :
  Smart Link group was enabled
  Wtr-time is: 30 sec.
  Load-Balance Instance: 10 
  There is no protected-vlan reference-instance
  DeviceID: 4c1f-cc8e-66bb  Control-vlan ID: 10
  Member                  Role   State    Flush Count Last-Flush-Time
  ----------------------------------------------------------------------

  GigabitEthernet0/0/1    Master Active   1           2023/12/07 15:57:28 UTC-08
:00 
  GigabitEthernet0/0/2    Slave  Inactive 0           0000/00/00 00:00:00 UTC+00
:00 

使用shutdown命令关闭接口GE0/0/1,可以看到接口GE0/0/1已经处于Inactive状态,接口GE0/0/2为Active状态。

cpp 复制代码
[SwitchA]interface GigabitEthernet 0/0/1
[SwitchA-GigabitEthernet0/0/1]shutdown
[SwitchA-GigabitEthernet0/0/1]display smart-link group 1
Smart Link group 1 information :
  Smart Link group was enabled
  Wtr-time is: 30 sec.
  Load-Balance Instance: 10 
  There is no protected-vlan reference-instance
  DeviceID: 4c1f-cc8e-66bb  Control-vlan ID: 10
  Member                  Role   State    Flush Count Last-Flush-Time
  ----------------------------------------------------------------------

  GigabitEthernet0/0/1    Master Inactive 1           2023/12/07 15:57:28 UTC-08
:00 
  GigabitEthernet0/0/2    Slave  Active   0           0000/00/00 00:00:00 UTC+00
:00 

使用undo shutdown命令开启接口GE0/0/1。

cpp 复制代码
[SwitchA-GigabitEthernet0/0/1]undo shutdown

等待30秒后,可以看到接口GE0/0/1处于Active状态,接口GE0/0/2为Inactive状态。

cpp 复制代码
[SwitchA-GigabitEthernet0/0/1]display smart-link group 1
Smart Link group 1 information :
  Smart Link group was enabled
  Wtr-time is: 30 sec.
  Load-Balance Instance: 10 
  There is no protected-vlan reference-instance
  DeviceID: 4c1f-cc8e-66bb  Control-vlan ID: 10
  Member                  Role   State    Flush Count Last-Flush-Time
  ----------------------------------------------------------------------

  GigabitEthernet0/0/1    Master Active   2           2023/12/07 16:03:41 UTC-08
:00 
  GigabitEthernet0/0/2    Slave  Inactive 0           0000/00/00 00:00:00 UTC+00
:00 

假设PC1所属的VLAN为VLAN100,PC2所属的VLAN为VLAN500,PC1和PC2都能访问Internet。

配置文件
  • SwitchA的配置文件
cpp 复制代码
#
sysname SwitchA
#
vlan batch 10 100 500
#
stp region-configuration
 instance 10 vlan 500
 active region-configuration
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
#
smart-link group 1
 load-balance instance 10 slave
 restore enable
 smart-link enable
 port GigabitEthernet0/0/1 master
 port GigabitEthernet0/0/2 slave
 timer wtr 30
 flush send control-vlan 10 password simple huawei-123
#
return
  • SwitchB的配置文件
cpp 复制代码
#
sysname SwitchB
#
vlan batch 10 100 500
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
 smart-link flush receive control-vlan 10 password simple huawei-123
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
 smart-link flush receive control-vlan 10 password simple huawei-123
return
  • SwitchC的配置文件
cpp 复制代码
#
sysname SwitchC
#
vlan batch 10 100 500
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
 smart-link flush receive control-vlan 10 password simple huawei-123
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
 smart-link flush receive control-vlan 10 password simple huawei-123
#
return
  • SwitchD的配置文件
cpp 复制代码
#
sysname SwitchD
#
vlan batch 10 100 500
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
 smart-link flush receive control-vlan 10 password simple huawei-123
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 100 500
 stp disable
 smart-link flush receive control-vlan 10 password simple huawei-123
#
return
相关推荐
狼头长啸李树身8 分钟前
眼儿媚·秋雨绵绵窗暗暗
大数据·网络·服务发现·媒体
SizeTheMoment1 小时前
初识HTTP协议
网络·网络协议·http
哲伦贼稳妥2 小时前
一天认识一个硬件之机房地板
运维·网络·经验分享·其他
hgdlip3 小时前
如何快速切换电脑的ip地址
网络·tcp/ip·电脑
程序员-珍5 小时前
虚拟机ip突然看不了了
linux·网络·网络协议·tcp/ip·centos
@海~涛5 小时前
鸿蒙OpenHarmony
华为·harmonyos
4647的码农历程5 小时前
Linux网络编程 -- 网络基础
linux·运维·网络
向李神看齐5 小时前
RTSP协议讲解
网络
Death2006 小时前
使用Qt进行TCP和UDP网络编程
网络·c++·qt·tcp/ip
魏大橙6 小时前
linux RCE本地/公网测试
网络·网络协议·udp