Windows上Kafka创建Topic时zookeeper报Unreasonable length = 308375649错误

在网上搜了半天,全是乱七八糟的答案,没有说明具体的原因,解决方法也不对。记录一下,给各位伙伴避坑

  • 当创建Topic运行以下命令时:

    bin\windows\kafka-topics.bat --create --bootstrap-server localhost:2181 --replication-factor 1 --partitions 1 --topic test

  • 出现zookeeper错误(java.io.IOException: Unreasonable length = 308375649)

    WARN Close of session 0x0 (org.apache.zookeeper.server.NIOServerCnxn)
    java.io.IOException: Unreasonable length = 308375649
    at org.apache.jute.BinaryInputArchive.checkLength(BinaryInputArchive.java:166)
    at org.apache.jute.BinaryInputArchive.readBuffer(BinaryInputArchive.java:127)

  • 分析问题原因:
    因为老版本的 Kafka/Zookeeper 设置与新的设置之间的变化。 在老版本中,我们应该使用 --zookeeper 选项和端口 2181(问题代码);但是,对于新的 Kafka/Zookeeper 版本,用户应默认将端口 9092 用于客户 API 。
    将之前的代码修改为以下代码解决该问题:

    bin\windows\kafka-topics.bat --create --bootstrap-server localhost:9092 --replication-factor 1 --partitions 1 --topic test

相关推荐
小羊没烦恼!3 天前
初探性能优化——2个月到4小时的性能提升
java·开发语言·windows·算法·c#
rockmelodies3 天前
# Windows Server2008 R2 Standard(SP1镜像U盘)重置本地管理员密码【完整详细步骤】
windows·密码破解
kakakahahahaha3 天前
Windows C盘空间不足的安全清理与迁移流程
windows·电脑·笔记本电脑·软件需求·c盘清理
做咩啊~3 天前
远程连接提示:身份验证错误,要求的函数不受支持
windows
Nano叶落3 天前
Kafka 消费积压排查入门:Docker 搭环境亲手制造一次 ‘消息堵死‘,10 分钟看懂 Lag
kafka
百事牛科技3 天前
PPT只读怎么取消?四种情况分别处理
windows·powerpoint
熊明才4 天前
WSL2 网络突然瘫痪(Network is unreachable / 没有 eth0)最短修复指南(2026年9月20日亲测可用)
linux·windows·wsl2
吉甫作诵4 天前
Kafka 集群安装与运维实战:消费组排查、Offset 重置与副本重分配
大数据·运维·分布式·kafka·消息队列
xbzb4 天前
Windows 启动故障修复知识整理:蓝屏 / 无限重启 / 盘符 X / 无 PE 盘
windows
我命由我123454 天前
Mac 操作系统 - 一些使用记录
运维·windows·学习·系统安全·运维开发·mac·学习方法