Oracle11g RAC无法使用VIP或SCAN IP连接数据库的解决方案

在windows客户端sqlplus工具使用VIP或scan的IP无法连接,报错如下:

C:\Users\WJW>sqlplus system/qweasd@192.168.2.200:1521/orcl

SQL*Plus: Release 11.2.0.1.0 Production on Thu May 17 12:35:28 2012

Copyright (c) 1982, 2010, Oracle. All rights reserved.

ERROR:

ORA-12545: Connect failed because target host or object does not exist

检查各组件状态,正常,TNSPING也是通的

原因:

metalink说明:Client is able to resolve all Fully Qualified Domain Name (FQDN) SCAN and VIP name but not short ones(without domain name) as its in different domain;

even though FQDN names were specified during Grid Infrastructure setup, due to bug 9150053 by default DBCA set database parameter local_listener to short node VIP name

while database is created.

因此只要把数据库实例参数local_listener内的host改为vip的IP地址即可

解决办法:

rac1:

SQL> show parameter local_listener

NAME TYPE VALUE


local_listener string (DESCRIPTION=(ADDRESS_LIST=(AD

DRESS=(PROTOCOL=TCP)(HOST=rac1

-vip)(PORT=1521))))

SQL> alter system set local_listener='(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=192.168.2.111)(PORT=1521))))' scope=both sid='orcl1';

SQL> alter system register;

rac2:

SQL> show parameter local_listener

NAME TYPE VALUE


local_listener string (DESCRIPTION=(ADDRESS_LIST=(AD

DRESS=(PROTOCOL=TCP)(HOST=rac2

-vip)(PORT=1521))))

SQL> alter system set local_listener='(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=192.168.2.112)(PORT=1521))))' scope=both sid='orcl2';

SQL> alter system register;

随后使用windows客户端连接成功:

C:\Users\WJW>sqlplus system/qweasd@192.168.2.200:1521/orcl

SQL*Plus: Release 11.2.0.1.0 Production on Thu May 17 13:14:39 2012

Copyright (c) 1982, 2010, Oracle. All rights reserved.

Connected to:

Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - Production

With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,

Data Mining and Real Application Testing options

另外解决Oracle 11gR2 RAC 无法在客户端通过scanIP连接数据库

安装完Oracle 11g rac后,在10g的客户端的 tnsnames.ora中配置好,scanip,但是无法访问,报错为目标主机不存在,折腾了很久,没弄明白,后面查到,系统初始化参数里有local_listener这一项,在这里可以对host的值加以修改,将scanip注册进来、在监听器中使用vip!


在racnode1服务器上:

root@racdb1 \~# su - oracle

oracle@racdb1 \~$ sqlplus /nolog

SQL*Plus: Release 11.2.0.1.0 Production on Wed Apr 21 13:44:12 2010

Copyright (c) 1982, 2009, Oracle. All rights reserved.

SQL> conn /as sysdba

Connected.

SQL> show parameter local_listener;

NAME TYPE VALUE


local_listener string (DESCRIPTION=(ADDRESS_LIST=(AD

DRESS=(PROTOCOL=TCP)(HOST=rac1_vip)(PORT=1521))))

设置

SQL> alter system set local_listener='(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=racscan)(PORT=1521))))' scope=both sid='racdb1';

System altered.

SQL>


节点二上面也是,一样的修改。

相关推荐
我不会插花弄玉4 分钟前
3.通用命令【由浅入深-redis】
数据库·redis·bootstrap
大牧师35 分钟前
Mybatis 框架教程
java·数据库·mybatis·数据持久化·orm
有想法的py工程师1 小时前
PostgreSQL【内核】 CBO 优化器的“早停下注”与数学模型失效分析
数据库·postgresql
冰暮流星2 小时前
sql之计算
数据库·sql
dishugj2 小时前
HANA集群状态监控
数据库·系统架构
小蒜学长3 小时前
基于Java的公司采购系统的设计与实现(代码+数据库+LW)
java·数据库·spring boot·后端·公司采购系统
lee_tianbai3 小时前
Java SSM 电影票预定系统|完整前后端项目,开箱即用(源码分享)
java·开发语言·数据库
SM_YHJ3 小时前
RFID通道门禁与资产台账联动的自动登记技术实现方案
大数据·数据库·人工智能
PaperData3 小时前
2014-2024年省级居民消费结构升级
数据库
砚底藏山河3 小时前
python量化入门:多周期数据对齐统一时间轴
java·数据库·python·金融·maven