记一次Mac端mysql重置密码

在执行mysql命令的时候,报如下的错误,表示不支持mysql命令:

zsh: command not found: mysql

1. 先查看mysql服务是否存在

在系统偏好设置中查看:

2. 发现mysql服务已经在运行,可能因为/usr/local/bin目录下缺失mysql导致

解决方法 :建立软链接

把mysql默认安装目录,比如your-mysql-path/bin/mysql,映射到/usr/local/bin目录下:

复制代码
cd /usr/local/bin
ln -fs /your-mysql-path/bin/mysql mysql
# 其中your-mysql-path是mysql的实际安装路径

要是不知道自己安装目录的,可以通过find / -name mysql 进行查找

3. 再次运行mysql 命令:
复制代码
mysql --version

mysql  Ver 14.14 Distrib 5.7.24, for macos10.14 (x86_64) using  EditLine wrapper

至此mysql 命令不生效的问题已解决

很早之前安装的mysql服务器,忘了密码,此次需要进行重置密码操作
复制代码
bin % mysql -u root -p

\Enter password:

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
密码重置步骤:
  1. 关闭mysql运行服务

./mysql.server stop

或者在系统偏好设置中进行手动关闭

  1. 切换到管理员模式。sudo su 并进行回车

  2. 进入到自己mysql安装目录,可安装上面提到的方式进入,并 执行命令(免密码进入数据库)

./mysqld_safe --skip-grant-tables &

  1. 输入./mysql命令并进行回车,进入到mysql命令模式。

  2. 输入FLUSH PRIVILEGES; 语句,进行回车,进行重新刷新更新内存权限信息

  3. 输入以下命令进行对root用户进行重新设置新密码,并进行回车。

ALTER USER 'root'@'localhost' IDENTIFIED BY '新密码';

至此密码重置已完成,对于有的用户要是还不生效的话,可以对mysql服务进行重启。

相关推荐
Elastic 中国社区官方博客5 小时前
将你自己的密钥用于现有 Elastic Cloud 部署
大数据·数据库·elasticsearch·全文检索
红海云6 小时前
Jev:给智能系统做判断的模型
大数据·数据库·人工智能
wjkjpcba6 小时前
PCBA烧录程序是什么:PCBA包工包料厂家解析烧录与测试
linux·数据库·人工智能·smt贴片加工·pcba贴片加工厂
꯭自꯭闭꯭6 小时前
达梦事物特性及MVCC
linux·运维·数据库
小马同学-7 小时前
MySQL主从复制和读写分离
数据库·mysql
谢亮_vipxieliang7 小时前
Spring 事务失效的常见场景
java·开发语言·数据库·spring boot
海绵宝宝转agent7 小时前
MySql高频面试八股开源笔记总结
mysql·面试·开源
geovindu8 小时前
sql: JSON and XML Data Handling in SQL using sql server 2025
大数据·数据库·sqlserver·数据库开发·数据库架构
IT大白鼠8 小时前
图数据库系列 · 第 02 篇——架构拆解:原生图存储到因果集群
数据库·架构·nosql
余槐i8 小时前
数据没回滚也不报错:@Transactional 自调用失效的 3 种复现与修复
spring boot·mysql·多线程·spring 事务