解决jenkins的Exec command命令不生效,或者执行停不下来的问题

Jenkins构建完后将war包通过 Publish Over SSH 的插件发布到服务器上,在服务器上执行脚本时,脚本中的 nohup 命令无法执行,并不生效,我配置的Exec command命令是后台启动一个war包,并输出日志文件。

nohup java -jar /home/jkapp/jkapp/jkapp.war > /home/jkapp/jkapp/jkapp.log 2>&1

在网上查询资料后,有人说命令前要加上source /etc/profile

source /etc/profile

nohup java -jar /home/jkapp/jkapp/jkapp.war > /home/jkapp/jkapp/jkapp.log 2>&1

加上后,Exec command命令确实可以执行了,但是会造成停止不了的现象,导致jenkins连接超时,error报错。

所以加上source /etc/profile的方法并不正确。

于是我在这里卡了很久的时间。

最终我找到了这个问题的完美解决办法:

那就是在Transfer的高级选项中勾选上Exec in pty

测试结果:

执行成功,问题解决了!

相关推荐
程序员-Benothing11 小时前
Linux系统时间管理:date、timedatectl、NTP、Chrony配置
linux·运维·服务器
迪康Defender12 小时前
终端安全实践:浅谈端点安全管理系统内置终端防火墙能力
运维·服务器·网络·经验分享·安全·php·终端安全管理
AI备忘录12 小时前
(二十二)华为华三锐捷迈普思科 802.1X 端口认证配置命令(网络准入五厂商对照)
运维·服务器·开发语言·网络·安全·华为
优化Henry12 小时前
LTE站点以太网光模块告警处理实践
运维·网络·笔记·学习·信息与通信
智能运维指南12 小时前
一体化运维监控:打破工具孤岛,实现监控运维一体化
运维·嘉为蓝鲸·一体化运维监控·全栈智能可观测中心
明王明王12 小时前
PVE 上用 SPICE:统一连接 Debian、Arch 和 Windows 11 桌面
运维·windows·debian
数字新视界12 小时前
2026机房动环监控选型指南:场景规模需求、市场发展占有率和竞争梯队报告解析
大数据·运维·网络·人工智能·嵌入式硬件·机房动环监控·机房环境安全
咯哦哦哦哦12 小时前
配置VNC sever 6.11.0版本 linux(激活码)
linux·运维·服务器
guo_wen_qiang12 小时前
jenkins流水线参数化配置
运维·docker·容器·jenkins·持续部署
꯭自꯭闭꯭13 小时前
DM主备集群以及读写分离集群搭建
linux·运维·数据库