AcWing 850. Dijkstra求最短路 II

这个跟之前的区别就在于这是一个稀疏图,点的数量会更多点

题目

给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环,所有边权均为非负值。

请你求出 1 号点到 n 号点的最短距离,如果无法从 1 号点走到 n 号点,则输出 −1。

输入格式

第一行包含整数 n 和 m。

接下来 m 行每行包含三个整数 x,y,z表示存在一条从点 x 到点 y 的有向边,边长为 z。

输出格式

输出一个整数,表示 1 号点到 n 号点的最短距离。

如果路径不存在,则输出 −1。

数据范围

1≤n,m≤1.5×10^5

图中涉及边长均不小于 0,且不超过 10000。

数据保证:如果最短路存在,则最短路的长度不超过 109。

输入样例:

3 3
1 2 2
2 3 1
1 3 4

输出样例:

3

代码与解析

java 复制代码
import java.util.*;

/**
 * Dijkstra算法求解最短路径(稀疏图)
 */
public class DijkstraShortestPath {
    static int n, m, idx, N = 1000010;
    static int[] h = new int[N], ne = new int[N], e = new int[N], w = new int[N], dis = new int[N];
    static boolean[] state = new boolean[N];  // 记录结点状态
    static Queue<Integer> q = new LinkedList<>();

    /**
     * 添加边
     *
     * @param a 边的起始结点
     * @param b 边的目标结点
     * @param c 边的权值
     */
    public static void add(int a, int b, int c) {
        e[idx] = b;
        ne[idx] = h[a];
        w[idx] = c;
        h[a] = idx++;
    }

    static class Pair {
        int first, second;

        public Pair(int a, int b) {
            this.first = a;
            this.second = b;
        }
    }

    /**
     * Dijkstra算法求解最短路径
     *
     * @return 最短路径的长度,如果不存在最短路径返回-1
     */
    public static int dijkstra() {
        // 初始化距离数组为无穷大
        Arrays.fill(dis, 0x3f3f3f3f);
        // 起始点距离为0
        dis[1] = 0;

        // 使用优先队列构建小根堆,按照距离值升序排列
        PriorityQueue<Pair> pq = new PriorityQueue<>(Comparator.comparingInt(p -> p.first));
        pq.offer(new Pair(0, 1));

        while (!pq.isEmpty()) {
            Pair p = pq.poll();
            int ver = p.second, distance = p.first;

            // 如果结点已经确定最短路径,继续下一轮循环
            if (state[ver]) continue;

            // 标记结点已访问
            state[ver] = true;

            // 遍历当前结点的邻接结点
            for (int i = h[ver]; i != -1; i = ne[i]) {
                int j = e[i];
                // 松弛操作:更新距离数组中的值
                if (dis[j] > dis[ver] + w[i]) {
                    dis[j] = dis[ver] + w[i];
                    // 将新的距离和结点编号加入优先队列
                    pq.offer(new Pair(dis[j], j));
                }
            }
        }

        // 如果终点的距离仍为初始值,说明不存在最短路径
        return dis[n] == 0x3f3f3f3f ? -1 : dis[n];
    }

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        n = in.nextInt();
        m = in.nextInt();
        // 初始化图的邻接表,每个链表的初始值为无穷大
        Arrays.fill(dis, 0x3f3f3f3f);
        Arrays.fill(h, -1);
        for (int i = 0; i < m; i++) {
            int x = in.nextInt();
            int y = in.nextInt();
            int z = in.nextInt();
            add(x, y, z);
        }
        System.out.println(dijkstra());
    }
}
相关推荐
2401_857610031 小时前
SpringBoot社团管理:安全与维护
spring boot·后端·安全
凌冰_2 小时前
IDEA2023 SpringBoot整合MyBatis(三)
spring boot·后端·mybatis
码农飞飞2 小时前
深入理解Rust的模式匹配
开发语言·后端·rust·模式匹配·解构·结构体和枚举
一个小坑货2 小时前
Rust 的简介
开发语言·后端·rust
monkey_meng2 小时前
【遵守孤儿规则的External trait pattern】
开发语言·后端·rust
Estar.Lee3 小时前
时间操作[计算时间差]免费API接口教程
android·网络·后端·网络协议·tcp/ip
新知图书3 小时前
Rust编程与项目实战-模块std::thread(之一)
开发语言·后端·rust
盛夏绽放4 小时前
Node.js 和 Socket.IO 实现实时通信
前端·后端·websocket·node.js
Ares-Wang4 小时前
Asp.net Core Hosted Service(托管服务) Timer (定时任务)
后端·asp.net
uzong4 小时前
7 年 Java 后端,面试过程踩过的坑,我就不藏着了
java·后端·面试