部署网站时遇到请求出现状态码206,可能是nginx配置问题

在部署网站系统的时候,部分接口出现状态码206,导致功能不能正常使用,经过排查,猜测可能是nginx配置中出现的问题。

目录

一、问题原因

二、解决办法


一、问题原因

当使用Nginx作为代理服务器时,确实存在一个代理缓存区。然而,这个缓存区的默认大小只有几十K,这可能导致某些文件在代理过程中无法完全加载。尤其是在某些版本的Nginx中,默认设置中没有对这种情况进行处理。这不仅限于JS文件,实际上任何类型的文件都可能受到影响。由于框架的JS文件通常较大,因此更容易出现类似的问题。为了解决这个问题,可以考虑对Nginx的缓存区进行优化,或者考虑升级到新版本的Nginx,该版本可能已经对这个问题进行了改进。

二、解决办法

在Nginx.conf文件的http中添加一下代码片段

bash 复制代码
proxy_buffer_size 128k;
proxy_buffers   32 128k;
proxy_busy_buffers_size 128k;

注意事项:如果是使用宝塔面板,直接复制这段代码进去可能会导致报错,原因是因为宝塔面板nginx默认存在一些默认配置,为了避免报错,可以考虑将其conf配置进行注释处理。

相关推荐
Ruiery6 小时前
Linux 6.6内核 CPU 深度解析(七):调度器启动 — 从单核到多核,调度器分阶段点亮
linux·运维·服务器
50万马克的面包6 小时前
CSDN-栈队列数组-知识点整理
linux·运维·服务器
Wang's Blog7 小时前
Java 项目实战: 外卖平台优化-Nginx配置文件结构与块层级
java·开发语言·nginx
MicrosoftCloud7 小时前
用户权限 04|/etc/sudoers 安全配置:从最小授权到「别把 ALL 随便给人」
运维·安全·ubuntu·sudo·sudoers
wjkjpcba7 小时前
PCBA烧录程序是什么:PCBA包工包料厂家解析烧录与测试
linux·数据库·人工智能·smt贴片加工·pcba贴片加工厂
꯭自꯭闭꯭8 小时前
达梦事物特性及MVCC
linux·运维·数据库
亚川楼宇自控系统数据中心厂家9 小时前
实验室智能化管理系统|人环物智一体化管控平台
运维
Lsetea9 小时前
Nginx加载证书时报SSL_CTX_use_PrivateKey_file失败:私钥配对与权限排查
nginx·https·ssl证书·私钥·证书部署
羔羊++10 小时前
18_实验十七_其他命令与自定义启动变量
linux
zmsup11 小时前
Agent 上下文调优:结合 OpsArk 运维智能体,设计模型每一步真正需要的信息
运维·agent·上下文压缩·运维智能体·上下文调优