Git推送大量内容导致http 413错误

Git推送大量内容导致服务端HTTP 413错误

问题描述

使用git push 大量变更内容(超过60M)时报 http 413错误,详细错误信息:

复制代码
Compressing objects: 100% (2907/2907), done.
Writing objects: 100% (6760/6760), 64.18 MiB | 1.18 GiB/s, done.
Total 6760 (delta 2480), reused 6760 (delta 2480), pack-reused 0
error: RPC failed; HTTP 413 curl 22 The requested URL returned error: 413
send-pack: unexpected disconnect while reading sideband packet
fatal: the remote end hung up unexpectedly
Everything up-to-date

原因分析

HTTP 413错误表明请求体太大(Request Entity Too Large),服务器无法处理。这种错误通常与服务器设置有关,限制了可以接受的请求大小。在Git中,如果你尝试推送过大的内容,可能会遇到这个问题。

解决方法

服务端如果配置了Nginx来管理Web请求,则可通过client_max_body_size配置项来设置客户端请求体的大小。参考nginx官网的介绍:

复制代码
Syntax: 	client_max_body_size size;
Default: 	client_max_body_size 1m;
Context: 	http, server, location

Sets the maximum allowed size of the client request body. If the size in a request exceeds the configured value, the 413 (Request Entity Too Large) error is returned to the client. Please be aware that browsers cannot correctly display this error. Setting size to 0 disables checking of client request body size.

如上所述,修改nginx配置,在server节点下,增加:client_max_body_size 100m;,将默认的1m放宽到100m,再执行nginx -s reload重新加载配置文件,问题解决。

当然,也可以主动减少推送文件大小,尝试改为分批推送。

另外,不使用http协议,改为git ssh协议来推送,也可以避免413错误。

参考

相关推荐
吴声子夜歌2 小时前
Nginx应用与运维——Nginx在Kubernetes中的应用(一)
运维·nginx·kubernetes
螺蛳粉 螺蛳粉3 小时前
第一篇:Keepalived 高可用实战:VIP 漂移与 Nginx 主备切换完整指南
运维·nginx·负载均衡·keepalived·高可用
吴声子夜歌3 小时前
Nginx应用与运维——Nginx在Kubernetes中的应用(三)
运维·nginx·kubernetes
吴声子夜歌4 小时前
Nginx应用与运维——Nginx在Kubernetes中的应用(二)
运维·nginx·kubernetes
Wang's Blog13 小时前
Java 项目实战: 外卖平台优化-Nginx配置文件结构与块层级
java·开发语言·nginx
Lsetea16 小时前
Nginx加载证书时报SSL_CTX_use_PrivateKey_file失败:私钥配对与权限排查
nginx·https·ssl证书·私钥·证书部署
吴声子夜歌20 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
Wang's Blog1 天前
Java 项目实战: 外卖平台优化-Nginx六种负载均衡策略对比与选型
java·nginx·负载均衡
吴声子夜歌1 天前
Nginx应用与运维——Nginx监控配置及管理(二)
运维·nginx
挖掘狂人1 天前
Git 从 0 到 1:用一个小项目走完 add / commit / reset / merge / rebase / push
git·后端·github