centos搭建ftp踩坑记录

ftp服务器搭建参考b站视频

第1坑,开放端口后仍然无法连接:

这里不仅需要在防火墙打开20和21端口,还需要打开被动访问所使用的端口,也就是在配置文件vsftpd.conf中指定的被动访问接收端口。

复制代码
pasv_enable=YES
pasv_min_port=40000
pasv_max_port=40080

如果是云服务器,还需要在平台上将平台上的防火墙的这些端口也打开。

第2坑,500 OOPS: vsftpd: refusing to run with writable root inside chroot()

这里是因为ftp的主目录的权限问题,需要改成755(必须)且所有人为root。

参考文章:

  1. Linux中Centos7系统搭建FTP服务详细过程
  2. vsftpd 报错refusing to run with writable root inside chroot
相关推荐
广州浮点FLOATLIC2 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
IT研究所3 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微
BLUcoding3 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK3 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2083 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)3 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter6253 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
zhengqweasd3 小时前
机房托管服务器怎么选硬盘,机械盘和 SSD 托管场景差异
运维·服务器·github
xh didida4 小时前
Linux -- 基础IO
linux·服务器·开发语言·c++