arm服务器上部署kibana

1.首先需要从elasticsearch对应的kibana版本(arm)

​​​​​​Download Kibana Free | Get Started Now | Elastic

注意:选平台时切勿选错,linux aarch64,并选择elasticsearch对应的历史版本

2.可以通过rz命令上传压缩包至 linux 服务器进行解压,存放路径建议和es放在一起,好找。

tar -zxvf kibana-7.13.2-linux-aarch64.tar.gz

3.修改配置信息

4.添加用户,修改权限(这里启动不能使用root启动),需要创建一个用户,并赋权;

#添加用户

useradd es

#授权 我们直接把整个文件夹的权限授予

chown -R es:es kibana-7.13.2

5.启动kibana

cd /opt/software/kibana-7.13.2/bin

前台启动

./kibana

后台启动(2>&1将标准输出流和错误输出流都输出到kibana.log)

nohup ./kibana > /opt/software/kibana-7.13.2/kibana.log 2>&1 &

6.如果防火墙没关闭的需要开放端口

开发端口

sudo firewall-cmd --zone=public --add-port=5601/tcp --permanent

重启防火墙服务

sudo systemctl restart firewalld.service

重新加载防火墙

sudo firewall-cmd --reload

查看端口是否开放

sudo firewall-cmd --list-ports

问题报错

(1)启动kibana报错

问题描述:

errorsavedobjects-service Unable to retrieve version information from Elasticsearch nodes.

原因分析:

es在启动时设置了密码开启了安全验证,导致kibana没访问到,取消安全验证就可让kibana找到es.

解决方法:

修改配置,添加账号和密码信息.

elasticsearch.username: "kibana_system"

elasticsearch.password: "pass"

相关推荐
见闻小天地3 分钟前
空调机房赛莱默B&G冷冻泵/冷却泵的核心技术特性分析
大数据·运维·数据库
JWASX23 分钟前
【agent 开发】Agent 智能体
大数据·人工智能·python
copilot中国版1 小时前
从关账到报表,Copilot 帮财务搭建标准化管理体系
大数据
T06205141 小时前
【数据集】地级市市场分割指数和市场一体化指数数据(2001-2024年)
大数据
幼儿园蛋小黄1 小时前
从设备树到 ARM 驱动:嵌入式 Linux 驱动开发学习总结
linux·arm开发·驱动开发
FPGA信号处理1 小时前
【电磁大数据理论与算法】第四课:电磁感知
大数据
问商十三载12 小时前
AI引擎生成式优化实践:刑事辩护律师团队IP构建
大数据·人工智能
会议咨询13 小时前
2026年大数据、信息系统与智能通信国际会议(BDIIC 2026)
大数据·信息系统·智能通信
Raas10013 小时前
MAI Gateway(魔芋企业级AI网关)能力解析:AI网关能做故障转移吗?AI网关核心功能详解
大数据·人工智能·网关·ai·gateway·mai gateway
IT研究所14 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微