DataGrip 连接 Centos MySql失败

  1. 首先检查Mysql是否运行:
    systemctl status mysqld , 如果显示没有启动则需要启动mysql

  2. 检查防火墙是否打开,是否打开3306的端口
    sudo firewall-cmd --list-all

    如果下面3306没有打开则打开3306端口

    public
    target: default
    icmp-block-inversion: no
    interfaces:
    sources:
    services: dhcpv6-client ssh
    ports: 3306/tcp
    protocols:
    masquerade: no
    forward-ports:
    source-ports:
    icmp-blocks:
    rich rules:

sudo firewall-cmd --zone=public --add-port=3306/tcp --permanent 如果添加成功则显示success

  1. 本地测试是否能够连接成功 telnet ip 3306 显示连接实现但是ping ip可以成功

  2. 后来想到这事一个云服务器,可能和网页设置的入站规则有关系

  3. 打开腾讯云的出入站规则设置发现没有打开3306端口,打开端口

  4. 重新使用telnet连接成功。

  5. 使用datagrip登录,test connection 成功

相关推荐
FYKJ_201027 分钟前
SSM校园失物招领系统41452-计算机课程设计、毕业设计
java·vue.js·spring boot·python·mysql·typescript·spark
哭泣方源炼蛊1 小时前
正则表达式c++内容汇集
数据库·c++·mysql·正则表达式
shdkfbbv1 小时前
【无标题】
linux·运维·服务器
周洲08302 小时前
STM32片内Flash读写深度详解|掉电参数保存、底层原理
linux·前端·stm32
shimly1234562 小时前
比 find + grep 更好用的 nm + addr2line
linux
迷途之人不知返2 小时前
【进程控制】-3-进程等待
linux
_upupup3 小时前
包管理器和vim
linux·服务器
一颗小树x3 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级
不恋水的雨3 小时前
gbase中union all导致末尾多出空格的坑
数据库·sql·mysql
_smart_boy__3 小时前
I.MX6U开发板Uboot无法ping Ubuntu问题解决方案(二)
linux·运维·ubuntu