413 Request Entity Too Large

413 Request Entity Too Large

问题描述:测试环境附件上传报错,如图

原因:nginx默认上传文件的大小是1M

解决方案:修改nginx配置

1.打开nginx配置文件 nginx.conf,路径一般是:/etc/nginx/nginx.conf

2.在http{}段中加入 client_max_body_size 20m;20m为允许最大上传的大小

3.保存后重启nginx,问题解决

步骤2如图

相关推荐
步行cgn1 小时前
Spring c 命名空间注入详解
java·后端·spring
明月_清风1 小时前
Maven 到底是什么?一篇文章搞懂 Java 项目构建与依赖管理
java·后端·maven
aramae2 小时前
MySQL复合查询(8)
java·c语言·开发语言·后端·算法
Rain的Java大神之路2 小时前
如何快速上传10G文件
java·spring boot·redis·后端·mysql·spring cloud·面试
Wang's Blog3 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog3 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
Ivanqhz3 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
qq_2518364574 小时前
springboot vue3 开发实现 拼豆管理系统
java·开发语言·ai编程
caoerzhong4 小时前
JeeWMS 开源仓库管理系统全景解读:一套 Java WMS 如何把 WMS/OMS/BMS/TMS 装进同一个系统
java·开源
曹牧5 小时前
Java集合框架:List、ArrayList、Map 和 HashMap
java