docker opensearch arm64 运行失败解决方案

opensearch版本

2.1.0

docker日志错误信息:

Disabling execution of install_demo_configuration.sh for OpenSearch Security Plugin

Enabling OpenSearch Security Plugin

Killing opensearch process 10

OpenSearch exited with code 143

Performance analyzer exited with code 1

opensearch日志错误信息:

uintx InitialCodeCacheSize=4096 is outside the allowed range 65536 ... 18446744073709551615

Improperly specified VM option 'InitialCodeCacheSize=4096'

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

解决方案

折腾了一上午,修改InitialCodeCacheSize参数、修改jvm参数、修改opensearch文件的参数都没效果。

最后直接升级2.12.0,运行正常了

相关推荐
姜鱼问生3 小时前
docker exec 排查容器问题:从日志到进程
运维·网络·数据库·docker·容器
人生百态,人生如梦4 小时前
Ubuntu在低版本下使用ccswitch+claudecode(CCSwitch+Docker+Claude)连调教程
linux·ubuntu·docker·claudecode·ccswitch
程序员老赵4 小时前
Docker 部署 OpenViking:轻松搭建 AI Agent 上下文数据库平台
docker·开源·agent
吴声子夜歌5 小时前
Docker入门与实战——高级镜像构建
docker
坐看风云变幻6 小时前
Betaflight 开发环境搭建保姆级教程(Ubuntu / Windows+WSL / Docker 三方案 + 官方网址大全)
windows·ubuntu·docker·无人机·飞控·betaflight
零基础1236 小时前
Docker 部署实战:从入门到精通
docker·容器
Lvan的前端笔记7 小时前
docker:基于docker的前端部署方案
前端·docker·状态模式
承渊政道7 小时前
自建服务越来越多怎么管理?Docker部署Flare,搭一个自己的数字入口
运维·docker·容器·内网穿透·cpolar·nas·flare
龙腾-虎跃8 小时前
Docker 一键启动服务合集:Redis、MySQL、Kafka、MinIO、Prometheus 等(网盘转存防失效)
redis·mysql·docker·kafka·prometheus·小龙虾·miniio
芷栀夏8 小时前
极空间部署Photopea:Docker运行、网页修图与多设备使用
运维·docker·容器