Nginx请求upstream timed out 错误时通常会尝试重新请求上游服务器(504 Gateway Timeout)

重新记录一下这个重复的nginx请求的问题:

背景

一个导出报表任务,下载报表时,发生了导出超时:504 Gateway Timeout的错误。

504 Gateway Timeout的原因如下:

  1. Nginx配置问题 :检查您的Nginx配置是否正确。确保Nginx已经正确地重新加载了新的配置。您可以使用nginx -t命令来测试Nginx配置文件的语法是否正确,然后使用nginx -s reload重新加载配置。
  2. Nginx日志 :查看Nginx的访问日志和错误日志,以了解请求是否到达Nginx服务器,以及Nginx服务器是否有任何错误。这些日志通常位于/var/log/nginx/目录下。
  3. 上游服务器响应缓慢:如果Nginx的上游服务器(例如您的应用程序服务器)响应缓慢或者无响应,也会导致504错误。您可以通过直接访问上游服务器来测试它是否正常工作。
  4. 网络问题:网络问题也可能导致504错误。确保网络连接畅通,没有防火墙或者代理服务器的限制。
  5. 资源不足:如果上游服务器资源不足,也可能导致504错误。您需要检查上游服务器的资源利用情况,确保它有足够的资源来处理请求。

原因

而我发生这个错误,是因为上游服务器响应多次超时导致的。 因为 Nginx 在遇到 upstream timed out 错误时通常会尝试重新发送请求,也就是会重放原先的请求到上游服务器。

Nginx 有一些相关的配置选项可以用来控制重试行为,其中包括:

  • proxy_connect_timeout:用于设置连接超时时间,即 Nginx 等待与上游服务器建立连接的最长时间。
  • proxy_send_timeout:用于设置向上游服务器发送请求的超时时间。
  • proxy_read_timeout:用于设置从上游服务器读取响应的超时时间。
  • proxy_next_upstream:用于设置出现错误时 Nginx 应该尝试下一个上游服务器的策略。

您可以在 Nginx 配置文件中设置这些选项,以便根据您的需求来调整 Nginx 对上游服务器的请求超时和重试行为。

例如,以下是一个简单的配置示例:

nginx.conf 复制代码
location / {
    proxy_pass http://backend;
    proxy_connect_timeout 5s;
    proxy_send_timeout 10s;
    proxy_read_timeout 20s;
    proxy_next_upstream error timeout;
}

如果你没有设置这些配置值的话,Nginx的默认超时配置值可以根据不同的版本和发行版而有所不同。以下是一些常见的默认超时配置值:

  • proxy_connect_timeout:默认为60秒。
  • proxy_send_timeout:默认为60秒。
  • proxy_read_timeout:默认为60秒。

解决

对接口直接加缓存,就可以避免第二次重放请求时,覆盖了第一次的请求所写的文件。

相关推荐
长安米粒贵几秒前
缓存明明加了,为什么数据还是不一致?聊聊 4 个容易忽略的边界
后端
传人2 分钟前
悬停旋转放大和位移效果如何写
前端·javascript·css
yunwei374 分钟前
eBPF 开发实践:使用 eBPF 隐藏进程或文件信息
linux·后端·性能优化
高频因子挖掘机5 分钟前
行情监控脚本重启后,怎样快速恢复而不重复拉取数据?
后端·github·api
aleafboat7 分钟前
只管去写(day2) 用claude分析老项目技术栈
后端
vx_Biye_Design13 分钟前
springboot宠物领养与救助平台64334-计算机课程设计、毕业设计
java·vue.js·spring boot·后端·mysql·课程设计·宠物
用户77139702070616 分钟前
.NET 依赖注入入门
后端
量化分析码农22 分钟前
【Python量化系统工程实战 #03】任务跑挂了没人知道?用 60 行代码搭一套「监控 + 邮件 + 桌面推送」告警系统
后端
0+11125 分钟前
Linux --进程间关系和守护进程
linux·运维·服务器
柠檬味拥抱26 分钟前
基于YOLOv8的电梯内电瓶车检测识别(中英文双版) | 附完整源码与效果演示
后端