小白学习U盘安装centos系统(二):安装系统

前言

  • 主板:华硕z390-a
  • 无线网

设置启动顺序

  1. 进入BIOS,按F7进入高级设置
  2. 修改启动项启动顺序,将U盘放在第一个启动

3. 保存并退出

重启会自动进入U盘启动盘

安装centos

  1. 进入安装页面 报错 modprobe: ERROR: could not insert 'floppy' ......

安装过程中很可能遇到报错 modprobe: ERROR: could not insert 'floppy'

出现错误不是操作系统的问题,你以为机器装不上这个Centos7,换成Centos8就可以了? 不是的,一样会报这个错 误(别问我怎么知道的)

出现的原因是安装引导程序找不到安装镜像了,事实上是找不到自己的U盘是哪个设备了。这很奇怪,引导程序都加载>了,但是他忘了自己从哪来的了,需要我们手动告诉他。

  1. 重启计算机,重新进入安装界面,不要选择安装系统
  2. 按E键,进入命令编辑模式

初始编辑时是这样的(没有拍清楚不好意思)

4. 将第一行核心命令改一下

ini 复制代码
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=CentoS\x207\x20x\86_64 rd.live.check quiet # 原始命令
# 改为
linuxefi /images/pxeboot/vmlinuz initrd=initrd.img linux dd quiet # 新命令
  1. 此时按下 ctrl+X 开始安装系统 还是安装不成功,不过此时会显示我们的磁盘信息: 可以看到,我们插入的U盘设备名称为 sdb4
  2. 再次重启,编辑命令
ini 复制代码
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=CentoS\x207\x20x\86_64 rd.live.check quiet # 原始命令
# 改为
linuxefi /images/pxeboot/vmlinuz initrd=initrd.img inst.stage2=hd:/dev/sdb4 quiet # 新命令

此时即可正常进入界面进行系统安装 7. 自定义安装位置

  • 我有两块硬盘,一块是固态盘,一块是机械盘,都选上,然后选中我要配置分区
  • 点击下面的加号,然后新增/boot挂载点,分配容量200,单位默认为MiB
  • 新增/boot/efi挂载点,分配容器200
  • 新增swap挂载点,分配容量4096
  • 新增/挂载点,分配容量50 GiB
  • 新增/data挂载点,分配剩余容量,不填即可,设备类型选择LVM

备注:如果不配置/boot挂载点,会导致每次重启都要先进一下BIOS,才能进入系统

  • 点击完成,会提示是否创建分区,接受更改即可
  1. 网络和主机名 因为我是把台式机直接改成了linux服务器,所以这里一定要连,否则无法上网。
  2. 安装系统 如果需要修改root密码,可以点击ROOT密码进行修改。安装完重启
相关推荐
跨境小彭2 小时前
Temu拉美站点铺货实操复盘:手动复制痛点与批量自动化解决方案
服务器·人工智能·搜索引擎·自动化·temu电商运营
心之语歌2 小时前
Tkinter 画布基本梳理
运维·服务器·python
温暖小土5 小时前
CentOS 部署 Milvus 向量数据库完整指南
centos·ai编程·milvus·向量数据库
Fcy6485 小时前
Linux下 进程间关系与守护进程
linux·运维·服务器·守护进程
g10565591396 小时前
公有云_云运维服务
java·运维·服务器
well06126 小时前
Linux粘滞位与Makefile机制深度解析
linux·运维·服务器
再写一行代码就下班6 小时前
linux sh脚本在windows修改导致无法使用解决方式
java·linux·centos
hzxpaipai6 小时前
杭州企业官网怎么建设?从策划到上线的5步建站方法
运维·服务器·前端·网络
smartpi_ai6 小时前
通用脱机烧录器为什么烧不进 CI-03?下载协议的门槛、免唤醒 10 条的建议值属性
服务器·网络·ci/cd
2501_937860947 小时前
中篇:TCP 为什么可靠又高效?滑动窗口、流量控制、拥塞控制与粘包全解析
服务器·网络·tcp/ip