Redis:报错Creating Server TCP listening socket *:6379: bind: No error

错误:

window下启动redis服务报错:

Creating Server TCP listening socket *:6379: bind: No error

原因:

端口6379已被绑定,应该是因为上次未关闭服务

解决:

①依次输入命令:

  • redis-cli.exe
    (启动Redis客户端,连接本机(127.0.0.1)的6379端口 开启redis服务)
  • shutdown
  • exit

②启动Redis服务:redis-server.exe redis.windows.conf

【配置完服务后启动服务命令 redis-server --service-start 关闭服务redis-server --service-stop】

相关推荐
饺子大魔王的男人16 小时前
Redis 内存和连接异常怎么排查?用 redis_exporter 搭一套可远程抓取的监控链路
数据库·redis·bootstrap
夕除17 小时前
redis--RDB AOF
数据库·redis·缓存
夕除19 小时前
redis--UV
redis
ShineWinsu21 小时前
对于Redis:Redis的认识以及分布式系统的解析
linux·数据库·c++·redis·缓存·消息队列·分布式架构
Wang's Blog1 天前
Java 项目实战: 外卖平台优化-使用Redis作为缓存产品与TTL配置
java·redis·缓存
一只旭宝1 天前
【C++复习】四种类型转换 + 常见设计模式 + Redis/MySQL(后端面试复习完整版)
c++·redis·笔记·mysql·设计模式
ShineWinsu1 天前
对于Redis:Redis特性以及应用场景的解析
linux·c++·redis·缓存·高并发·分布式系统·key-value
羑悻的小杀马特1 天前
Docker高阶实战:从Redis集群到C++微服务,全面解析镜像优化与生产环境部署+镜像制作常见问题详解
c++·redis·docker·镜像制作·dockefile
程序猿乐锅1 天前
【黑马点评 | 第八篇】Redisson分布式锁
java·数据库·spring boot·redis·分布式·spring·缓存
阿狗童鞋2 天前
Redis实战指南
数据库·redis·缓存