Nginx莫名奇妙返回了404

描述

nginx作为反向代理,代理python的服务,但是通过代理访问服务的时候,报了404的错误。

难受的是客户现场没有查看日志的权限,只有查看配置文件的权限,我们检测了几遍配置文件也没有找到问题,哎~

问题引起的原因

原因是nginx后面的服务处理很慢,超过proxy_read_timeout, 此时应该报一个504的错误,也就是返回50x.html

关键点来了, 50x.html文件不存在,此时就返回404了。

相关推荐
AKA__Zas1 小时前
TCP 与 IP 浅显皮毛
服务器·网络·tcp/ip
夜听莺儿鸣8 小时前
502-002_Linux驱动开发模块化编程
linux·驱动开发·模块化编程
wuminyu9 小时前
C++协程实现接收端的零拷贝Buffer管理原理剖析
java·linux·c语言·jvm·c++
程序员清风9 小时前
Docker、Nginx 与 Kubernetes 部署 AI 后端服务
nginx·docker·kubernetes
科力锐品牌君10 小时前
应用级灾备 | 海量非结构化数据如何实现高效数据保护
linux·运维·网络·安全·系统安全·数据安全·灾备
zhangrelay10 小时前
ROS项目设计案例智能大模型正经乱答案例
linux·笔记·学习·ubuntu·机器人
流浪00111 小时前
Linux系统篇39——线程(四) pthread库的由来和线程的创建与等待
linux·操作系统·线程·pthread库
Lancker11 小时前
chnroute-linux — 中国大陆 IP 段每日自动更新 + 「仅允许国内访问」落地
linux·运维·tcp/ip
辻弋20111 小时前
【无标题】
大数据·服务器·前端·搜索引擎·开源软件
高山有多高11 小时前
【Linux笔记】Linux进程与守护进程
linux