http实现post请求时本地没问题,线上报413错误、nginx配置免费https、nginx反向代理


错误原因

前端发送请求以后后端没有收到请求
而客户端却报了413错误
是请求实体过大的异常
如果请求夹带着文件就可能造成请求实体过大
那这里是什么原因造成的呢
在基础的后端开发中
都会用到nginx反向代理
默认大小为1M
超过1M都会造成请求无法发送到服务器的SpringBoot项目中
所以需要对nginx进行设置


解决

首先,要cd到nginx的配置文件的文件夹下

bash 复制代码
# 进入配置页面
vim nginx.conf
# 然后敲击i键进入可写模式
# 在配置文件中的http框中加入
# 这里的大小可以根据实际情况自定义
client_max_body_size 20M;
# 键盘敲击:进入命令行模式
# 退出并保存
wq

然后重启服务,cd到sbin文件夹下

bash 复制代码
#重启nginx服务
./ nginx -s reload

这样就解决咯!


其他方式

方式一

上传文件失败,报上面的错:请求实体太大。
原因:nginx有个参数client_max_body_size在限制请求实体的大小,把它改大点就好了。
{如果配置文件没有这个参数,应该会在系统里有个默认的值}
1.打开nginx配置文件 nginx.conf, 路径一般是:/etc/nginx/nginx.conf。
2.在http{}段中加入 client_max_body_size 20m,20m为允许上传的最大值,可自己决定多大。
3.保存后重启nginx。


方式二

知乎上的一篇文章。


关于nginx的文章

Nginx配置免费HTTPS详细教程

相关推荐
Lvan的前端笔记3 小时前
docker:每个前端项目一个 Nginx 容器还是只有一个Nginx容器
前端·nginx·docker
姜鱼问生3 小时前
Nginx 缓存命中率监控:从 X-Cache-Status 到实时统计
运维·nginx·缓存
发光小北3 小时前
四路can转WIFI在现场应用中有什么问题?
网络协议
Apipi*3 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
不像程序员的程序媛4 小时前
检测网络的命令mtr详解
网络
天启HTTP4 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
运维行者_4 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
此时不提桶,更待何时5 小时前
06-14-A-Kafka集群运维与迁移实战详解
运维·kafka
hz567896 小时前
涉密视频会议设备配置指南:终端、音视频采集与配套设施选型
服务器·网络·数据库·安全·实时音视频·信息与通信·智能硬件
优橙教育7 小时前
零基础学AI应用开发要多久?3个月能到什么水平
服务器·开发语言·网络·php