http实现post请求时本地没问题,线上报413错误、nginx配置免费https、nginx反向代理


错误原因

前端发送请求以后后端没有收到请求
而客户端却报了413错误
是请求实体过大的异常
如果请求夹带着文件就可能造成请求实体过大
那这里是什么原因造成的呢
在基础的后端开发中
都会用到nginx反向代理
默认大小为1M
超过1M都会造成请求无法发送到服务器的SpringBoot项目中
所以需要对nginx进行设置


解决

首先,要cd到nginx的配置文件的文件夹下

bash 复制代码
# 进入配置页面
vim nginx.conf
# 然后敲击i键进入可写模式
# 在配置文件中的http框中加入
# 这里的大小可以根据实际情况自定义
client_max_body_size 20M;
# 键盘敲击:进入命令行模式
# 退出并保存
wq

然后重启服务,cd到sbin文件夹下

bash 复制代码
#重启nginx服务
./ nginx -s reload

这样就解决咯!


其他方式

方式一

上传文件失败,报上面的错:请求实体太大。
原因:nginx有个参数client_max_body_size在限制请求实体的大小,把它改大点就好了。
{如果配置文件没有这个参数,应该会在系统里有个默认的值}
1.打开nginx配置文件 nginx.conf, 路径一般是:/etc/nginx/nginx.conf。
2.在http{}段中加入 client_max_body_size 20m,20m为允许上传的最大值,可自己决定多大。
3.保存后重启nginx。


方式二

知乎上的一篇文章。


关于nginx的文章

Nginx配置免费HTTPS详细教程

相关推荐
虎头金猫4 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特4 天前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
AI职业加油站4 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
wuyk5554 天前
《WiFi 嵌入式物联网开发全套实战》| 第 16 章 ESP32 AP+STA 双模共存原理与工程坑点
网络·stm32·物联网
此冬歌咏4 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
xing-xing4 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅4 天前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren4 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
XUEYUAN52124 天前
ASN 自治系统号风控:平台如何通过 IP 所属自治域批量识别代理流量
python·网络协议·http·网络安全·socks5
其实防守也摸鱼4 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透