http实现post请求时本地没问题,线上报413错误、nginx配置免费https、nginx反向代理


错误原因

前端发送请求以后后端没有收到请求
而客户端却报了413错误
是请求实体过大的异常
如果请求夹带着文件就可能造成请求实体过大
那这里是什么原因造成的呢
在基础的后端开发中
都会用到nginx反向代理
默认大小为1M
超过1M都会造成请求无法发送到服务器的SpringBoot项目中
所以需要对nginx进行设置


解决

首先,要cd到nginx的配置文件的文件夹下

bash 复制代码
# 进入配置页面
vim nginx.conf
# 然后敲击i键进入可写模式
# 在配置文件中的http框中加入
# 这里的大小可以根据实际情况自定义
client_max_body_size 20M;
# 键盘敲击:进入命令行模式
# 退出并保存
wq

然后重启服务,cd到sbin文件夹下

bash 复制代码
#重启nginx服务
./ nginx -s reload

这样就解决咯!


其他方式

方式一

上传文件失败,报上面的错:请求实体太大。
原因:nginx有个参数client_max_body_size在限制请求实体的大小,把它改大点就好了。
{如果配置文件没有这个参数,应该会在系统里有个默认的值}
1.打开nginx配置文件 nginx.conf, 路径一般是:/etc/nginx/nginx.conf。
2.在http{}段中加入 client_max_body_size 20m,20m为允许上传的最大值,可自己决定多大。
3.保存后重启nginx。


方式二

知乎上的一篇文章。


关于nginx的文章

Nginx配置免费HTTPS详细教程

相关推荐
hz5678923 分钟前
涉密视频会议设备配置指南:终端、音视频采集与配套设施选型
服务器·网络·数据库·安全·实时音视频·信息与通信·智能硬件
优橙教育32 分钟前
零基础学AI应用开发要多久?3个月能到什么水平
服务器·开发语言·网络·php
IT研究所1 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微
AIgorithmGEEK1 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2081 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)1 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter6251 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
zhengqweasd1 小时前
机房托管服务器怎么选硬盘,机械盘和 SSD 托管场景差异
运维·服务器·github
心易行者3 小时前
Agent应用+API端点商业化进阶实战:从单体智能体到可付费调用的API全流程
运维·服务器·人工智能·python·apache