nginx开启目录索引搭建文件服务器

目录索引

ngx_http_autoindex_module 模块可以支持目录列表浏览,开启方式

复制代码
location / {
    autoindex on;
}

开启后就可以通过浏览器访问目录下的文件列表并且可以下载,像很多镜像资源站一样。可以文件浏览下载。这时候如果对某个目录不是所有用户可以访问下载,则可以使用ngx_http_auth_basic_module 模块开启限制资源访问。需要输入用户名密码认证获取范围权限。

用户认证

开启配置

复制代码
location / {
    auth_basic           "closed site";
    auth_basic_user_file conf/htpasswd;
}

auth_basic_user_file文件指定认证的用户密码。用户密码可以依赖 "htpasswd" 命令生成。

安装http tools

复制代码
yum -y install httpd-tools

htpasswd命令生成认证文件

复制代码
# htpasswd -bc 文件名 用户名 密码 
#-c 创建文件 -b 命令行指定密码,不用确认框
htpasswd -bc htpasswd test 123456

生成的密码文件内容

复制代码
test:$apr1$nk.CIrS7$eHHqORaeDBTVltMKsD6u/.

最终的nginx配置

复制代码
location /authfile/ {
  #指定文件目录
  alias /data/html/authfile/;
  #开启目录索引
  autoindex on;
  #使用服务器时间
  autoindex_localtime on;
  #是否精确显示文件大小
  autoindex_exact_size off;
  #开启auth_basic 参数随便指定一个名称,默认是off不开启
  auth_basic "authfile";
  #用户认证文件
  auth_basic_user_file /etc/nginx/htpasswd;
}

这时访问 /authfile/ 浏览器就会弹出用户名和密码输入框,输入正确后才会展示目录索引列表内容。

下载限速

对于稍微大一点的文件,为了避免一个用户下载导致占用带宽过大,影像其它用户操作,可以配置文件下载时限制下载速度。设置方法如下:

复制代码
location /download/ {
	root D:/tmp/;
	limit_rate 50k; #每秒下载速度
	limit_rate_after 2m;#超过2m后开始限速
}
相关推荐
Zhou14113617 分钟前
Docker_03_DockerCompose多容器编排
运维·docker·容器
北京中科新远科技19 分钟前
AI网卡五层检查法:协议、PCIe、NUMA、端口与验收
服务器·网络·人工智能
shdkfbbv19 分钟前
【无标题】
linux·运维·服务器
wp123_130 分钟前
TLVR 电感在 AI 服务器电源中的应用与市场前景分析
服务器·人工智能·科技·ai·硬件工程
ycvv2 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
_upupup2 小时前
包管理器和vim
linux·服务器
ESDWAN2 小时前
SD-WAN 企业选型与落地指南:从链路测试到网络架构设计
运维·网络·架构
一颗小树x2 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级
啊哈一半醒2 小时前
Docker 底层知识:从 Namespace 到 UnionFS
运维·docker·容器
_smart_boy__2 小时前
I.MX6U开发板Uboot无法ping Ubuntu问题解决方案(二)
linux·运维·ubuntu