Centos 报错 One of the configured repositories failed

目录预览


一、问题描述

使用yum update更新命令就出现下面问题,系统是刚安装的,然后修改了一下IP变成手动。(排查问题前,先回顾自己做了哪些操作,方便进一步排错),然后就出现了以下代码(部分):

复制代码
One of the configured repositories failed (CentOS-7 - Updates),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=updates ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable updates
        or
            subscription-manager repos --disable=updates

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=updates.skip_if_unavailable=true

二、原因分析

通过对自己步骤的分析(设置为DHCP可以正常,设置手动就报错),可以确定是我修改IP不正确导致的。

设置手动IP的时候:

  • 想都没想就将网关设置254了
  • 并且DNS没有修改成手动,后面发现就是这2个问题。

其他原因见参考链接。


三、解决方案

  1. 进入图形化界面
  2. 修改IP和DNS

    这里需要注意的是gateway的设置,不是192.168.189.254,而是VMware中nat网卡的网关地址:
  • 打开VM中编辑里的虚拟网络编辑器点击NAT设置:
  • NAT设置中就可以看到网关IP
  • 然后关闭DNS的自动,设置为8.8.8.8(其他也可以)。设置完成后,点击应用(Apply),然后将右上角的网断开连接,再连接就可以了。我们可以在终端ping一下看看可不可以上网就欧克啦。

四、参考链接

  1. CentOS7 执行yum 命令报错 One of the configured repositories failed (Unknown)

  2. centos7使用图形界面设置网络IP和DNS(VM)中

如能帮你解决问题,请点赞收藏评论,帮助更多的人解决问题。

相关推荐
再写一行代码就下班21 分钟前
linux sh脚本在windows修改导致无法使用解决方式
java·linux·centos
daemon.qiang11 天前
国内虚拟机对接 Freedesktop:Fork xserver、自建 Runner 与提交 MR 实战
linux·ubuntu·centos·gitlab·开源软件
lqg_zone11 天前
CentOS 7 虚拟机磁盘 I/O 卡顿排查实录:从 iostat 异常到虚拟盘后端故障的完整定位
linux·服务器·mysql·centos
江屿风12 天前
【Linux系统】【Linux进程终止等待详解与程序替换机制初体验】流食般投喂
linux·运维·笔记·系统架构·centos·unix
螺蛳粉 螺蛳粉12 天前
CentOS 7.9 自建 Yum 源服务器搭建指南
linux·服务器·centos
小小的木头人12 天前
CentOS 7 下 Nginx 访问自定义目录报 403 的完整排查:从端口权限到 SELinux
nginx·centos
蜡台14 天前
VirtualBox Centos8 配置互联网访问和局域网访问
centos·虚拟机·vbox
闲云野鹤在人间15 天前
Docker入门|第3章 镜像详解
linux·网络·docker·容器·centos·云计算·php
闲云野鹤在人间16 天前
Docker入门|第1章 容器生态系统完整解析
运维·服务器·docker·容器·centos
Meta3917 天前
cenots8安装docker
docker·容器·centos