centos7 修改mysql的datadir流程

旧目录:/var/lib/mysql/

新目录:/data/mysqlData/

1、先将 cp my.cnf /etc/my.cnf 然后再yum install mysql-community-server开始安装mysql...

(第一次安装的话,一般只执行第一步就可以了)

2、修改datadir 的值

3、创建新目录

4、删除旧目录: rm -rf /var/lib/mysql/

5、赋予新目录权限: sudo chown -R mysql:mysql /data/mysqlData/

6、控制台执行 mysqld --initialize --console 进行初始化

7、启动

8、若启动失败,查看 cat /var/log/mysqld.log 日志

相关推荐
李白客29 分钟前
数据融合平台怎么选:批流一体、实时同步与数据质量的 7 个维度
数据库·数据库架构
数据库小学妹41 分钟前
MySQL库存扣减实战:原子UPDATE、分桶方案与锁范围分析
数据库·后端·mysql
旺仔不是程序员42 分钟前
LIMIT 1:PostgreSQL 只取一行的高效查询姿势
数据库·后端·sql
烟沙九洲2 小时前
Redis 缓存穿透、缓存击穿、缓存雪崩
数据库·redis
Elastic 中国社区官方博客2 小时前
jina-ocr-v1:在低成本 GPU 上实现更快速的文档解析
大数据·数据库·elasticsearch·搜索引擎·全文检索·jina
Linux-lucky2 小时前
39-41-Linux学习之旅之redis缓存基础与NFS基础
linux·运维·mysql·ubuntu
于平安2 小时前
MySQL-变量,流程控制与游标
数据库·mysql
我滴老baby2 小时前
检索的上限,在切块时就定了:一次〈民法典〉实测,看懂 ChatDOC 的“上下文检索”
数据库·全文检索·文档处理
Databend2 小时前
Jev 爆火之后,我们把它集成进了数据湖仓
大数据·数据库·agent