centos7 修改mysql的datadir流程

旧目录:/var/lib/mysql/

新目录:/data/mysqlData/

1、先将 cp my.cnf /etc/my.cnf 然后再yum install mysql-community-server开始安装mysql...

(第一次安装的话,一般只执行第一步就可以了)

2、修改datadir 的值

3、创建新目录

4、删除旧目录: rm -rf /var/lib/mysql/

5、赋予新目录权限: sudo chown -R mysql:mysql /data/mysqlData/

6、控制台执行 mysqld --initialize --console 进行初始化

7、启动

8、若启动失败,查看 cat /var/log/mysqld.log 日志

相关推荐
ToddyBear22 分钟前
云厂商技术支持部门的原话:元数据库删了,我们也恢复不了[特殊字符]
数据库·产品运营
IanSkunk1 小时前
从检查设备到训练方案:眼科与视光中心设备联动的数据通路、字段口径与校验规则
服务器·数据库·负载均衡
ShineWinsu1 小时前
对于Redis:事务的解析
数据库·redis·mysql·缓存·面试·事务·acid
ao-weilai3 小时前
MySQL数据库:内置函数
android·数据库·mysql
LaughingZhu3 小时前
Product Hunt 每日热榜 | 2026-10-02
数据库·人工智能·深度学习·神经网络·搜索引擎
天疆说3 小时前
腾讯会议 Linux 版在 NVIDIA 显卡上看不到画面:EGL 像素配置与窗口视觉不匹配的排查与修复
linux·数据库·腾讯会议
2603_969579284 小时前
中小团队数据库选型:MySQL vs PostgreSQL,业务场景怎么选
数据库·mysql·postgresql
IT大白鼠4 小时前
图数据库系列 · 第 06 篇——避坑汇总:经典生产问题
数据库·nosql·图库数据库
江湖有缘4 小时前
3开源Sqlite数据库管理工具整理合集,可Docker一键部署!
数据库·sqlite·开源