centos7 修改mysql的datadir流程

旧目录:/var/lib/mysql/

新目录:/data/mysqlData/

1、先将 cp my.cnf /etc/my.cnf 然后再yum install mysql-community-server开始安装mysql...

(第一次安装的话,一般只执行第一步就可以了)

2、修改datadir 的值

3、创建新目录

4、删除旧目录: rm -rf /var/lib/mysql/

5、赋予新目录权限: sudo chown -R mysql:mysql /data/mysqlData/

6、控制台执行 mysqld --initialize --console 进行初始化

7、启动

8、若启动失败,查看 cat /var/log/mysqld.log 日志

相关推荐
IvorySQL7 小时前
PostgreSQL 日报|修复截断 zstd 备份检测(10 月 9 日)
数据库·postgresql
刘胡子大叔7 小时前
SQL 脚本的导入顺序
数据库·sql
代码什么用7 小时前
Spring对IoC的实现
数据库·spring
hz567899 小时前
涉密视频会议设备配置指南:终端、音视频采集与配套设施选型
服务器·网络·数据库·安全·实时音视频·信息与通信·智能硬件
广州浮点FLOATLIC9 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
程序员Sunday10 小时前
MySQL 为什么使用 B+ 树索引?把范围查询、回表和覆盖索引连起来
数据库·mysql
半杯咖啡半行码10 小时前
Qt开发实战:数据库、MV 模式、QProcess与串口通信全攻略
数据库·qt
Yyyyyy~10 小时前
[ Mysql ] 库的操作
mysql
小米里的大麦10 小时前
16 MySQL 事务
数据库·mysql
西柚小萌新10 小时前
【LLM&&AI应用开发 八股文】--4.3.Agent智能体(下)
java·开发语言·数据库