成功解决7版本的数据库导入 8版本数据库脚本报错问题

我 | 在这里

⭐ 全栈开发攻城狮、全网10W+粉丝、2022博客之星后端领域Top1、专家博主。

🎓擅长 指导毕设 | 论文指导 | 系统开发 | 毕业答辩 | 系统讲解等。已指导60+位同学顺利毕业

✈️个人公众号:热爱技术的小郑 。回复 Java全套视频教程 或 前端全套视频教程 即可获取 300G+ 教程资料,以及大量毕设项目源码。

🐬专注干货知识分享、项目实战案例开发分享

🚪 传送门:Github毕设源码仓库

文章目录

前言

  在使用可视化操作工具Navicate运行数据库脚本的时候 报的错误:Unknown collation: 'utf8mb4_0900_ai_ci'

  解释:这个错误通常是因为你的 MySQL 数据库版本不支持 utf8mb4_0900_ai_ci 排序规则。在 MySQL 5.7 之前,utf8mb4_0900_ai_ci 排序规则并不存在,因此如果你在更低版本的 MySQL 中尝试使用这个排序规则,就会遇到这个错误。

解决办法

  • 1、升级 MySQL 版本:如果可能,升级你的 MySQL 到 8.0 版本或更高,因为这些版本原生支持 utf8mb4_0900_ai_ci。

  • 2、更改排序规则:如果不能升级 MySQL,考虑将排序规则改为 utf8mb4_general_ci 或 utf8mb4_unicode_ci,它们在较老的 MySQL 版本中被广泛支持。

  你可以修改 SQL 脚本,或者在导入数据时进行全局替换。以下是如何进行替换的示例:【建议使用编辑本对脚本进行全局替换,方便快捷】

复制代码
ALTER TABLE your_table_name CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

  或者在 SQL 文件中,将所有 utf8mb4_0900_ai_ci 替换为 utf8mb4_unicode_ci。

  • 3、修改导入脚本:如果是在导入脚本中出现问题,可以手动编辑该脚本,将 utf8mb4_0900_ai_ci 替换为适合你当前 MySQL 版本的排序规则。

修改前执行脚本报错

修改后执行脚本成功

注意

  重点看 CHARSET 和 COLLATE 设置的是否符合当前数据库版本

相关推荐
写后端的胖头鱼11 小时前
【高频面试题】FullText 全文索引(MySQL)
数据库·mysql·索引·全文索引
路远的数据库笔记11 小时前
SQL Server迁移国产数据库怎么做?九套口岸库零停机割接实战
数据库·经验分享·sqlserver·dba
樱花落木兰11 小时前
分布式登录实战:Session 会话共享改造,Redis 存储用户登录状态
java·javascript·数据库·redis·分布式·缓存
kaiyou202612 小时前
用户研究岗秋招,统计分析能力怎么学习和证明?
数据库·python·学习
mjhcsp12 小时前
DeepSeek V4.1 Flash 批量处理效能实测
java·前端·数据库
ShineWinsu12 小时前
对于Redis:Steam、Geospatial、Hyperloglog、Bitmap、Bitfield类型的解析
数据库·c++·redis·分布式·缓存·面试·zset
lie..12 小时前
30天从零开始学AI应用开发(Day 17):ChromaDB 上手:给本地文档建一个“外挂大脑”
数据库·人工智能·oracle
code_whiter13 小时前
01-MySQL数据库基础
数据库·mysql
weixin_3823952313 小时前
本地部署 ERP 选型记录:从 Excel 到轻量系统的这几年
数据库·人工智能·数据挖掘
2401_8914092614 小时前
期货量化用得上的几类行情数据:逐笔、Level2、分钟线和五档tick
数据库