helm安装jenkins保姆级别

一、创建nfs服务器

这一步跳过、自行百度
注意:要给共享目录赋予权限chmod一下,不然到时候容器没办法在目录里面创建文件,初始化时候会报错误代码2

二、添加Jenkins的Helm仓库

yaml 复制代码
helm repo add jenkinsci https://charts.jenkins.io
helm repo update

三、设置自己的jenkins配置

powershell 复制代码
sudo vim /usr/local/software/jenkins/myvalues.yaml

这里不要安装插件,要安装等jenkins安装成功的时候再自己安装,不然初始化会报错误代码1,查看日志默认插件地址访问不了外网

yaml 复制代码
controller:
  JCasC:
    enabled: true
    configScripts:
      welcome-message: |
        jenkins:
          systemMessage: "Welcome to Jenkins on Kubernetes with Helm"
  installPlugins: []
  serviceType: NodePort
  nodePort: 32000

设置pv存储不然项目会报没有存储的地方

vim /usr/local/software/pv_pvc/my-pv.yaml

yaml 复制代码
apiVersion: v1
kind: PersistentVolume
metadata:
  name: jenkins
spec:
  capacity:
    storage: 8Gi
  accessModes:
    - ReadWriteOnce
  nfs:
    path: /usr/local/software/nfs_share
    server: ip                                

四、执行安装

为了简单,我喜欢一把梭哈,执行执行这4条命令,相当于直接重新启动

powershell 复制代码
helm uninstall jenkins -n jenkins
kubectl delete pv jenkins
helm install jenkins /usr/local/software/jenkins/jenkins  --namespace jenkins -f /usr/local/software/jenkins/myvalues.yaml
kubectl apply -f /usr/local/software/pv_pvc/my-pv.yaml

启动成功

五、通过32000登录jenkins修改登录方式,并创建账号,默认是谁都可以操作

保存后会弹出个页面,让你创建账号,自己创建吧

六、修改插件地址

http://mirror.xmission.com/jenkins/updates/update-center.json

点击submit

然后再重启jenkins,就可以安装插件了,不重启,会报错

相关推荐
吴声子夜歌2 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng2 小时前
NRPE 添加命令(一)
linux·运维·服务器
pt10432 小时前
CML网络仿真入门-2:使用CML模拟网络实验环境
运维·网络协议
沫璃染墨3 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
HAHAXX84 小时前
电商RPA批量上架通用方案:一套流程如何同时跑通拼多多、抖店、淘宝和跨境平台
java·运维·rpa
零基础1234 小时前
LLM Agent 驱动的物模型构建:从设备手册到边缘接入的自动化实践
运维·人工智能·经验分享·python·自动化
程序猿老A5 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器
Ruiery6 小时前
Linux 6.6内核 CPU 深度解析(九):时钟与 TSC — 内核怎么从 PIT/HPET 切到 TSC
linux·运维·服务器
吴声子夜歌6 小时前
Nginx应用与运维——Nginx监控配置及管理(二)
运维·nginx
吴声子夜歌7 小时前
Nginx应用与运维——Nginx日志管理
java·运维·nginx