helm安装jenkins保姆级别

一、创建nfs服务器

这一步跳过、自行百度
注意:要给共享目录赋予权限chmod一下,不然到时候容器没办法在目录里面创建文件,初始化时候会报错误代码2

二、添加Jenkins的Helm仓库

yaml 复制代码
helm repo add jenkinsci https://charts.jenkins.io
helm repo update

三、设置自己的jenkins配置

powershell 复制代码
sudo vim /usr/local/software/jenkins/myvalues.yaml

这里不要安装插件,要安装等jenkins安装成功的时候再自己安装,不然初始化会报错误代码1,查看日志默认插件地址访问不了外网

yaml 复制代码
controller:
  JCasC:
    enabled: true
    configScripts:
      welcome-message: |
        jenkins:
          systemMessage: "Welcome to Jenkins on Kubernetes with Helm"
  installPlugins: []
  serviceType: NodePort
  nodePort: 32000

设置pv存储不然项目会报没有存储的地方

vim /usr/local/software/pv_pvc/my-pv.yaml

yaml 复制代码
apiVersion: v1
kind: PersistentVolume
metadata:
  name: jenkins
spec:
  capacity:
    storage: 8Gi
  accessModes:
    - ReadWriteOnce
  nfs:
    path: /usr/local/software/nfs_share
    server: ip                                

四、执行安装

为了简单,我喜欢一把梭哈,执行执行这4条命令,相当于直接重新启动

powershell 复制代码
helm uninstall jenkins -n jenkins
kubectl delete pv jenkins
helm install jenkins /usr/local/software/jenkins/jenkins  --namespace jenkins -f /usr/local/software/jenkins/myvalues.yaml
kubectl apply -f /usr/local/software/pv_pvc/my-pv.yaml

启动成功

五、通过32000登录jenkins修改登录方式,并创建账号,默认是谁都可以操作

保存后会弹出个页面,让你创建账号,自己创建吧

六、修改插件地址

http://mirror.xmission.com/jenkins/updates/update-center.json

点击submit

然后再重启jenkins,就可以安装插件了,不重启,会报错

相关推荐
姜鱼问生2 小时前
Nginx 缓存命中率监控:从 X-Cache-Status 到实时统计
运维·nginx·缓存
Apipi*2 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
运维行者_3 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
此时不提桶,更待何时4 小时前
06-14-A-Kafka集群运维与迁移实战详解
运维·kafka
IT研究所6 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微
AIgorithmGEEK6 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2086 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)6 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter6256 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
zhengqweasd6 小时前
机房托管服务器怎么选硬盘,机械盘和 SSD 托管场景差异
运维·服务器·github