服务器死机/无故宕机排查思路/服务器起不来

1、查看服务器型号

dmidecode -t system

dmidecode | grep 'Product Name'

2、风扇异响:查看BMC,坏了一个风扇其他的所有的风扇会全速转。

3、服务器亮红灯

红灯就是 故障告警 不一定是啥··需要查看BMC口日志。这种就是看bmc日志·· 会有打印的

-问题现象:服务器系统盘亮红灯

-问题原因:系统盘磁盘脚线损坏(系统盘做了raid 1)

-解决方案:①服务器器无法通过control + R进入raid卡页面,通过bios进入可以查看raid情况,显示Need Attention。更换磁盘,磁盘自动重构raid。红灯变黄灯再变绿灯,重构完成,业务恢复正常。

在这里插入图片描述

4、死机问题:

1、确认bmc日志;是否有硬件异常告警;硬件导致死机。

2、查看/var/log/message 日志; 搜关键字command line 是开机时打印,往前即为死机前日志。;

3、主节点optimizi-memory.sh会打印内存回收,若看到每分钟都有drop_caches日志,那说明是内存不足导致死机。 确认该节点部署服务数是否合理、是否技战法导致内存占用问题。

4、未确认的死机问题;需要收集 /var/log/message* 及 /var/log/sa/ 下所有日志,打包保存。

5、重启看系统启动报错。能否进入系统。

messages文件在/var/log/下

/var/log/messages:几乎所有的开机系统发生的错误都会在此记录。

例如:

我的/var/log/下的messages日志文件有

ll|grep messages

-rw------- 1 root root 150 May 17 03:20 messages

-rw------- 1 root root 1396 Apr 25 23:48 messages-20150426

-rw------- 1 root root 1017 Apr 28 17:16 messages-20150503

-rw------- 1 root root 2786 May 6 17:15 messages-20150510

-rw------- 1 root root 972 May 17 01:02 messages-20150517

根据你的需要查看相应的日志

关键字:Command line

还可以看 /usr/kib/cloudmanager/components/lark/log/opt.log

5、自检不通过

可能原因:

①卡内存自检不通过,把内存拔插下

相关推荐
夜之眷属41 分钟前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
极客先躯44 分钟前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图
传人1 小时前
为什么 Xshell 中可以通过java -version查询到java 版本号码,Electerm 却查不到?
java·linux·服务器
韩振方1 小时前
为什么服务显示占了 8G,实际内存却没那么多?
运维
陌上花开缓缓归以2 小时前
mebdlts3.4.1安全启动全流程
服务器·算法
鬼手点金2 小时前
opencode-全能开发者配置
java·linux·服务器·前端·javascript·学习·前向传播
xixiaoyunya2 小时前
虚拟机备份怎么做:镜像级与文件级搭配的完整实操方案
linux·运维·网络
阿明62 小时前
进程替换【Linux】
linux·运维·服务器
sunoo-2292 小时前
【嵌入式Linux驱动学习】Day1-Day2 全流程梳理:环境搭建→U-Boot→内核→根文件系统→驱动基础
linux·运维·驱动开发·笔记·学习·阿里云·恩智浦
YonyouHRSaaS3 小时前
从安全、信创、运维三方面看,人力资源管理系统哪种部署方式更适合企业HR?
运维·安全·hr系统·人力资源管理系统·hr saas·人事管理系统