服务器死机/无故宕机排查思路/服务器起不来

1、查看服务器型号

dmidecode -t system

dmidecode | grep 'Product Name'

2、风扇异响:查看BMC,坏了一个风扇其他的所有的风扇会全速转。

3、服务器亮红灯

红灯就是 故障告警 不一定是啥··需要查看BMC口日志。这种就是看bmc日志·· 会有打印的

-问题现象:服务器系统盘亮红灯

-问题原因:系统盘磁盘脚线损坏(系统盘做了raid 1)

-解决方案:①服务器器无法通过control + R进入raid卡页面,通过bios进入可以查看raid情况,显示Need Attention。更换磁盘,磁盘自动重构raid。红灯变黄灯再变绿灯,重构完成,业务恢复正常。

在这里插入图片描述

4、死机问题:

1、确认bmc日志;是否有硬件异常告警;硬件导致死机。

2、查看/var/log/message 日志; 搜关键字command line 是开机时打印,往前即为死机前日志。;

3、主节点optimizi-memory.sh会打印内存回收,若看到每分钟都有drop_caches日志,那说明是内存不足导致死机。 确认该节点部署服务数是否合理、是否技战法导致内存占用问题。

4、未确认的死机问题;需要收集 /var/log/message* 及 /var/log/sa/ 下所有日志,打包保存。

5、重启看系统启动报错。能否进入系统。

messages文件在/var/log/下

/var/log/messages:几乎所有的开机系统发生的错误都会在此记录。

例如:

我的/var/log/下的messages日志文件有

ll|grep messages

-rw------- 1 root root 150 May 17 03:20 messages

-rw------- 1 root root 1396 Apr 25 23:48 messages-20150426

-rw------- 1 root root 1017 Apr 28 17:16 messages-20150503

-rw------- 1 root root 2786 May 6 17:15 messages-20150510

-rw------- 1 root root 972 May 17 01:02 messages-20150517

根据你的需要查看相应的日志

关键字:Command line

还可以看 /usr/kib/cloudmanager/components/lark/log/opt.log

5、自检不通过

可能原因:

①卡内存自检不通过,把内存拔插下

相关推荐
蓝速科技3 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz3 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese4 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky4 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南5 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123455 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人5 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender5 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
Wang's Blog6 小时前
Java 项目实战: 外卖平台-删除分类的关联校验与自定义业务异常
java·服务器·项目开发
zly35006 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器