ORA-03137: TTC 协议内部错误

ORA-03137: TTC 协议内部错误,突然收到线上项目告警,系统宕机不能使用了,排查之后发现数据库服务宕机了,手动重启后服务器启动了,通过查看分析数据库日志发现ORA-03137: TTC 协议内部错误


1.问题描述

Oracle数据库宕机,查看数据库日志,报错: ORA-03137: TTC 协议内部错误: 3120 \[\] \[\] \[\] \[\] \[\] \[\] \[\]


2.问题原因

此报错源于oracle 11.2.0.1其中一个bug。


3.解决方法:

1、禁用Bind Peeking

sql 复制代码
#登录
sqlplus / as sysdba
#禁用
alter system set "_optim_peek_user_binds"=false;

2、将程序使用的JDBC DRIVER升级到11.2.0.2

3、使用数据库版本11.2.0.3及以上,弃用Oracle 11.2.0.1

此bug已在11.2.0.3以上版本修复,可升级此版本或更高


4.案例总结:

如果是生产环境,建议先使用禁用Bind Peeking方案,保证数据可用,之后做数据库升级。

如果是其他非生产环境,建议直接升级oracle数据库版本

相关推荐
赵渝强老师33 分钟前
【赵渝强老师】崖山数据库的数据库文件
数据库·国产数据库·yashandb·崖山数据库
做运维的阿瑞35 分钟前
多表查询基础:INNER JOIN、LEFT JOIN、RIGHT JOIN
数据库·sql·mysql·算法
IvorySQL1 小时前
PostgreSQL 日报 | 可见性映射数据损坏修复(9 月 26 日)
数据库·postgresql
Seraphina361 小时前
DVWA(SQL注入-low,medium,XSS反射-low)
前端·数据库·笔记·sql·网络安全·web·xss
CHEEVEN_QY1 小时前
搅拌摩擦焊FSW工艺参数对焊缝成形影响的实验研究10.1
linux·服务器·数据库
帷幕落秋2 小时前
Redis哨兵模式
运维·数据库
ly76892 小时前
Redis 主从复制全解析:从 PSYNC 协议到复制积压缓冲区的故障切换边界
java·数据库·redis·主从复制·故障切换·psync
夜雪一千2 小时前
MySQL 中什么是条件注释
数据库·mysql
可乐鸡翅yeah_2 小时前
AES‑128 加密 M3U8,IV 初始化向量新手容易踩坑
前端·网络·数据库·ffmpeg·音视频·m3u8在线
IvorySQL3 小时前
PostgreSQL 日报| relchecks 溢出导致表无法删除(9 月 28 日)
数据库·人工智能·ai·postgresql·区块链