使用zabbix监控k8s

一、 参考文献

小阿轩yx-案例:Zabbix监控kubernetes云原生环境
手把手教你实现zabbix对Kubernetes的监控

二、部署经验

关于zabbix监控k8s,总体来说是分为两块内容,一是在k8s集群部署zabbix-agent和zabbix- proxy。二是在zabbix进行配置。

1.在k8s上部署zabbix的agent和proxy组件

部署组件是通过helm进行部署的。如果集群没有装helm则需要先安装helm。步骤较为简单。

wget https://get.helm.sh/helm-v3.8.1-linux-amd64.tar.gz ##此处可以更改版本,如wget https://get.helm.sh/helm-v3.8.1-linux-amd64.tar.gz

tar -zxvf helm-v3.8.1-linux-amd64.tar.gz

cp linux-amd64/helm /usr/local/bin/helm

接下来就是使用chart包部署组件。
chart包下载地址

此处可以自己选择zabbix版本。我的是6.4版本。进入之后会显示包,自己根据自己的k8s版本选择,我的k8s版本是1.17的,很老的版本,所以选的chart也比较老,是6.0目录下的1.0.0版本的。如果选很新的,在部署的时候会报错。

这个地方不用非得用命令去下载,直接浏览器下载下来就行。

解压,然后修改里面的values.yaml文件。

主要是这两个文件。修改里面的镜像仓库地址和tag。

修改以下三个镜像的地址和tag。因为我是内网部署,所以先提前把镜像下载好了。


改完之后,使用

bash 复制代码
helm lint 你的chart包目录
helm package 你的chart包目录  #会生成一个tgz的包
helm install 你的tgz的包   #此处helm命令也可以参考其他方式

部署完之后,kubectl get pod,svc -n 你的命名空间

可以看到相关的pod:

zabbix-agent-xxxx

zabbix-kube-state-metrics-xxxx-xxxx

zabbix-proxy-xxx-xxx

2.zabbix上的相关配置

参考上述文章

出现的问题

1.kube-state-metrics给定的cpu和内存太小,导致容器一直重启,OOMKILLED。解决方案:增大内存即可。

2、zabbix上配置完成后,报错,获取node失败。发现是因为

bash 复制代码
kubectl get secret zabbix-service-account -n monitoring -o jsonpath={.data.token} | base64 -d

这行代码获取的值不对。重新更新了一次就好了。

三级标题

四级标题
五级标题
六级标题
相关推荐
bloglin9999914 小时前
vmware部署centos7启动docker容器后无法访问服务
运维·docker·容器
weixin_4445793014 小时前
Containerd
容器·k8s
AutumnWind042018 小时前
【Docker Compose 快速入门】
运维·docker·容器
如果'\'真能转义说21 小时前
Docker Desktop | 本地化挂载 Postgresql
docker·postgresql·容器
谢亮_vipxieliang21 小时前
从 Docker 到 Kubernetes:概念对照与迁移
docker·容器·kubernetes
怪力左手1 天前
docker+qemu创建镜像
运维·docker·容器
筑梦之路1 天前
K8S yaml文件部署kafka集群(Kraft模式)——筑梦之路
容器·kafka·kubernetes
极小狐1 天前
CI 作业里 kubectl 连不上集群?用 Kubernetes Agent 打通部署链路的 7 个步骤
ci/cd·kubernetes·gitlab·devops·k8s部署
站在墙头上1 天前
ubantu安装docker
docker·容器