修复docker启动失败:Failed to start Docker Application Container Engine

配置了镜像源之后,运行sudo systemctl restart docker.service失败,提示让运行systemctl status docker.service或journalctl -xeu docker.service查看详细信息。

运行后者发现有如下日志:

  • 红色区域是我设置的一个镜像源
  • 这个日志的意思就是不支持这样的协议,需要在前面加上https://
    加上之后重新systemctl restart docker.service启动成功。

【以下可以不看,仅作记录】

排查过程中,有博客提到当磁盘空间不足的时候也可能启动失败,此时可通过在/etc/docker/daemon.json中添加如下字段限制docker容器所占的空间,但其实这两个字段已经不被docker 27.3.1支持了,添加了之后反而会导致docker服务启动失败

json 复制代码
    "storage-driver": "devicemapper",
    "storage-opts": [
        "dm.basesize=10G"
    ]
相关推荐
灯澜忆梦10 小时前
【minio】#1 | 简介与安装
docker·对象存储·minio
江湖有缘19 小时前
3款开源绘图工具整理合集,可Docker一键部署!
docker·容器·开源
TTATTC20 小时前
告别协议选型内耗:深入拆解微服务“内部 gRPC + 边界 REST”混合通信架构与 Envoy 转码实战
docker·开源
小匠石钧知1 天前
06_在k8s集群中安装MetalLB实现LoadBalancer
云原生·容器·kubernetes·service·loadbalancer·metallb
光依旧2 天前
PageIndex没翻车,翻车的是我的解析器
docker·langchain·大模型·向量数据库·pdf解析·rag·pageindex
谢亮_vipxieliang2 天前
容器排障实战手册:从日志到内核的分层排障
docker·云原生·容器·eureka
梦想不只是梦与想2 天前
Docker 常用命令
docker
wzq11_6662 天前
Kubernetes集群——Pod篇
云原生·容器·kubernetes
wzq11_6662 天前
Kubernetes集群——命令篇
云原生·容器·kubernetes
小白的码BUG之路2 天前
Docker -- 构建ruoyi-gateway镜像
docker·容器·gateway