修复docker启动失败:Failed to start Docker Application Container Engine

配置了镜像源之后,运行sudo systemctl restart docker.service失败,提示让运行systemctl status docker.service或journalctl -xeu docker.service查看详细信息。

运行后者发现有如下日志:

  • 红色区域是我设置的一个镜像源
  • 这个日志的意思就是不支持这样的协议,需要在前面加上https://
    加上之后重新systemctl restart docker.service启动成功。

【以下可以不看,仅作记录】

排查过程中,有博客提到当磁盘空间不足的时候也可能启动失败,此时可通过在/etc/docker/daemon.json中添加如下字段限制docker容器所占的空间,但其实这两个字段已经不被docker 27.3.1支持了,添加了之后反而会导致docker服务启动失败

json 复制代码
    "storage-driver": "devicemapper",
    "storage-opts": [
        "dm.basesize=10G"
    ]
相关推荐
程序员清风9 小时前
Docker、Nginx 与 Kubernetes 部署 AI 后端服务
nginx·docker·kubernetes
Zhu75810 小时前
离线二进制部署-Kubernetes-v1.36.4
容器·贪心算法·kubernetes
谢亮_vipxieliang11 小时前
镜像安全:扫描、签名与软件供应链
安全·docker
天衍四九-12 小时前
Docker容器实战系列(八):Docker生产最佳实践与避坑指南,系列终章
运维·docker·容器
Zhou14113613 小时前
Docker_03_DockerCompose多容器编排
运维·docker·容器
啊哈一半醒15 小时前
Docker 底层知识:从 Namespace 到 UnionFS
运维·docker·容器
fruge18 小时前
飞牛OS部署Flare导航页:Docker Compose、YAML书签配置与cpolar公网访问
运维·docker·容器
Zhou14113618 小时前
Docker_02_Dockerfile与存储网络
网络·docker·容器
guo_wen_qiang21 小时前
云服务器elasticsearch环境搭建-单台
运维·elasticsearch·容器
码上上班21 小时前
k8s知识点总结
云原生·容器·kubernetes