单节点calico性能优化

在单节点上部署calicov3273后,发现资源占用

修改calico以下配置是资源消耗降低

1、因为是单节点,没有跨节点pod网段组网需要,禁用overlay方式网络(ipip,vxlan),使用route方式网络

配置calico-node的环境变量

复制代码
CALICO_IPV4POOL_IPIP: Never
CALICO_IPV4POOL_VXLAN: Never
CALICO_IPV6POOL_VXLAN: Never
FELIX_IPINIPENABLED: false
FELIX_VXLANENABLED: false

参考

Troubleshoot eBPF mode | Calico Documentation (tigera.io)

2、节点使用XDP加速hostendpoint之间通信,但是是单节点,没有必要,而且环境中单节点一直报XDP的错误

failed to wipe the XDP state error=failed to load BPF program (/usr/lib/calico/bpf/filter.o): stat /sys/fs/bpf/calico/xdp/prefilter_v1_calico_tmp_A: no such file or directory

因此,禁用XDP。

复制代码
FELIX_XDPENABLE: false
FELIX_BPFENABLED: false #禁用bpf,默认为false,可以不用配置

参考

Configuring Felix | Calico Documentation (tigera.io)

Kind XDP disabled for dev environment by jayunit100 · Pull Request #3017 · projectcalico/calico (github.com)

3、设置calico_backend: bird为calico_backend: vxlan(在calico部署文件中configmap中配置),节省资源消耗(没有overlay网络不需要bird)

参考

Customize Calico configuration | Calico Documentation (tigera.io)

Comment out the line - -bird-ready and - -bird-live from the calico/node readiness/liveness check (otherwise disabling BIRD will cause the readiness/liveness check to fail on every node)

至此,部署的calico性能消耗明显降低,如下图所示

相关推荐
陈陈CHENCHEN18 小时前
【Kubernetes】纯 IPv6 K8s 集群访问外部 IPv4 服务
云原生·容器·kubernetes
troy12819 小时前
如何在谷歌云(Google Cloud)上部署 Kubernetes 集群
云原生·容器·kubernetes
程序员清风1 天前
Docker、Nginx 与 Kubernetes 部署 AI 后端服务
nginx·docker·kubernetes
Zhu7581 天前
离线二进制部署-Kubernetes-v1.36.4
容器·贪心算法·kubernetes
程序猿阿越1 天前
containerd如何拉取镜像
后端·kubernetes·源码阅读
Elastic 中国社区官方博客1 天前
Kubernetes attributes processor v1:它对 EDOT Collector 意味着什么
java·大数据·elasticsearch·搜索引擎·贪心算法·kubernetes·全文检索
bllovepigpig2 天前
操作系统个人学习笔记(四):K8s基础
笔记·学习·kubernetes
键盘鼓手苏苏2 天前
ESLint 规则渐进式升级:从 0 警告到全面开启的迁移策略(续篇)
云原生·kubernetes·k8
码上上班2 天前
k8s知识点总结
云原生·容器·kubernetes
谢亮_vipxieliang3 天前
从 Docker 到 Kubernetes:概念对照与迁移
docker·容器·kubernetes