Centos7使用yum工具出现 Could not resolve host: mirrorlist.centos.org

在 CentOS 7 中使用 yum 工具时,出现 "Could not resolve host: mirrorlist.centos.org" 的错误,一般情况是因为默认的镜像源无法访问。

以下是一些常用的解决方法:

检查网络连接 :首先使用 ping 命令测试网络连接是否正常。如果 ping mirrorlist.centos.org 不通,但 ping www.baidu.com 正常,说明 DNS 解析没问题,基本确认是 yum 源的问题

更换镜像源:可以切换到其他镜像源,如阿里云镜像源。

以下是更换为阿里云镜像源的步骤

1、先备份原有的 yum 配置文件、先备份原有的 yum 配置文件、先备份原有的 yum 配置文件

复制代码
mv /etc/yum.repos.d/CentOS-Base.repo /etc/yum.repos.d/CentOS-Base.repo.bak

2、下载阿里云 yum 配置文件

复制代码
curl -o /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-7.repo

3、清除缓存并生成新的缓存

复制代码
yum clean all
yum makecache

4、更新系统

复制代码
yum -y update
相关推荐
云杂项1 分钟前
tmux指南:安装、配置与高效使用(Ubuntu上)
linux·服务器·ubuntu
YOLO数据集集合7 分钟前
风机叶片表面损伤检测数据集 | 风机叶片 表面损伤 污渍检测 无人机巡检 风电运维9119期
运维·人工智能·计算机视觉·目标跟踪·无人机·智慧城市·电力巡检
j7~21 分钟前
【Linux网络编程】四十七.《Linux IO 模型详解:阻塞 IO、非阻塞 IO 与 IO 多路转接(select)》
linux·运维·网络·select·非阻塞io·阻塞io·i/o多路连接
分布式存储与RustFS43 分钟前
用RustFS给Harbor当S3存储后端
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
GeW1 小时前
智能工厂背后:Linux在跑,数据库在扛,高端制造在加速
linux
泡海椒1 小时前
趋势分析报表:jquick-pdf折线图PDF生成实战
java·大数据·运维·服务器·前端·pdf
qq_394562001 小时前
【在Linux上升级nginx】
linux·服务器·nginx
丸子君君1 小时前
【以麒麟服务器时间为准,定时请求时间同步】
运维·服务器·单片机
海盗12341 小时前
AI 新闻日报 2026-09-28:正确性审查自动化、7×24 个人智能体、具身部署态
运维·人工智能·机器人·自动化·人工智能aigc
元岳数字人小元2 小时前
数字人源码系统:模块化开发赋能智能场景灵活迭代升级
运维·人工智能·开源·人机交互·交互