docker-compose 配置nginx

前言

前端打包的dist文件在宿主机,nginx运行在docker-compose

问题

nginx.conf 在本地配置可以生效,但是链接到容器就报错

基于本地的nginx运行,本地nginx.conf 如下

复制代码
server {
    listen 8081;
    location / {
        root /usr/local/software/testweb/dist; # 指向你的Vue应用解压后的目录,宿主机目录
        try_files $uri $uri/ /index.html; # 尝试直接找到文件,如果找不到则回退到index.html(Vue路由需要)
    }

}

基于容器运行,映射到容器的nginx.conf配置如下

复制代码
server {
    listen 80;
    root /usr/share/nginx/html; #容器内的地址
    location / {
        try_files $uri $uri/ /index.html; # 尝试直接找到文件,如果找不到则回退到index.html(Vue路由需要)
    }

}

容器内部目录截图如下

容器的docker-compose配置如下

复制代码
version: '3.8'
services:
  nginx:
    image: nginx:latest
    ports:
    volumes:
      - /usr/local/software/dist:/usr/share/nginx/html 
这里是将前面的本地dist路径,挂载到容器,然后上面的nginx.conf 的 root /usr/share/nginx/html; 容器内的地址,才会生效
相关推荐
虎头金猫4 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特4 天前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
分布式存储与RustFS4 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
玉&心4 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing4 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
赵文宇(温玉)4 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang4 天前
上传本地镜像到harbor中
docker·容器·持续部署
羑悻的小杀马特4 天前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作
BianHuanShiZhe4 天前
docker常见命令
docker
正经教主4 天前
【FDE系列】阶段2:Day 43:Docker Compose — 多容器一键编排
人工智能·docker·fde