BGP联邦实验

一.需求

1.AS1存在两个环回,一个地址为192.168.1.0/24,该地址不能再任何协议中宣告

AS3存在两个环回,一个地址为192.168.2.0/24,该地址不能再任何协议中宣告

AS1还有一个环回地址为10.1.1.0/24,AS3另一个环回地址是11.1.1.0/24

最终要求这两个环回可以互相通讯。

2.整个AS2的IP地址为172.16.0.0/16

3.AS间的骨干链路Ip地址随意分配

4.使用BGP协议让整个网络所有设备的环回可以互相访问

5.减少路由条目数量,避免环路出现

完成上图内容,使用联邦+反射器

二.需求分析

1.AS1 和 AS3 各有一个特定环回地址禁止宣告,另一个环回地址需实现互通

2.AS2 需使用 172.16.0.0/16 进行 IP 地址规划​

3.AS 间骨干链路 IP 自主分配,保证链路互联互通且地址不冲突。​

4.利用 BGP 协议,通过联邦和反射器实现全网设备环回地址相互访问。​

5.减少路由条目数量,通过合适的 BGP 机制和策略,避免网络出现环路。

三.配置

R1

复制代码
[r1]interface GigabitEthernet 0/0/0
[r1-GigabitEthernet0/0/0]ip address 172.16.16.1 30
[r1]interface LoopBack 0    
[r1-LoopBack0]ip address 192.168.1.1 24
[r1]interface LoopBack 1
[r1-LoopBack1]ip address 10.1.1.1 24
[r1]bgp 1
[r1-bgp]router-id 10.1.1.1 
[r1-bgp]peer 172.16.16.2 as-number 2
[r1-bgp]network 10.1.1.0 24
[r1]interface Tunnel 0/0/0
[r1-Tunnel0/0/0]ip address 192.168.3.1 24
[r1-Tunnel0/0/0]tunnel-protocol gre 
[r1-Tunnel0/0/0]source 10.1.1.1
[r1-Tunnel0/0/0]destination 11.1.1.1
[r1]ip route-static 192.168.2.0 24 Tunnel 0/0/0

R2

复制代码
[r2]interface GigabitEthernet 0/0/0
[r2-GigabitEthernet0/0/0]ip address 172.16.16.2 30
[r2]interface GigabitEthernet 0/0/1
[r2-GigabitEthernet0/0/1]ip address 172.16.19.1 30
[r2]interface GigabitEthernet 0/0/2
[r2-GigabitEthernet0/0/2]ip address 172.16.17.1 30    
[r2]interface LoopBack 0
[r2-LoopBack0]ip address 172.16.2.1 24
[r2]ospf 1 router-id 2.2.2.2    
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 172.16.2.0 0.0.0.255    
[r2-ospf-1-area-0.0.0.0]network 172.16.17.1 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 172.16.19.1 0.0.0.0
[r2]bgp 64512
[r2-bgp]router-id 172.16.2.1
[r2-bgp]peer 172.16.16.1 as-number 1
[r2-bgp]peer 172.16.3.1 as-number 64512
[r2-bgp]confederation id 2
[r2-bgp]peer 172.16.3.1 as-number 64512
[r2-bgp]peer 172.16.3.1 connect-interface LoopBack 0
[r2-bgp]peer 172.16.3.1 next-hop-local
[r2-bgp]confederation peer-as 64513
[r2-bgp]peer 172.16.5.1 as-number 64513
[r2-bgp]peer 172.16.5.1 connect-interface LoopBack 0
[r2-bgp]peer 172.16.3.1 next-hop-local 
[r2-bgp]peer 172.16.5.1 ebgp-max-hop
[r2-bgp]network 172.16.2.0 24
[r2]ip route-static 172.16.0.0 21 NULL 0
[r2-bgp]network 172.16.0.0 21

R3

复制代码
[r3]interface GigabitEthernet 0/0/0
[r3-GigabitEthernet0/0/0]ip address 172.16.17.2 30
[r3]interface GigabitEthernet 0/0/1
[r3-GigabitEthernet0/0/1]ip address 172.16.18.1 30    
[r3]interface LoopBack 0
[r3-LoopBack0]ip address 172.16.3.1 24
[r3]ospf 1 router-id 3.3.3.3    
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 172.16.17.2 0.0.0.0    
[r3-ospf-1-area-0.0.0.0]network 172.16.3.0 0.0 
[r3-ospf-1-area-0.0.0.0]network 172.16.3.0 0.0.0.255
[r3-ospf-1-area-0.0.0.0]network 172.16.18.1 0.0.0.0
[r3]bgp 64512
[r3-bgp]router-id 172.16.3.1
[r3-bgp]confederation id 2
[r3-bgp]peer 172.16.2.1 as-number 64512
[r3-bgp]peer 172.16.2.1 connect-interface LoopBack 0
[r3-bgp]peer 172.16.4.1 as-number 64512  
[r3-bgp]peer 172.16.4.1 connect-interface LoopBack 0
[r3-bgp]network 172.16.3.0 24
[r3-bgp]peer 172.16.4.1 reflect-client

R4

复制代码
[r4]interface GigabitEthernet 0/0/0    
[r4-GigabitEthernet0/0/0]ip address 172.16.18.2 30
[r4]interface GigabitEthernet 0/0/1
[r4-GigabitEthernet0/0/1]ip address 172.16.22.1 30
[r4]interface LoopBack 0    
[r4-LoopBack0]ip address 172.16.4.1 24
[r4]ospf 1 router-id 4.4.4.4    
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 172.16.4.0 0.0.0.255
[r4-ospf-1-area-0.0.0.0]network 172.16.22.1 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 172.16.18.2 0.0.0.0
[r4]bgp 64512
[r4-bgp]router-id 172.16.4.1    
[r4-bgp]confederation id 2
[r4-bgp]peer 172.16.3.1 as-number 64512[r4-bgp]peer 172.16.3.1 connect-interface LoopBack 0
[r4-bgp]confederation peer-as 64513
[r4-bgp]peer 172.16.7.1 as-number 64513
[r4-bgp]peer 172.16.7.1 connect-interface LoopBack 0
[r4-bgp]peer 172.16.7.1 ebgp-max-hop
[r4-bgp]network 172.16.4.0 24

R5

复制代码
[r5]interface GigabitEthernet 0/0/0
[r5-GigabitEthernet0/0/0]ip address 172.16.19.2 30
[r5]interface GigabitEthernet 0/0/1
[r5-GigabitEthernet0/0/1]ip address 172.16.20.1 30
[r5]interface LoopBack 0    
[r5-LoopBack0]ip address 172.16.5.1 24
[r5]ospf 1 router-id 5.5.5.5    
[r5-ospf-1]area 0
[r5-ospf-1-area-0.0.0.0]network 172.16.5.0 0.0.0.255
[r5-ospf-1-area-0.0.0.0]network 172.16.20.1 0.0.0.0
[r5-ospf-1-area-0.0.0.0]network 172.16.19.2 0.0.0.0
[r5]bgp 64513
[r5-bgp]router-id 172.16.5.1    
[r5-bgp]confederation id 2
[r5-bgp]confederation peer-as 64512
[r5-bgp]peer 172.16.2.1 as-number 64512
[r5-bgp]peer 172.16.2.1 connect-interface LoopBack 0
[r5-bgp]peer 172.16.2.1 ebgp-max-hop
[r5-bgp]peer 172.16.6.1 as-number 64513    
[r5-bgp]peer 172.16.6.1 connect-interface LoopBack 0
[r5-bgp]network 172.16.5.0 24

R6

复制代码
[r6]interface GigabitEthernet 0/0/0
[r6-GigabitEthernet0/0/0]ip address 172.16.20.2 30
[r6]interface GigabitEthernet 0/0/1
[r6-GigabitEthernet0/0/1]ip address 172.16.21.1 30    
[r6]interface LoopBack 0
[r6-LoopBack0]ip address 172.16.6.1 24
[r6]ospf 1 router-id 6.6.6.6    
[r6-ospf-1]area 0    
[r6-ospf-1-area-0.0.0.0]network 172.16.6.0 0.0.0.255
[r6-ospf-1-area-0.0.0.0]network 172.16.21.1 0.0.0.0
[r6-ospf-1-area-0.0.0.0]network 172.16.20.2 0.0.0.0
[r6]bgp 64513
[r6-bgp]router-id 172.16.6.1
[r6-bgp]confederation id 2-
[r6-bgp]peer 172.16.5.1 as-number 64513
[r6-bgp]peer 172.16.5.1 connect-interface LoopBack 0
[r6-bgp]peer 172.16.7.1 as-number 64513
[r6-bgp]peer 172.16.7.1 connect-interface LoopBack 0
[r6-bgp]network 172.16.6.0 24-
[r6-bgp]peer 172.16.7.1 reflect-client

R7

复制代码
[r7]interface GigabitEthernet 0/0/0
[r7-GigabitEthernet0/0/0]ip address 172.16.22.2 30
[r7]interface GigabitEthernet 0/0/1
[r7-GigabitEthernet0/0/1]ip address 172.16.21.2 30
[r7]interface GigabitEthernet 0/0/2    
[r7-GigabitEthernet0/0/2]ip address 172.16.23.1 30
[r7]interface LoopBack 0
[r7-LoopBack0]ip address 172.16.7.1 24
[r7]ospf 1 router-id 7.7.7.7    
[r7-ospf-1]area 0
[r7-ospf-1-area-0.0.0.0]network 172.16.7.0 0.0.0.255
[r7-ospf-1-area-0.0.0.0]network 172.16.21.2 0.0.0.0
[r7-ospf-1-area-0.0.0.0]network 172.16.22.2 0.0.0.0
[r7]bgp 64513
[r7-bgp]router-id 172.16.7.1    
[r7-bgp]confederation id 2
[r7-bgp]peer 172.16.23.2 as-number 3
[r7-bgp]confederation peer-as 64512
[r7-bgp]peer 172.16.4.1 as-number 64512
[r7-bgp]peer 172.16.4.1 connect-interface LoopBack 0
[r7-bgp]peer 172.16.6.1 next-hop-local
[r7-bgp]peer 172.16.4.1 ebgp-max-hop
[r7-bgp]peer 172.16.6.1 as-number 64513
[r7-bgp]peer 172.16.6.1 connect-interface LoopBack 0
[r7-bgp]peer 172.16.6.1 next-hop-local
[r7-bgp]network 172.16.7.0 24
[r7]ip route-static 172.16.0.0 21 NULL 0
[r7-bgp]network 172.16.0.0 21

R8

复制代码
[r8]interface GigabitEthernet 0/0/0    
[r8-GigabitEthernet0/0/0]ip address 172.16.23.2 30
[r8]interface LoopBack 0
[r8-LoopBack0]ip address 192.16.2.1 24
[r8]interface LoopBack 1
[r8-LoopBack1]ip address 11.1.1.1 24
[r8]bgp 3
[r8-bgp]router-id 11.1.1.1    
[r8-bgp]peer 172.16.23.1 as-number 2
[r8-bgp]network 11.1.1.0 24
[r8-bgp]network 192.168.2.0 24
[r8]interface Tunnel 0/0/0
[r8-Tunnel0/0/0]ip address 192.168.3.2 24    
[r8-Tunnel0/0/0]tunnel-protocol gre 
[r8-Tunnel0/0/0]source 11.1.1.1
[r8-Tunnel0/0/0]destination 10.1.1.1
[r8]ip route-static 192.168.1.0 24 Tunnel 0/0/0

四.检验

r1环回ping r8环回

复制代码
[r1]ping -a 192.168.1.1 192.168.2.1
  PING 192.168.2.1 56 data bytes=56 Sequence=1 ttl=255 time=70 ms
    Reply from 192.168.2.1: bytes=56 Sequence=2 ttl=255 time=60 ms
    Reply from 192.168.2.1: bytes=56 Sequence=3 ttl=255 time=50 ms
    Reply from 192.168.2.1: bytes=56 Sequence=4 ttl=255 time=70 ms
    Reply from 192.168.2.1: bytes=56 Sequence=5 ttl=255 time=40 ms

--- 192.168.2.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 40/58/70 ms

所有设备的环回互相访问

复制代码
[r6]ping -a 172.16.6.1 10.1.1.1
  PING 10.1.1.1: 56 data bytes=56 Sequence=1 ttl=253 time=40 ms
    Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=253 time=30 ms
    Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=253 time=40 ms
    Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=253 time=50 ms
    Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=253 time=30 ms

--- 10.1.1.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 30/38/50 ms

[r6]ping -a 172.16.6.1 11.1.1.1
  PING 11.1.1.1: 56 data bytes=56 Sequence=1 ttl=254 time=30 ms
    Reply from 11.1.1.1: bytes=56 Sequence=2 ttl=254 time=30 ms
    Reply from 11.1.1.1: bytes=56 Sequence=3 ttl=254 time=30 ms
    Reply from 11.1.1.1: bytes=56 Sequence=4 ttl=254 time=30 ms
    Reply from 11.1.1.1: bytes=56 Sequence=5 ttl=254 time=40 ms

--- 11.1.1.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 30/32/40 ms

[r6]ping -a 172.16.6.1 172.16.2.1
  PING 172.16.2.1: 56 data bytes=56 Sequence=1 ttl=254 time=30 ms
    Reply from 172.16.2.1: bytes=56 Sequence=2 ttl=254 time=50 ms
    Reply from 172.16.2.1: bytes=56 Sequence=3 ttl=254 time=30 ms
    Reply from 172.16.2.1: bytes=56 Sequence=4 ttl=254 time=50 ms
    Reply from 172.16.2.1: bytes=56 Sequence=5 ttl=254 time=20 ms

--- 172.16.2.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 20/36/50 ms

[r6]ping -a 172.16.6.1 172.16.3.1
  PING 172.16.3.1: 56 data bytes=56 Sequence=1 ttl=253 time=50 ms
    Reply from 172.16.3.1: bytes=56 Sequence=2 ttl=253 time=40 ms
    Reply from 172.16.3.1: bytes=56 Sequence=3 ttl=253 time=40 ms
    Reply from 172.16.3.1: bytes=56 Sequence=4 ttl=253 time=40 ms
    Reply from 172.16.3.1: bytes=56 Sequence=5 ttl=253 time=30 ms

--- 172.16.3.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 30/40/50 ms

[r6]ping -a 172.16.6.1 172.16.4.1
  PING 172.16.4.1: 56 data bytes=56 Sequence=1 ttl=254 time=20 ms
    Reply from 172.16.4.1: bytes=56 Sequence=2 ttl=254 time=30 ms
    Reply from 172.16.4.1: bytes=56 Sequence=3 ttl=254 time=30 ms
    Reply from 172.16.4.1: bytes=56 Sequence=4 ttl=254 time=40 ms
    Reply from 172.16.4.1: bytes=56 Sequence=5 ttl=254 time=40 ms

--- 172.16.4.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 20/32/40 ms

[r6]ping -a 172.16.6.1 172.16.5.1
  PING 172.16.5.1: 56 data bytes=56 Sequence=1 ttl=255 time=20 ms
    Reply from 172.16.5.1: bytes=56 Sequence=2 ttl=255 time=10 ms
    Reply from 172.16.5.1: bytes=56 Sequence=3 ttl=255 time=30 ms
    Reply from 172.16.5.1: bytes=56 Sequence=4 ttl=255 time=30 ms
    Reply from 172.16.5.1: bytes=56 Sequence=5 ttl=255 time=20 ms

--- 172.16.5.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 10/22/30 ms

[r6]ping -a 172.16.6.1 172.16.5.1
  PING 172.16.5.1: 56 data bytes=56 Sequence=1 ttl=255 time=20 ms
    Reply from 172.16.5.1: bytes=56 Sequence=2 ttl=255 time=10 ms
    Reply from 172.16.5.1: bytes=56 Sequence=3 ttl=255 time=30 ms
    Reply from 172.16.5.1: bytes=56 Sequence=4 ttl=255 time=30 ms
    Reply from 172.16.5.1: bytes=56 Sequence=5 ttl=255 time=20 ms

--- 172.16.5.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 10/22/30 ms

[r6]ping -a 172.16.6.1 172.16.6.1
  PING 172.16.6.1: 56 data bytes=56 Sequence=1 ttl=255 time=1 ms
    Reply from 172.16.6.1: bytes=56 Sequence=2 ttl=255 time=1 ms
    Reply from 172.16.6.1: bytes=56 Sequence=3 ttl=255 time=1 ms
    Reply from 172.16.6.1: bytes=56 Sequence=4 ttl=255 time=1 ms
    Reply from 172.16.6.1: bytes=56 Sequence=5 ttl=255 time=1 ms

--- 172.16.6.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round -trip min/avg/max = 1/1/1 ms
相关推荐
python算法(魔法师版)20 分钟前
API安全
网络·物联网·网络协议·安全·网络安全
一刀到底21128 分钟前
做为一个平台,给第三方提供接口的时候,除了要求让他们申请 appId 和 AppSecret 之外,还应当有哪些安全选项,要过等保3级
java·网络·安全
9527华安1 小时前
紫光同创FPGA实现AD7606数据采集转UDP网络传输,提供PDS工程源码和技术支持和QT上位机
网络·qt·fpga开发·udp·紫光同创·ad7606
北漂老男孩1 小时前
网络协议与系统架构分析实战:工具与方法全解
网络·网络协议·系统架构
___波子 Pro Max.1 小时前
http断点续传
网络·http
Johny_Zhao1 小时前
Ubuntu安装部署Zabbix网络监控平台和设备配置添加
linux·网络·mysql·网络安全·信息安全·云计算·apache·zabbix·shell·yum源·系统运维·itsm
熙曦Sakura2 小时前
【Linux网络】HTTPS
linux·网络·https
_板栗_2 小时前
HTTP 错误状态码以及常用解决方案
网络·网络协议·http
熙曦Sakura3 小时前
【Linux网络】 HTTP cookie与session
linux·网络·http