达梦数据库:同1台服务器如何启动不同版本的DMAP服务

需求背景:

用户使用资源比较高的服务器,作为测试环境提供服务器,因为在这台服务器,运行了很多个数据库版本实例的情况,但是当dmap版本和数据库版本不一致时,通过dmap备份会报错。

解决办法:

1.在对应版本的bin目录新建dmap.ini文件

配置AP_PORT=4237 #默认端口为4236

复制代码
vi dmap.ini
AP_PORT=4237

2.修改DMAP服务脚本里面dmap的绝对路径

复制代码
vi DmAPService

DMAP_INI_PATH=/home/dmdba/dmdbms/bin_174

3.修改参数EXTERNAL_AP_PORT

复制代码
SP_SET_PARA_VALUE(1,'EXTERNAL_AP_PORT',4237);
相关推荐
虎头金猫1 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
AI职业加油站1 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏1 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
-梅1 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog1 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发
张洛闻Eren1 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
琥珀色糖1 天前
SimlpeHttp
linux·服务器
其实防守也摸鱼1 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
第十人i1 天前
Linux 日志管理系统:journald 配置与优化
linux·服务器
布裘1 天前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境