在IIS上无法使用PUT等请求

错误来源:

```

chat:1 Access to XMLHttpRequest at 'http://101.126.139.3:11000/api/receiver/message' from origin 'http://101.126.139.3' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

```

其实我的后端代码已经配置过这个,所以肯定不是后端的问题。

后端配置如下:

cs 复制代码
builder.Services.AddCors(options => options.AddPolicy("CorsPolicy",
    set =>
    {
        set.SetIsOriginAllowed(origin => true)
            .AllowAnyHeader()
            .AllowAnyMethod()
            .AllowCredentials();
    }));

结合解决方案,首先你应该解决后端的跨域配置,使得在本地运行没有问题。然后再考虑IIS的问题。

今天在为我的代码修改的时候,偶然注意到控制台出现了下面的错误,这个请求是用来上传消息的,但是竟然失败,我运行本地的程序并没有这个问题。

我后来查到这个是因为IIS的webDAV会阻止某些请求,导致PUT等请求无法使用,于是我搜索了一些解决方案,似乎是版本不对的缘故,很多方案都不奏效。

因为我在很多台服务器上都配置过这个东西,之前都没这个问题。这个问题忽然出现,也是让我很尴尬。

于是我试着删除之前安装的这个功能,于是它确实工作了。前端的请求能够正常工作了。

解决方案:

删除WebDAB发布功能。

为什么这次会带来这个问题,这次重装为Windows系统之后,我又重装了IIS,我想着管他有用没用,功能我装了不少,没想到它会带来问题。

相关推荐
比兔代理4 小时前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog6 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog6 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
Ivanqhz6 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
骇客野人8 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
Wang's Blog9 小时前
Java 项目实战: 外卖平台-删除分类的关联校验与自定义业务异常
java·服务器·项目开发
zly35009 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
学习中的码虫10 小时前
网络编程5
服务器·网络
GPU实战笔记10 小时前
本地跑不动 llama.cpp,临时租云 GPU 怎么搭?从启动服务到环境复用
java·服务器·网络·人工智能·深度学习·llama