【Hadoop】Hadoop集群安装中出现的问题

1.namenode 和 secondarynamenode 启动失败

执行 start-dfs.sh 脚本,发现 namenode 和 secondarynamenode 没有启动,之后使用 hdfs namenode 命令单独启动时,报错如下:/app/hadoop/hadoop-2.6.4/name/in_use.lock 权限不足

通过下面命令查到 in_use.lock 文件的所有者和所属组都为root(uid,gid=0),所以执行命令 chown 将其都改为hadoop。

之后成功启动namenode,secondarynamenode同理。

2.主服务器上DataNode启动失败

使用hdfs datanode 命令启动后报错如下:clusterID 不匹配

解决方案:停止所有hadoop进程,删除DataNode的旧数据目录(注意:此操作会清空 DataNode 存储的数据块,测试环境可放心执行),该目录在 hdfs-site.xml 中的 dfs.datanode.data.dir 配置,重新启动 HDFS 服务。

3.子服务器上DataNode报错

先找到主服务器上的clusterID值,保证子服务器的 $HADOOP_HOME/data/current/VERSION 文件中clusterID的值与主服务器一致。之后使用命令 ./hadoop-daemon.sh start datanode 启动datanode即可。

相关推荐
mounter6251 分钟前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
yumgpkpm1 小时前
Acceldata ODP(Open Data Platform)3.3.6.4(RHEL9)保姆级完整安装手册
大数据·人工智能·hive·hadoop·kafka·hbase·cloudera
sunxunyong1 小时前
hs2偶发连接失败问题处理
hadoop
xh didida1 小时前
Linux -- 基础IO
linux·服务器·开发语言·c++
zly35002 小时前
centos7 mount设备挂载 /dev/sda1/硬盘挂载
linux·运维·服务器
工业一体机老司机2 小时前
工业一体机选购后的系统部署:Ubuntu下Docker容器化运行与GPIO配置
linux·ubuntu·docker·人机交互
哎呦,帅小伙哦3 小时前
进程监控工具——htop
linux·运维·服务器
夏虫不可与之言冰4 小时前
Windows WSL2 (Ubuntu) 搭建 ESP‑IDF 6.1 开发环境全过程演示
linux·windows·ubuntu·esp32·乐鑫科技·乐鑫eim·乐鑫代理商
春涧草茶5 小时前
慢就是快12-12手动抛出异常
java·linux·前端
KING-WU5126 小时前
Linux 工具之Make 与 Makefile
java·linux·服务器