DORIS 服务器宕机重启后出现的问题

在Doris服务器重启后或者Doris BE节点挂了,重启Doris 的BE 节点时,显示系统当前允许的最大打开文件数(ulimit -n​)低于推荐值(60000),这可能导致 Doris BE 在高并发或处理大量数据时出错或性能下降。

解决方法:使用 root 权限编辑这个文件:

bash 复制代码
sudo vi /etc/security/limits.conf

添加以下内容(如果已有类似内容,直接修改即可):

bash 复制代码
doris soft nofile 655350
doris hard nofile 655350

修改 /etc/pam.d/common-session 或 /etc/pam.d/login(不同系统略有区别):

bash 复制代码
sudo vi /etc/pam.d/login

确认有这行:

bash 复制代码
session required pam_limits.so

重启系统:

bash 复制代码
sudo reboot

重启后查看 :得到的数据是:655350

bash 复制代码
ulimit -n

重启完系统后需要关闭分区才能启动BE

bash 复制代码
swapoff -a

当重启完BE。发现脚本错误,最后发现是FE节点服务器和BE节点服务器之间的网不通:如下

注意这个是都Doris的物理地址不是DCN地址

具体原因是因为重启服务器后,FE的ip 发生了变化,使用 ip r 查看路由 :

最后需要关闭 多出来的这个路由:

bash 复制代码
sudo ifconfig eno3 down

最后重启BE执行脚本就正常了

相关推荐
阳光九叶草LXGZXJ6 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
黄大刀7 小时前
DataPulse一款开箱即用的SCADA(四)-历史记录
运维·scada·动环
正在走向自律9 小时前
AI数据分析与可视化:从基础到应用实践
服务器·人工智能·python·机器学习·数据分析·pandas
OnlineProxy9 小时前
亚马逊多账号运营:如何在规避“关联封号”风险的同时实现电商规模化扩张
服务器·数据库·redis
归秋1429 小时前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
Android系统攻城狮10 小时前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
91刘仁德10 小时前
IP协议详解:从IP协议头到网段划分、路由与NAT
linux·服务器·网络·网络协议·tcp/ip
辻弋20110 小时前
五年前的旅行视频糊成马赛克?Video2X用Real-ESRGAN逐帧重建细节,但只支持Windows、集显用户建议直接放弃
服务器·数据库·windows·游戏引擎·电脑
硅基手札11 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
工作10年+,存储芯片行业13 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie