Jetty所有版本对应Servlet,Jsp,JVM,Protocols

Version Years Home Min JVM Servlet JSP Status Protocols
12.1 2025- Eclipse 17 [1](https://jetty.org/download.html#_footnotedef_1 "1") 3.1, 4.0, 5.0, 6.0, 6.1 2.3, 3.0, 3.1 Stable / Supported HTTP/1.1 (RFC 7230), HTTP/2 (RFC 7540), HTTP/3 (RFC 9114), WebSocket (RFC 6455, JSR 356), FastCGI, Jakarta EE8 thru EE11, JakartaEE Namespace [2](https://jetty.org/download.html#_footnotedef_2 "2"), JavaEE Namespace [3](https://jetty.org/download.html#_footnotedef_3 "3")
12 2023- Eclipse 17 [1](https://jetty.org/download.html#_footnotedef_1 "1") 3.1, 4.0, 5.0, 6.0 2.3, 3.0, 3.1 Stable / Supported HTTP/1.1 (RFC 7230), HTTP/2 (RFC 7540), HTTP/3 (RFC 9114), WebSocket (RFC 6455, JSR 356), FastCGI, Jakarta EE8 thru EE10, JakartaEE Namespace [2](https://jetty.org/download.html#_footnotedef_2 "2"), JavaEE Namespace [3](https://jetty.org/download.html#_footnotedef_3 "3")
11 2020-2025 Eclipse 11 [1](https://jetty.org/download.html#_footnotedef_1 "1") 5.0 3.0 EOL / Unsupported (Notice) HTTP/1.1 (RFC 7230), HTTP/2 (RFC 7540), HTTP/3 (RFC 9114), WebSocket (RFC 6455, JSR 356), FastCGI, Jakarta EE9, JakartaEE Namespace [2](https://jetty.org/download.html#_footnotedef_2 "2")
10 2020-2025 Eclipse 11 [1](https://jetty.org/download.html#_footnotedef_1 "1") 4.0 2.3 EOL / Unsupported (Notice) HTTP/1.1 (RFC 7230), HTTP/2 (RFC 7540), HTTP/3 (RFC 9114), WebSocket (RFC 6455, JSR 356), FastCGI, Jakarta EE8
9.4 2016-2025 Eclipse 1.8 3.1 2.3 EOL / Unsupported (Notice) HTTP/1.1 (RFC 7230), HTTP/2 (RFC 7540), WebSocket (RFC 6455, JSR 356), FastCGI
9.3 2015-2020 Eclipse 1.8 [4](https://jetty.org/download.html#_footnotedef_4 "4") 3.1 2.3 Deprecated HTTP/1.1 (RFC 7230), HTTP/2 (RFC 7540), WebSocket (RFC 6455, JSR 356), FastCGI
9.2 2014-2018 Eclipse 1.7 [4](https://jetty.org/download.html#_footnotedef_4 "4") 3.1 2.3 Deprecated HTTP/1.1 (RFC 2616), javax.websocket, SPDY v3
9.1 2013-2014 Eclipse 1.7 [4](https://jetty.org/download.html#_footnotedef_4 "4") 3.1 2.3 Deprecated HTTP/1.1 (RFC 2616)
9.0 2013-2013 Eclipse 1.7 [4](https://jetty.org/download.html#_footnotedef_4 "4") 3.1-beta 2.3 Deprecated HTTP/1.1 (RFC 2616)
8 2009-2014 Eclipse / Codehaus 1.6 [4](https://jetty.org/download.html#_footnotedef_4 "4") 3.0 2.2 Venerable HTTP/1.1 (RFC 2616), WebSocket RFC 6455, SPDY v3
7 2008-2014 Eclipse / Codehaus 1.5 2.5 2.1 Venerable HTTP/1.1 (RFC 2616), WebSocket RFC 6455, SPDY v3
6 2006-2010 Codehaus 1.4-1.5 2.5 2.0 Antique HTTP/1.1 (RFC 2616)
5 2003-2009 Sourceforge 1.2-1.5 2.4 2.0 Relic HTTP/1.1 (RFC 2616)
4 2001-2006 Sourceforge 1.2, J2ME 2.3 1.2 Ancient HTTP/1.1 (RFC 2616)
3 1999-2002 Sourceforge 1.2 2.2 1.1 Fossilized HTTP/1.1 (RFC 2068)
2 1998-2000 Mortbay 1.1 2.1 1.0 Legendary HTTP/1.0 (RFC 1945)
1 1995-1998 Mortbay 1.0 - - Mythical HTTP/1.0 (RFC 1945)
相关推荐
啃瓜子的松鼠3 分钟前
泛微OAe9-后端二开异步调用
java
秋天的怀念_David1 小时前
第二十一夜 · 数字黑洞与西西弗斯的惩罚
java·程序人生·算法
外收内放1 小时前
Python基础语法练习题(73)
java·前端·python
Wang's Blog1 小时前
Java 项目实战: 交友项目 - 环信后台发送消息测试
java·交友
用户3721574261351 小时前
Java 操作 Word 脚注和尾注:添加、读取与删除
java
小嘉丶学长2 小时前
Day14 · 字典与集合
java·开发语言·网络·python·学习·1024程序员节
字节探索2 小时前
Spring Boot 接口幂等性设计:从唯一索引到 Redis+Lua 的工程实践
java·spring boot
用户3721574261352 小时前
Java 实现 Excel 与 Markdown 相互转换:表格导出、格式设置与多表提取
java
SL_staff2 小时前
制造业订单交付总踩坑?用结构化节点协同模型重构计划系统
java·开源·全栈
永遠_3 小时前
YAML格式化工具
java