Jenkins容器配置Git插件checkout超时时间

一、引言

Jenkins脚本在构建时通过Jenkins插件Git下载仓库,有个项目比较大,checkout时间超过默认的10分钟,导致项目构建报错,checkout报错信息如下:

在项目代码仓不能更改下以及网络等条件不能更改下,只能将checkout得默认时间加长。

二、修改checkout默认时间

由于Jenkins容器使用k8s启动,只需要多加JAVA_OPTS参数-Dorg.jenkinsci.plugins.gitclient.Git.timeOut=30如下图即可:,重新构建后从构建日志可以发现Checkout超时已经生效,如图所示:

相关推荐
骇客野人2 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
蓝速科技5 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese5 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky6 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
郑州光合科技余经理7 小时前
同城外卖小程序开发:下单成功后,后台导出能不能对上用户端状态
开发语言·前端·git·后端·uni-app·php·ai编程
智能运维指南7 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123457 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人7 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender7 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35008 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器