数据库意外中止,无法启动

文章目录

环境

系统平台:N/A

版本:4.1.1

症状

使用过程中数据库突然中止,且无法启动,存在一些类似报错信息:

LOG: checkpoints are occurring too frequently (7 seconds apart)

HINT: Consider increasing the configuration parameter "checkpoint_segments".

PANIC: could not write to file "pg_xlog/xlogtemp.9028": No space left on device

STATEMENT: insert into t1 select generate_series(1,1000000),'nan',md5('highgo');

PANIC: could not write to file "pg_xlog/xlogtemp.9028": No space left on device

server closed the connection unexpectedly

This probably means the server terminated abnormally

before or while processing the request.

The connection to the server was lost. Attempting reset: LOG: server process (PID 9028) was terminated by signal 6: Aborted

DETAIL: Failed process was running: insert into t1 select * from t2;

LOG: terminating any other active server processes

WARNING: terminating connection because of crash of another server process

DETAIL: The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.

HINT: In a moment you should be able to reconnect to the database and repeat your command.

Failed.

!> LOG: all server processes terminated; reinitializing

LOG: database system was interrupted; last known up at 2017-12-04 18:05:09 CST

LOG: database system was not properly shut down; automatic recovery in progress

LOG: redo starts at 0/103FE040

LOG: redo done at 0/14FFFF68

LOG: last completed transaction was at log time 2017-12-04 18:05:09.85515+08

PANIC: could not write to file "pg_xlog/xlogtemp.9084": No space left on device

LOG: startup process (PID 9084) was terminated by signal 6: Aborted

LOG: aborting startup due to startup process failure


LOG: database system shutdown was interrupted; last known up at 2017-12-04 18:05:23 CST

LOG: database system was not properly shut down; automatic recovery in progress

LOG: redo starts at 0/103FE040

LOG: redo done at 0/14FFFF68

LOG: last completed transaction was at log time 2017-12-04 18:05:09.85515+08

PANIC: could not write to file "pg_xlog/xlogtemp.9138": No space left on device

LOG: startup process (PID 9138) was terminated by signal 6: Aborted

LOG: aborting startup due to startup process failure

问题原因

wal日志所在文件系统空间不足。

解决方案

清理该文件系统下过期的临时文件,或将wal日志存放至更大的系统空间中。

注意:严禁删除wal日志!

相关推荐
IvorySQL8 小时前
PostgreSQL 日报|修复截断 zstd 备份检测(10 月 9 日)
数据库·postgresql
刘胡子大叔9 小时前
SQL 脚本的导入顺序
数据库·sql
代码什么用9 小时前
Spring对IoC的实现
数据库·spring
hz5678911 小时前
涉密视频会议设备配置指南:终端、音视频采集与配套设施选型
服务器·网络·数据库·安全·实时音视频·信息与通信·智能硬件
广州浮点FLOATLIC11 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
程序员Sunday11 小时前
MySQL 为什么使用 B+ 树索引?把范围查询、回表和覆盖索引连起来
数据库·mysql
半杯咖啡半行码12 小时前
Qt开发实战:数据库、MV 模式、QProcess与串口通信全攻略
数据库·qt
小米里的大麦12 小时前
16 MySQL 事务
数据库·mysql
西柚小萌新12 小时前
【LLM&&AI应用开发 八股文】--4.3.Agent智能体(下)
java·开发语言·数据库
邓工说电13 小时前
智慧断路器安全吗?数据加密、离线保护与合规认证全解读
大数据·数据库·人工智能·智能断路器·炜晔科技