云计算案例排错(云上3)

故障1

CPU&内存配额错误

solo-1工作负载启动失败,提示:重启启动容器失败。

解决方案:看下solo-1的更新升级中的容器规划配置,是否是正确的配置(CPU配额:申请0.25Core 限制0.29Core;内存配额:申请512MiB 限制998.4MiB)另一个8090配额为(CPU 0.25Core 限制0.45Core;内存 512MiB 限制1996.8MiB)

故障点2!

solo-1工作负载启动失败

solo-1工作负载启动失败

分析:1.solo-1工作负载的yaml文件初始化容器参数错误

2.solo-1工作负载的yaml文件探针参数错误

3.solo节点EIP地址没有了提示:Check tables failed

4.第一题目的ECS的mysql的EIP与dockerfile文件的EIP不一致,无法与数据库通信提示:Check tables failed

5.第一题目的ECS的mysql安全组入方向规则删除3306端口提示:Check tables failed

6.solo集群的2个安全组出方向规则将远端的any改为安全组,非any

解决方案:1.将solo-1工作负载的yaml文件里初始化容器参数改为正确的

2.将solo-1工作负载的yaml文件探针修改为正确的

3.将solo节点绑定eip

4.将第一题的目的ECS的mysql的EIP换成与dockerfile文件中的EIP地址一致

5.将第一题的目的ECS的mysql入向安全组规则加上3306端口

6.将solo集群的2个安全组的出向规则远端改为any

说明:solo节点重新绑定EIP,等solo-1工作负载起来后可能会不看外部访问地址,此时需要去节点管理将所有节点的信息进行同步(节点右边更多--同步节点信息)

故障3

ingress访问失败

网页报错为404或502错误

分析:此问题是solo-1工作负载发生问题导致,工作负载为 未就绪状态

解决方案:参考上个步骤

故障4

ingress访问失败,域名无法访问

分析:hosts文件被修改了

解决方案:将hosts总的域名和地址映射为正确的

相关推荐
workflower1 天前
世界模型向产业上游发掘的热点
人工智能·机器学习·机器人·云计算·无人机
通信瓦工1 天前
Meta开放式机架V3 BBU/机架结构设计参考
ai·云计算
鹿邑妈糊2 天前
kvm-clock时钟虚拟化原理
云计算
AI Data 搭子2 天前
阿里云发布 Agentic Storage 全矩阵产品:面向 AI 到 Agent 负载的全栈演进
人工智能·阿里云·云计算
ZhangJun952 天前
Linux常用命令笔记,中高级运维高频指令,并附上vim常见操作
linux·运维·centos·云计算·vim
逐流人2 天前
Ceph对象存储与文件系统存储管理:从RADOS网关、S3与Swift到CephFS快照同步
linux·运维·ceph·云原生·云计算·swift·rados
逐流人3 天前
Ceph分布式存储集群配置与池管理:从配置优先级到PG、复本池与纠删码池
运维·分布式·ceph·云原生·云计算·rados
jqpwxt3 天前
启点创新科技景区私有化票务管理系统:智慧景区数字化建设核心服务商,以本地部署筑牢景区数字化安全与稳定底座
大数据·人工智能·科技·云计算·旅游
ZhangJun953 天前
三次握手、四次挥手的具体细节和流程详解,附加思考题
tcp/ip·计算机网络·云计算
腾讯云大数据3 天前
腾讯云数据智能体TCDataAgent升级:大数据平台不只“给人用”,也要“给Agent用”
大数据·云计算·腾讯云