管理工具无法连接数据库,但是navicat可以正常连接

文章目录

环境

系统平台:银河麒麟 (海光),Microsoft Windows (64-bit) 10

版本:4.5.8,4.5.7,4.5.6,4.5.10,4.5.11

症状

管理工具连接数据库报错"尝试连线失败",但是使用navicat可以正常连接,cmd使用telnet查看5866端口是通的,使用psql也可以正常连接,驱动属性配置connectTimeout、socketTimeout后也没有效果;

管理工具日志报错:

复制代码
cannot assign requested address:no futher information

问题原因

用户使用了vpn或其他网络环境阻止了ipv6的网络通信,瀚高管理工具(JRE)在运行时默认使用ipv6协议栈,所以无法正常连接;

解决方案

hgdbdeveloper解压目录下etc\hgdbdeveloper.conf中default_options参数最前面添加以下配置,并重启管理工具使其生效

复制代码
-J-Djava.net.preferIPv4Stack=true
相关推荐
李兆龙的博客3 小时前
问津集 #26:Lakebase——Postgres 的版本化页面存储、数据库分支与计算弹性
数据库
在角落发呆3 小时前
工具配置备份步骤:从手动备份到自动化方案
运维·windows·自动化
百度一下吧4 小时前
Nginx 使用手册:从安装配置到实战部署
运维·nginx
JeJe同学4 小时前
Docker镜像导入、容器启动
linux·运维·docker
回眸&啤酒鸭4 小时前
【回眸】自动化白盒测试落地实战指南
运维·自动化·log4j
倔强的石头_5 小时前
聊聊金仓KFS:一款把数据同步软件做扎实的产品
数据库
闲云野鹤在人间5 小时前
MySQL|从理论、安装、备份到主从复制、MHA高可用详解
linux·运维·数据库·mysql·云计算
禾小西5 小时前
Redis:从两大维度和三大主线建立知识体系
数据库·redis·缓存
禾小西6 小时前
Redis 数据结构:快速的 Redis 有哪些慢操作?
数据结构·数据库·redis
数据库小学妹6 小时前
数据共享交换平台选型:交换方式对比与避坑指南
数据库·信创·数据同步·数据交换平台·政务数据共享·数据共享交换平台·数据库底座