Nacos配置中心避坑指南:灵活配置 server-addr 的坑

Nacos 3.x 优势介绍及接入指南

固定地址配置

在SpringCloud + Nacos的配置中,单环境配置还是比较简单的,application.yml 中配置如下:

bash 复制代码
application.yml 

spring:
  application:
      name: myapp
#  profiles:
#    active: dev
#    active: pre
  config:
    import:
      - nacos:nacos-config-example.properties?refreshEnabled=true
      # yml格式的文件必须加.yml后缀
      - nacos:sysconfig.yml?refreshEnabled=true
  cloud:
    nacos:
      config:
        server-addr: 127.0.0.1:8848 # 换成你的IP
        username: nacos
        password: nacos

环境隔离配置

但是如果需要进行环境隔离,想要在 dev 和 pre 环境中连接到不同的 nacos 服务地址,该如何配置呢? 你可能想到了,分别新建一个 application-dev.yml 和 application-pre.yml 文件,将spring.cloud.nacos.config.server-addr 在各自的环境中分别配置,于是有了下面三个配置文件:

bash 复制代码
application.yml 

spring:
  application:
      name: myapp
  profiles:
#    active: dev
    active: pre
  config:
    import:
      - nacos:nacos-config-example.properties?refreshEnabled=true
      # yml格式的文件必须加.yml后缀
      - nacos:sysconfig.yml?refreshEnabled=true
XML 复制代码
application-dev.yml

spring:
  cloud:
    nacos:
      config:
        server-addr: localhost:8848 # 本地开发环境
        username: nacos
        password: nacos
XML 复制代码
application-pre.yml

spring:
  cloud:
    nacos:
      config:
        server-addr: 192.168.1.221:8848 # 测试环境
        username: nacos
        password: nacos

错误信息:

但是这样配置的话 applicatioin-pre.yml 中的server-addr 并不会生效。此时启动的话会看到如下错误:

14:33:30.475 main INFO com.alibaba.nacos.plugin.auth.spi.client.ClientAuthPluginManager -- ClientAuthPluginManager Load ClientAuthService com.alibaba.nacos.client.auth.impl.NacosClientAuthServiceImpl success.

14:33:30.476 main INFO com.alibaba.nacos.plugin.auth.spi.client.ClientAuthPluginManager -- ClientAuthPluginManager Load ClientAuthService com.alibaba.nacos.client.auth.ram.RamClientAuthServiceImpl success.

2026-04-20T14:33:35.373+08:00 INFO 1 --- heyou-rag remote.worker.1 c.a.n.c.remote.client.grpc.GrpcClient : grpc client connection server: 127.0.0.1 ip, serverPort: 9848, grpcTslConfig: {"enableTls":false,"mutualAuthEnable":false,"trustAll":true}

2026-04-20T14:33:35.376+08:00 ERROR 1 --- heyou-rag remote.worker.1 c.a.n.c.remote.client.grpc.GrpcClient : Server check fail, please check server 127.0.0.1, port 9848 is available, error ={}

java.util.concurrent.ExecutionException: com.alibaba.nacos.shaded.io.grpc.StatusRuntimeException: UNAVAILABLE: io exception

at com.alibaba.nacos.shaded.com.google.common.util.concurrent.AbstractFuture.getDoneValue(AbstractFuture.java:594) ~nacos-client-3.0.3.jar!/:na

at com.alibaba.nacos.shaded.com.google.common.util.concurrent.AbstractFuture.get(AbstractFuture.java:469) ~nacos-client-3.0.3.jar!/:na

at com.alibaba.nacos.common.remote.client.grpc.GrpcClient.serverCheck(GrpcClient.java:234) ~nacos-client-3.0.3.jar!/:na

报错原因:

这是因为从 Spring Cloud Alibaba 2025.1.x 版本开始,已不再支持 bootstrap.yml/properties 文件。你需要将配置直接写入 application.yml 或 application.properties 中。 并且推荐通过spring.config.import 方式导入Nacos配置。系统启动时当加载到有 nacos:xxx 的配置文件需要引入时,就会立刻触发 NacosConfigManager 和底层 NacosClient 的初始化,进而建立与 Nacos Server 的连接(包括 gRPC 9848 端口)。这就导致 Nacos客户端(特别是作为配置中心时)的初始化早于 Spring Boot 常规配置文件(如 application-{profile}.yml)的加载。因此它只能使用application.yml文件中的配置,如果没有找到 server-addr ,就会自动采用默认地址:127.0.0.1:8848(当然gRPC端口会+1000,得到9848)

解决方案:

知道了问题的原因那解决方法就简单了,我们可以把 spring.config.import : nacos:xxx 的配置和spring.cloud.nacos.config.server-addr 属性一起分别配置到 application-{profile}.yml 文件中,这样就不会在刚加载主文件时就去初始化 NacosClient了。修改后配置如下:

bash 复制代码
application.yml 

spring:
  application:
      name: myapp
  profiles:
#    active: dev
    active: pre
XML 复制代码
application-dev.yml

spring:
  config:
    import:
      - nacos:nacos-config-example.properties?refreshEnabled=true
      # yml格式的文件必须加.yml后缀
      - nacos:sysconfig.yml?refreshEnabled=true
  cloud:
    nacos:
      config:
        server-addr: localhost:8848 # 本地开发环境
        username: nacos
        password: nacos
XML 复制代码
application-pre.yml

spring:
  config:
    import:
      - nacos:nacos-config-example.properties?refreshEnabled=true
      # yml格式的文件必须加.yml后缀
      - nacos:sysconfig.yml?refreshEnabled=true
  cloud:
    nacos:
      config:
        server-addr: 192.168.1.221:8848 # 测试环境
        username: nacos
        password: nacos
相关推荐
此时不提桶,更待何时8 小时前
06-12-A-Kafka存储深水区与源码解析详解
分布式·kafka·linq
此时不提桶,更待何时11 小时前
06-15-A-Kafka生态集成与流处理详解
分布式·kafka
此时不提桶,更待何时16 小时前
06-13-A-Kafka客户端与协议深入详解
分布式·kafka
程序猿乐锅1 天前
从0-1一文详解RabbitMQ
java·分布式·后端·中间件·rabbitmq·ruby
LoneEon1 天前
CentOS7 部署 Nacos3.x 集群实战:从注册中心到 AI 管理中心
linux·人工智能·nacos
老陈说编程2 天前
1. 鸿蒙 (HarmonyOS) 2012 至 2026 年的发展历程
分布式·华为·个人开发·harmonyos·鸿蒙·鸿蒙系统·程序员创富
ly76894 天前
Redis 分布式锁的边界条件:Redlock 争议、锁续期与客户端崩溃后的互斥失效
数据库·redis·分布式·分布式锁·watchdog·redlock
灯澜忆梦4 天前
【minio】#5 | MinIO 分布式部署 + HTTPS 部署
分布式·网络协议·https·对象存储·minio
谢亮_vipxieliang4 天前
Spring Cloud 服务治理入门:注册发现、配置中心、网关限流、熔断降级与分布式一致性方案
分布式·spring·spring cloud