如果openKylin 2.0 SP2主机的IPv4地址改变,如何让GitLab正常运行

作者:沈传越

明德融创工作室(Minter Fusion Studio, MFS) 出品

本文介绍的所有步骤均经过测试复现。


本文针对GitLab管理员使用。如果对于相关的专业词汇不太清楚。可以参考以下文章:

《如何在openKylin下安装并配置GitLab(v0.1.1)》

《何谓磐石架构》

《openKylin 2.0 SP桌面操作系统的mm-cli命令详解(v01.0)》

如果公司运行GitLab的服务器,因为某些原因变更了IPv4地址,那么,就需要重新配置GitLab,本文介绍相关的操作步骤。

一、术语

【操作系统】

计算机系统中的一种软件。是具有特定功能的程序模块的集合,能有效管理软硬件资源,合理组织工作流程,向用户提供服务,使用户方便地使用计算机,使整个计算机系统能高效运行。

【指令】

用户通过终端(Terminal)直接输入,用来操控操作系统的命令。

【执行指令】

用户在终端中输入指令,然后按回车键,运行指令对应的程序,完成相应的功能。

二、操作步骤

  1. Ctrl+Alt+T(同时按下Ctrl、Alt、T三个键),打开命令终端(Terminal)。

  2. 在命令终端中,执行以下指令,将openKylin 2.0 SP2桌面系统切换到维护模式(Maintain Mode):

sudo mm-cli -o

sudo reboot

  1. 在重新启动系统后,按Ctrl+Alt+T(同时按下Ctrl、Alt、T三个键),打开命令终端。

  2. 在命令终端中,执行以下指令:

ifconfig

查询当前主机的IP地址。具体方法,参考 《如何在Linux下查看当前主机的IP地址(v0.1.0)》。

记录查询到的IPv4地址。

  1. 执行以下指令,修改gitlab的配置文件gitlab.rb:

sudo vim /etc/gitlab/gitlab.rb

该指令会打开gitlab的配置文件gitlab.rb。然后按下面步骤操作。

1)按Esc键,输入/external_url。

2)使用↓键,将光标向下移动到

external_url='https://gitlab.example.com'

这一行。

按"a"键进入新增编辑状态。将两个单引号''之间的http://gitlab.example.com,更换为第4步中刚刚查到的IPv4,或者是GitLab服务器的IP地址,如:http://192.168.0.++++7++++

3)按Esc键,然后输入

:wq

完成存盘退出。

  1. 执行以下指令,让配置生效:

sudo gitlab-ctl reconfigure

这一步需要等待一段时间。当看到以下内容时,配置成功。

Running handlers:

2026-04-24T09:56:29+08:00 INFO: Running report handlers

Running handlers complete

2026-04-24T09:56:29+08:00 INFO: Report handlers complete

Infra Phase complete, 6/892 resources updated in 46 seconds

gitlab Reconfigured!

  1. 在浏览器地址栏中输入:http://192.168.1.87/users/sign_in,其中"192.168.1.87"是第5步,在gitlab.rb文件中输入的那个IPv4地址。如果正常显示如图1所示的登录页面,则说明GitLab正常运行。

图1 GitLab登录页面

  1. 如果GitLab没有正常运行,执行以下指令,启动GitLab

sudo gitlab-ctl start

  1. 执行以下指令,将openKylin 2.0 SP2桌面系统切换回普通模式(Normal Mode):

sudo mm-cli -c -a

$ sudo reboot

三、可能遇到的问题及解决方案

如果遇到以下问题:

|--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| Running handlers: 2026-04-23T20:35:06+08:00 ERROR: Running exception handlers There was an error running gitlab-ctl reconfigure: directory/usr/lib/systemd/system (package::runit_systemd line 22) had an error: Chef::Exceptions::InsufficientPermissions: Cannot create directory/usr/lib/systemd/system at /usr/lib/systemd/system due to insufficient permissions Running handlers complete 2026-04-23T20:35:06+08:00 ERROR: Exception handlers complete Infra Phase failed. 4 resources updated in 01 minutes 30 seconds 2026-04-23T20:35:06+08:00 FATAL: Stacktrace dumped to /opt/gitlab/embedded/cookbooks/cache/cinc-stacktrace.out 2026-04-23T20:35:06+08:00 FATAL: --------------------------------------------------------------------------------------- 2026-04-23T20:35:06+08:00 FATAL: PLEASE PROVIDE THE CONTENTS OF THE stacktrace.out FILE (above) IF YOU FILE A BUG REPORT 2026-04-23T20:35:06+08:00 FATAL: --------------------------------------------------------------------------------------- 2026-04-23T20:35:06+08:00 FATAL: Chef::Exceptions::InsufficientPermissions: directory/usr/lib/systemd/system (package::runit_systemd line 22) had an error: Chef::Exceptions::InsufficientPermissions: Cannot create directory/usr/lib/systemd/system at /usr/lib/systemd/system due to insufficient permissions |

原因是openKylin 2.0 SP2是因为系统处于正常模式(Normal Mode),磐石架构的保护开启,无法写入系统核心区域。

解决方案:

  1. Ctrl+Alt+T(同时按下Ctrl、Alt、T三个键),打开命令终端。

  2. 在命令终端中,执行下面两条指令,将系统切换到维护模式(Maintain Mode):

sudo mm-cli -o

sudo reboot

  1. 在重新启动系统后,按Ctrl+Alt+T(同时按下Ctrl、Alt、T三个键),打开命令终端。

  2. 在命令终端中,执行以下指令:

sudo gitlab-ctl reconfigure

重新配置GitLab。


【创作团队】

策 划:沈传越

文字创作:沈传越

技术支持:樊瑞平

图片采集:沈传越

制 图:樊瑞平

技术验证:沈传越

编 辑:沈传越

版式设计:沈传越

相关推荐
不会就选b15 小时前
Linux之TCP理论<1>
linux·运维·服务器
倔强的石头10616 小时前
应用账号最小权限实践:读写账号、报表账号、运维账号分层
java·运维·开发语言
Android系统攻城狮17 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_samples_min调用流程与实战(六十)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
_upupup18 小时前
Linux中的自动化构建——make/Makefile
linux·运维·自动化
还卿一钵无情泪19 小时前
Docker 部署Unsloth 绕开环境配置难题
运维·人工智能·docker·ai·容器·nlp·干货
打工仔折腾 AI20 小时前
Docker镜像分层与卷挂载到底怎么工作:一次文件系统层面的实测分析
运维·人工智能·后端·python·docker·容器·性能优化
大猫会长20 小时前
调用codebuddy集成的supabase授权白屏解决方法
linux·运维·服务器
夜之眷属21 小时前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
极客先躯21 小时前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图
韩振方21 小时前
为什么服务显示占了 8G,实际内存却没那么多?
运维