Windows IIS开启和配置服务器

调试HTTP连接的大步骤

VS调试运行>IIS部署,浏览器打开>远程ping>(远程telnet打开)>远程浏览器打开

这里没有任何项目(打开了IIS6.0,旧版)

控制面板

根据解释,这个IIS6.0已经过时了,不应该打开这个。

IIS有两个版本:

添加网站

物理路径填csproj项目的路径。

HTTP 错误 500.19模块 IIS Web Core错误代码 0x80070005配置错误 由于权限不足而无法读取配置文件 配置文件 \\?\C:\Users\Administrator\Documents\MyASPNET\MyAccountServerWeb\web.config

原因:把程序放在了比如用户/文档 这种有权限限制的文件夹。移出来,直接放C盘或D盘根目录。

Web应用部署到IIS,本地可以访问,远程不行,可以ping通

打开Windows Defender

添加入站规则

还是不行,用cmd输入Telnet IP 端口号,报错'telnet' 不是内部或外部命令,也不是可运行的程序。

去控制面板>程序>启动或关闭Windows功能>Telnet勾选,确定。

试了试80端口,可以连接。试了自己的8080,连接失败

腾讯云防火墙也要放行:

相关推荐
虎头金猫3 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
AI职业加油站3 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏3 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
-梅3 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog3 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发
张洛闻Eren3 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
琥珀色糖3 天前
SimlpeHttp
linux·服务器
其实防守也摸鱼3 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
第十人i3 天前
Linux 日志管理系统:journald 配置与优化
linux·服务器
布裘3 天前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境