xx000 can not wait without a pgproc

文章目录

环境

系统平台:Linux x86-64 Red Hat Enterprise Linux 7

版本:4.5.7,4.5.8

症状

数据库启动报错,无法正常启动数据库。日志提示错误信息如下

比致命错误还过分的错误 XX000 can not wait without a pgproc

问题原因

解决方案

解决方法有两个,当方法一无法解决时,使用方法二

方法一 启动过程中避免数据库连接

将pg_hba.conf中远程连接配置注释掉,禁止数据库远程连接。reload生效或者修改参数listen_address为localhost,然后关闭审计。

命令如下:

sql 复制代码
cd $PGDATA

---修改参数

vi postgresql.auto.conf 

listen_addresses = 'localhost'

保存后启动数据库

pg_ctl start

---关闭审计

psql -U syssao

select set_audit_param('hg_audit','off');

---退出

\q

---查询审计状态

psql -U syssao

select show_audit_param();

方法二 重新生成审计相关文件

将hgaudit目录和audit_param.conf备份,确认数据库正常后删除,创建hg_audit目录hgaudit,启动数据库,audit_param.conf自动生成,由审计功能造成的数据库问题消失。

命令如下

sql 复制代码
----备份

cd $PGDATA

mv hgaudit hgauditbak

mv audit_param.conf audit_param.confbak

---创建目录


mkdir -p hgaudit/audit_archive_ready

chmod 700 -R hgaudit

---启动数据库

pg_ctl start

检查数据库正常后删除备份

----删除

rm -rf hgauditbak

rm -rf audit_param.confbak

其中$PGDATA是数据文件目录。

报错编码

XX000

相关推荐
PaperData28 分钟前
2007-2020年税收调查面板数据
数据库
程序员清风1 小时前
CSV、Excel 与数据库数据读取实践
数据库·oracle·excel
变量探索SEQVEC1 小时前
一个网段里 10 个 IP,其实是同一个人:13 天蜜罐日志的攻击者画像
服务器
OsDepK1 小时前
OSMDE_v1.9.0已加入FTP与shell功能
linux·运维·服务器
GEO实战经验分享1 小时前
GEO技术与工具全景:从监测仪表盘到Schema的实战指南
数据库
一个天蝎座的程序猿1 小时前
IoTDB集群扩容:从慌乱到从容的经验分享
数据库
剑锋所指,所向披靡!2 小时前
HTTP服务器的基本相关概念
服务器·网络协议·http
硅基手札2 小时前
【Linux内核专栏 11】驱动框架:platform / char / misc / 设备树
linux·运维·服务器
小小龙学IT2 小时前
Python SQLAlchemy 2.0 深度解析:从 Core 到 ORM 的数据访问双引擎
开发语言·数据库·python
2301_777998342 小时前
TCP协议:滑动窗口与流量控制
服务器·网络·网络协议·tcp/ip·php