docker登录失败解决方法。http: server gave HTTP response to HTTPS client

1. 报错信息

bash 复制代码
docker login -uadmin {ip}:{port}
Password:
Error response from daemon: Get "{ip}:{port}/v2/": http: server gave HTTP response to HTTPS client

2. 问题分析

错误信息表明服务器使用的是HTTPS协议(即端口443或其它HTTPS默认端口之外的端口,如这里的8858),但是客户端尝试使用HTTP协议(即端口80)进行连接。这通常是因为配置错误或者URL格式不正确。

3. 解决方法

修改/etc/docker/daemon.json,如果该文件不存在,那么创建该文件

添加如下配置

json 复制代码
{
  "insecure-registries": ["{ip}:{port}"]
}

然后再重启docker

bash 复制代码
sudo systemctl restart docker
相关推荐
sbjdhjd5 小时前
云安全 | Docker 容器逃逸复盘(三):docker.sock 挂载与 Docker-in-Docker 风险
经验分享·网络安全·docker·云原生·容器·kubernetes·云安全
zxanz15 小时前
网站为什么需要 SSL 证书来实现 https?
https
长按助力退休7 小时前
HTTP缓存从强缓存到协商缓存,前端性能优化第一步
http
帷幕落秋7 小时前
Docker的两种安装
运维·docker·容器
工业一体机老司机7 小时前
工业一体机选购后的系统部署:Ubuntu下Docker容器化运行与GPIO配置
linux·ubuntu·docker·人机交互
Lsetea10 小时前
curl报58 unable to set private key file:客户端证书与私钥加载排查
运维·https·ssl证书·openssl·curl
Lsetea10 小时前
OpenSSL报certificate is not yet valid:error 9与notBefore时间排查
linux·运维·https·ssl证书·openssl
2501_9159090611 小时前
iOS应用从开发到上架App Store的完整发布流程与步骤指南
android·ios·小程序·https·uni-app·webview
姜鱼问生11 小时前
docker exec 排查容器问题:从日志到进程
运维·网络·数据库·docker·容器
人生百态,人生如梦12 小时前
Ubuntu在低版本下使用ccswitch+claudecode(CCSwitch+Docker+Claude)连调教程
linux·ubuntu·docker·claudecode·ccswitch