一、SuperMap iServer
问题1:假期期间 iServer 报错关闭,目前重启不起来。
11.3.0

【问题原因 】iServer非正常关闭,残留进程锁定数据库文件 (database is locked)
【解决办法】通过任务管理器关闭iServer残留进程后,重启iServer即可。
问题2:iServer 未授权访问漏洞按图示方式处理后,访问 iServer 一直在 setup 页面刷新,原因及处理方法。
11.3.0

【解决办法 】在iserver-all-.jar\resource\security\shiroUrls.ini 文件末尾加上:
/services/**/ .css = anon
/services/**/.js = anon
/ = roleFilterADMIN,PUBLISHER
问题3:iServer服务提供者正常,发布聚合服务后看不到图
11.3.0
【问题原因 】由于地图瓦片的比例尺不一致导致
【解决办法】将服务聚合中比例尺不一致的地图重新切图。
问题4:iServer中转发arcgis服务转发成功,但预览为空白
11.3.0
【解决办法】升级至12.1.0官网正式版,问题解决。下载地址:https://support.supermap.com/DownloadCenter/ProductPlatform.aspx
问题5:web许可中有3套iServer但扩展模块不同,咨询是否有办法(如在iserver-system.xml中写死模块)固定每台机器占用的许可模块
11.3.0
【解决方案】iServer配置web许可时,可以选择扩展模块,不同机器可以选择不同的扩展模块
问题6:人大金仓数据库连接端口报错提示与实际填写的不一致
11.3.0

解决办法】版本问题下载最新双周包,https://pan.baidu.com/s/1r4q55GpBItgLbP90LEg67g?pwd=6655
问题7:supermap-iserver-11.3.0-linux-arm64-all包GPA模型变量里的数据源类型缺少内存型,咨询如何解决
11.3.0

【问题原因 】GPA模型中的内存型数据源是在12.1.0版本上才集成进来的【解决办法】通过官网下载地址升级iServer版本到12.1.0
问题8:瀚高数据库的数据服务无法发布,通过工作空间方式发布时无数据服务可选,通过PGIS方式无法获取数据集,需定位发布失败原因
11.3.0
【问题原因 】iServer默认依赖库无法连接瀚高数据库安全版。【解决办法】将瀚高数据库中的libpq、libssl、libcrypto依赖库替换至iServer安装目录support/objectsjava/bin下,即可正常发布数据服务
问题9:咨询iServer的加密方式能否配置,是否支持SM国密算法对用户密码进行加密存储
12.0.0
【解决办法】在iServer安装目录webapps/iserver/WEB-INF/shiro.ini文件中配置passwordService为com.supermap.services.security.SMPasswordService,即可支持对iServer中用户密码进行国密加密;注意该功能需升级iServer版本至12.1.0
问题10:咨询iServer最新版本用户手册PDF从哪里下载
11.3.0
【解决办法】支持方提供平台产品线SuperMap GIS 2026 MPP营销资源汇总链接,其中包含iServer用户手册PDF等资源 https://lexiangla.com/teams/k100048/docs/89a6b5d0924111f18a41c68dcc4e3528?company_from=bc917b20f73c11eaaa6e52540005f435
问题11:用户咨询iServer想要配置机器学习环境该如何配置,需要正确的AI服务环境配置方法
11.3.0
【解决办法】参考iServer帮助文档机器学习服务配置说明:https://help.supermap.com/iServer/zh/Server_Service_Management/AIserver/MLservice2.htm
问题12:用户咨询WMTS服务与超图自带栅格瓦片的区别
11.3.0
【解决办法 】底图类数据(影像、电子地图、行政区划):优先使用栅格瓦片
业务类数据(管网、地类图斑、实时数据):优先使用动态服务或矢量瓦片
混合需求:按比例尺分层,小比例尺瓦片 + 大比例尺动态服务
问题13:用户申请的12i Web试用授权导入许可中心后没有许可分配记录,与之前的界面表现不一致,需确认授权导入问题及后续配置步骤
12.0.0

【解决办法】需在产品中配置Web许可后许可分配界面才会有记录:配置许可时选Web许可,填入许可地址ws://{ip}:9183,点击获取许可看到许可类型后点击下一步完成配置,之后在许可中心许可分配页面即可看到使用许可的机器信息
问题14:用户iServer 12很多服务时不时异常,一会儿自动恢复一部分另一部分又异常,服务不稳定,有项目演示需求需保证服务正常加载
12.0.0
【解决办法】调大服务节点规格,针对服务实例过过的节点进行拆分到多个节点上去
问题15:在iServer中如何更新已发布的瓦片
11.3.0
【解决办法】通过服务管理找到发布的瓦片服务,重新指定新切的瓦片文件即可
问题16:用户iServer在互联网环境只暴露/totopgty路径,想将iServer代理到/totopgty/iserver二级路径下,咨询如何通过二级路径实现代理
11.3.0
【解决办法 】
1、找到 iServer 安装目录下的 conf/server.xml 文件。
2、在 节点下新增 节点,用于修改 iServer 的默认访问路径:
3、参数说明:
- path :指定访问的二级路径,即 /totopgty/iserver
- docBase :iServer 的实际部署路径,请根据您的实际安装目录修改
4、将 autoDeploy 和 deployOnStartup 都设置为 false ,避免 Tomcat 自动部署导致 iServer 启动两次。
问题17:用户反馈缺陷:为适配非public模式的数据集名称"模式名@表名",iServer WFS100为正常返回XML将@替换成_,导致用户获取的数据集名带_,获取不到原始@数据集名报错找不到该数据集
11.3.0
【解决办法】客户数据集名称写错,改正确后可正常获取
问题18:用户申请的Web试用许可,iServer启动报错,需定位许可报错原因
11.3.0
【问题原因 】许可中心导入的许可为 11i,但是尝试接入许可中心的iServer为12i,许可不匹配导致报错。
【解决办法】重新为12i的iServer申请一套新的许可并导入到新的Web许可中心中。
问题19:咨询iServer 12.1.0容器版本是否已提供下载,需要获取容器版本安装包
12.0.0
【解决办法】支持人员提供iServer 12.1.0容器版本百度网盘下载链接(https://pan.baidu.com/s/10DoR7HdggsVvVr9FRu8tmA 提取码: pviw),用户确认收到。
问题20:用户咨询iServer是否支持SpatiaLite数据库
11.3.0

【解决办法】UDBX本身就是基于SpatiaLite的数据库格式
问题21:用户咨询iServer的SPATIAL空间查询是否支持一次传入多个坐标进行批量查询,支持人员确认当前不支持该用法,单次查询仅可使用一个空间查询条件
11.3.0
【问题原因 】iServer空间查询接口单次请求仅支持一组空间查询条件,不支持一次查询多个坐标。【解决办法】单次SPATIAL查询仅传入一个坐标条件,如需查询多个坐标,需拆分为多次请求分别执行。
问题22:iServer发布服务后对内蒙古范围数据进行切图,切图速度极慢,其中一个全内蒙图层已切图三天、整体已切一个星期,10多个图层切到14级,数据直接连接禹贡数据库,需要排查切图缓慢的原因及相关影响因素
11.3.0

【问题原因 】切图三天的图层数据量达两百多万条,数据未创建空间索引,导致地图渲染缓慢,切图效率极低。【解决办法】切图之前对数据创建空间索引,并可通过重建空间索引操作处理:https://help.supermap.com/iDesktopX/zh/tutorial/DataProcessing/DataManagement/DTv_ReBuildSIndex.html
问题23:用户反馈iServer查询空间字段结果与数据库实际存储不一致(iServer查出198个要素、数据库同参数查出102个),远程排查确认为查询请求EPSG:3857与数据坐标系4490不一致导致
11.3.0

【问题原因 】iServer查询请求中坐标系EPSGcode指定为3857,与数据库中数据的4490坐标系不一致,导致查询返回的空间字段结果与数据库实际不符。【解决办法】将查询请求参数改为"targetEpsgCode":4490,查询结果即与数据库一致。
问题24:iServer 10.2.1迁移新服务器并升级12i过程中,服务配置信息(存储于本地文件)如何迁移,涉及服务、工作空间、数据源、符号库、用户权限等配置迁移方式
10.2.1
【解决办法】配置存本地文件时采用方案B:将旧版本iServer相应路径文件拷贝至新版本iServer对应路径;iserver-services-interfaces.xml、iserver-system.xml、shiro.ini、server.xml、web.xml、iserver-geoprocessing.xml需按旧配置编辑修改;参考https://help.supermap.com/iserver/zh/Install_Uninstall/ungratenote.htm 及 https://blog.csdn.net/supermapsupport/article/details/126296927
问题25:iServer 10.2.1升级12i时工作空间及UDB、UDBX数据版本兼容性、数据能否回退及自定义符号、JAR包等组件兼容性如何保障
10.2.1
【解决办法】iServer与iDesktopX大版本必须统一,iServer12i发布的数据建议采用iDesktopX 12i制作或重新打开后保存;iServer小版本号建议高于iDesktopX;若需旧版回退,务必完整备份旧版数据、服务器及相关配置,用副本做升级
问题26:iServer 10.2.1迁移升级12i后,原有REST地图服务、数据服务、空间分析服务及WMS、WMTS、WFS等标准服务的服务地址、接口参数、返回结果和认证方式是否会变化,业务系统是否需修改
10.2.1
【解决办法】原有服务地址、接口参数、返回结果和认证方式基本不变,12i在10i基础上新增部分参数但原有参数兼容;注意下线功能,若旧环境使用了已下线功能迁移后无法直接运行,提前参考https://help.supermap.com/iserver/zh/Appendix/iServer_offlineFunction.htm 制定替代方案
问题27:iServer 10.2.1迁移升级12i时,现有地图缓存、影像缓存、三维场景、S3M等三维缓存能否直接复用,无法复用时重新生成缓存的时间和磁盘空间如何估算
10.2.1
【解决办法】缓存向下兼容可直接复用,但强烈建议采用iDesktopX 12i制作或重新打开保存数据,12i在S3M上有几何压缩MeshOpt、纹理压缩DXT/CRN_DXT5等优化;可使用iDesktopX 12i的S3M瓦片升级工具(三维数据→瓦片工具→S3M版本升级);生成缓存耗时与空间取决于数据范围和切图层级,可参考旧版切片存储大小和生成耗时
问题28:iServer 12i对新服务器操作系统、JDK、数据库版本等运行环境的具体要求,以及10.2.1现有许可能否继续使用、新服务器资源配置如何评估
10.2.1
【解决办法】新服务器配置要求参考https://help.supermap.com/iserver/zh/Install_Uninstall/SystemConfig/SystemConfig.htm ,iServer 12i要求GLIBC≥2.28、GCC≥8.3需确认操作系统满足;iServer 10版本许可不能延续使用在12版本上,需申请12i版本许可
问题29:用户反馈地图已设置透明但发布到iServer后背景仍显示白色,支持人员指导在地图属性中设置背景颜色验证透明效果,并说明需勾选相关选项后保存地图与场景、清理iServer输出缓存并重新上传工作空间
11.3.0
【问题原因 】用户在图层属性中设置透明而非地图属性,且iServer端存在旧缓存导致背景未透掉。【解决办法】在地图属性(而非图层属性)中设置背景颜色验证透明效果,勾选相应透明选项后保存地图和场景;清理服务器上iServer缓存(路径:supermap-iserver-11.3.0-windows-x64-deploy\webapps\iserver\output),清除后将工作空间重新上传至服务器再浏览验证;地图瓦片制作可参考在线文档:https://help.supermap.com/iDesktopX/zh/tutorial/MapTiles/MapTiles.html,数据更新频繁时建议iServer动态出图,数据基本不变时建议预先切好瓦片再发布。
问题30:用户咨询坐标系为4543的OSGB倾斜摄影数据,是否必须先切片生成S3M缓存才能通过iServer发布服务,寻求正确的数据处理与发布流程
11.3.0
【解决办法】如果是WebGL前端加载,需要先将OSGB数据的坐标系转换为4490,然后切片生成S3M缓存,再通过iServer发布服务;
问题31:咨询11版本iServer集群(服务配置存储连数据库)如何迁移到12版本,需要具体实施步骤及注意事项
11.3.0
【解决办法】参考迁移博客https://blog.csdn.net/supermapsupport/article/details/126296927,建议按迁移配置文件方式实施,迁移前务必备份;
问题32:需要统计部分iServer服务器的内存和性能指标,希望获得监控统计方法的指导
11.3.0
【解决办法】使用iServer管理页面中的"监控"模块查看统计内容,参考文档:https://help.supermap.com/iserver/zh/Server_Service_Management/serverMonitor/serverMonitor.htm
问题33:iServer监控模块中显示"没有请求次数",不清楚该提示的含义,需解释监控统计结果
11.3.0
【解决办法】该提示说明在当前统计时间内服务器没有接收到任何服务请求,即目前没有用户在访问iServer发布的服务
问题34:另一台Linux服务器iServer启动失败,support/objectsjava/bin下执行ldd libWrapj*.so检查发现大量依赖库not found,需补齐依赖恢复启动
11.3.0
【解决办法】将support/objectsjava中sysDepLibs文件夹(或解压sysDepLibs.tar.gz)内所有文件拷贝到support/objectsjava/bin目录,重新执行ldd确认无缺失依赖后iServer即可正常启动
问题35:iServer登录异常:密码输入正确可跳转但右上角仍提示需登录,密码输错提示密码错误,无痕浏览器无效;晚间更新正式高级许可报错31,机器仍读取到试用许可,需排查登录及许可更新失败问题
11.3.0
【问题原因 】正式许可配套的id文件被不小心移除,许可管理混乱导致更新正式许可报错31并引发登录异常。【解决办法】1、备份并删除过期许可/试用许可(位于/opt/SuperMap/License/),注意保留id文件;2、将正式许可文件放至/opt/SuperMap/License/;3、iServer切换许可并重启后许可生效登录恢复
问题36:12i iServer网络锁插在13.2.201.237,跨网段机器(13.2.217.x)需访问许可,统信UOS安装许可驱动报错(状态码65),修改ulimit文件句柄无效,需完成跨网段许可访问配置并确认驱动安装验证方法
12.0.0
【问题原因 】状态码65表示重复安装许可驱动,机器上残留11i许可驱动(Linux端版本8.31为11i驱动);跨网段访问还需开启插锁机器acc选项及客户端"允许访问远程授权"。【解决办法】卸载11驱动重装12驱动(Windows安装会覆盖,卸载命令为Tools\SuperMapLicenseCenter\Tools\SuperMap_Trial_License.exe加-purge、-r参数;插锁机器开启acc、放行1947端口,客户端许可中心输入网络锁IP直连并勾选"允许访问远程授权",验证许可读取成功
问题37:iServer的WMS130服务GetFeature请求报错,之前调用正常,更换图层为gxbt0710后查询异常
12.0.0

【问题原因 】请求参数不规范且更换图层后未同步更新图层编码:wms130应使用CRS参数而非SRS、坐标参数应用I/J而非XY、LAYERS及QUERY_LAYERS未替换为新图层编码。【解决办法】按服务能力文档(http://{服务器IP}:{端口}/iserver/services/{服务名称}/wms130?SERVICE=WMS&REQUEST=GetCapabilities)核对并替换gxbt0710图层的LAYERS、QUERY_LAYERS编码,修正CRS与I/J参数后查询恢复正常
问题38:咨询哪些日志文件是iServer的访问日志,如何调取iServer服务的访问日志记录
11.3.0
【解决办法】三种方式:1、针对重点关注服务在服务管理中开启【服务访问日志】;2、在conf/server.xml中配置AccessLogValve开启catalina访问日志;3、查看访问日志数据库(iServer安装目录/logs/accessrecords.db),系统每隔15分钟巡检一次记录总量,超过40000条时按规则自动清理
问题39:咨询一台服务器能否同时启动两个版本的iServer,修改server.xml端口后启动报错,需定位端口配置问题
11.3.0
【解决办法】一台服务器可以启动两个版本的iServer,只需修改端口号;只需改8090和8015两个端口即可(8453为https重定向端口无需修改),报错原因可能是9090等端口被占用,尝试改为8091和8016后正常启动
问题40:iServer许可到期后更新许可,启动提示没有权限,需排查许可文件配置及日志信息,现场为Windows环境,已通过腾讯会议远程排查
11.3.0

【问题原因 】过期许可文件未删除
【解决办法 】
1、删除旧许可(位于C:\Program Files\Common Files\SuperMap\License)
2、清除浏览器缓存
3、重启iServer
问题41:业主单位要求排查弱口令隐患,已部署的iServer服务用户仍为默认admin,咨询是否可以修改账户密码、如何修改,以及修改后是否会影响之前发布的服务
11.3.0
【解决办法】停止iServer服务后执行密码修改脚本完成账户修改;修改账户不会影响之前发布的服务,仅当通过token方式访问服务时需同步更新token凭据
问题42:正式许可换许可流程中需要导出清除文件,咨询Linux系统下如何导出许可清除文件及c2s文件位置
11.3.0
【解决办法】Linux系统通过命令./licensetool.sh -clear执行清除;或在有Java环境下于组件bin目录(iServer为例:【iServer安装目录】/support/objectsjava/bin)执行 java -jar com.supermap.licensemanager.jar -clear;清除后查看opt/SuperMap/license目录下的*.c2s文件,将原C2S文件提供给许可负责人处理后重新生成许可
问题43:iServer发布知识图谱服务后会一直连接实体所在数据库,导致iServer进程被占满进而崩溃
11.3.0

【问题原因 】部分服务关联的数据库数据源iServer无法连接,系统不断重试连接,最终线程阻塞使iServer无法响应
【解决办法】将工作空间另存为sxmu文件,修改其中的sml:Server节点为同一网段内的数据库IP,保障数据库连接即可。
问题44:咨询动态出图(含缓存机制)与切瓦片再发布服务的出图性能主要差异
11.3.0
【解决办法】动态出图主要在底层绘制上存在些许差异,若两者都使用缓存,则出图性能没有区别
问题45:文件型数据源发布REST数据服务失败:发布后数据集列表为空、桌面报发布服务失败、iServer上传370M压缩包(泰安市变更调查数据110万图斑)在上传限制已调为4G后仍报超限
11.3.0
【问题原因 】Nginx限制了上传请求
【解决办法】通过nginx.conf的调大client_max_body_size参数值即可。
问题46:修改iServer默认访问路径的方法
11.3.0

【解决办法】远程协助修改iServer/conf/server.xml并新增:,详细参考:https://blog.csdn.net/supermapsupport/article/details/125613328
问题47:iServer 10.2.1大量"解析HTTP请求header错误"日志(请求目标中含无效字符如0xe60x9c0x88.json),咨询是否会导致所有服务不可用
10.2.1
【问题原因 】第三方调用请求时中文地图名/数据集名称未做URL编码,直接发中文导致Tomcat按RFC 7230/3986校验报无效字符。【解决办法】JS发送请求时用encodeURIComponent对中文编码后再请求即可,该报错不影响其他服务正常使用
问题48:iServer服务报许可错误,提示没有获取到基础版许可,服务无法正常使用
11.3.0

【问题原因 】服务器硬盘被catalina.out日志文件写满(该文件写了77G日志),磁盘空间耗尽导致iServer无法正常获取许可,报"没有获取到基础版许可"错误。【解决办法】删除超大日志文件释放磁盘空间后重启iServer服务,许可恢复正常;建议对catalina.out日志文件做定期清理机制,避免再次写满硬盘
问题49:iServer访问日志har文件在指定路径下未生成
12.0.0

【问题原因 】未开启访问统计配置,不会生成访问日志。【解决办法】在iServer中开启访问统计并自定义文件名,开启后自动生成"文件名+时间戳+.har"格式的访问日志文件
问题50:一次性插入上万条数据是否需设置批量提交参数及一次写入的数据量上限
12.0.0
【问题原因 】未设置批量提交参数时每条记录就是一个事务,设置后所有数据为同一个事务一次提交,无需担心SQL语句被截断。【解决办法】批量插入时设置批量提交参数;服务器端无写入条数限制,组件使用PostGIS数据库测试一次性提交几十万条数据均正常
问题51:调用管道占压新增接口(POST features)时报错code=400,"添加要素失败,未添加任何要素。失败消息:addFeature方法中更新objRecord时失败";定位到是传OFFSET参数即报错,不传则成功,但页面需要该参数。
11.3.0
【问题原因 】数据库为PostgreSQL,"offset"为其保留字,使用该字段名会导致addFeature方法中更新objRecord时失败。【解决办法】将数据集中"OFFSET"字段名更换为非保留字名称。修改方式:在桌面iDesktopX中打开该数据库型数据源,找到数据集pipeline_integrity,右键"属性-属性结构"直接修改字段名称;注意:不要直接在数据库中改,否则iDesktopX中数据集不会同步,可能引发其他问题;修改后需同步调整前后端接口的字段映射。
问题52:询问在何种情况下地图没有矢量地图渲染选项(同为矢量单图层,第二个无该选项)。
11.3.0
【问题原因】一般矢量数据组成的动态地图服务均有该选项,影像和栅格没有;
问题53:项目现场地图服务出现白图,需排查是否为iServer导致ArcGIS瓦片缺失;需确认缺失的瓦片文件并定位问题根源
11.3.0
【问题原因 】通过工具查看ArcGIS原始缓存确认原始瓦片数据本身缺失,白图并非iServer服务导致。【解决办法】问题1与问题2确认为同一问题;可依据服务日志中tile key的输出锁定具体缺失的.bundle文件,支持侧另提供增强日志的class包便于更直观定位缺失文件,原始缓存需重新补切缺失瓦片
问题54:客户之前部署的iServer(192.168.201.134:8090)当天上午起频繁崩溃,多次强制重启后仍反复挂掉(此前的iServer修改验证已无问题),需排查崩溃原因
11.3.0
【问题原因 】TIN地形数据处理不恰当【解决办法】"合并TIN配置文件"最终会在iserver端合并数据,占用iserver资源,建议采用"合并TIN"在数据层面直接合并好地形
问题55:通过REST服务请求获取的图例中包含缺省风格图例,用户希望去除图例中的缺省风格,咨询缺省风格为何一定存在以及能否去除
11.3.0
【问题原因 】缺省风格属于特殊单值项,经与研发确认产品设计上必须保留,图例中的缺省风格无法去除。【解决办法】前端自行控制展示:通过REST请求获取图例信息后,不添加"缺省风格"的图例项进行展示
问题56:导出为PersonalGDBVector文件时报"TK数据集携带投影不一致,不能导出"错误,之前一起导出未报过坐标问题
11.3.0
【问题原因 】第一个查询结果做了坐标转换,后续所有查询数据需设置一致坐标系否则报坐标系不一致。【解决办法】在流程中对数据集重设坐标系后不再报错,可正常导出。
问题57:GPA流程中第一个查询结果做坐标转换后,需为后续每个新增图层都设置坐标系否则报不一致,咨询能否删除第一个数据的坐标系以省去逐个设置
11.3.0
【解决办法】GPA不支持删除坐标系算子,改用迭代数据集方式统一坐标系,减少逐个重设坐标系的次数,支持人员提供参考模型文件,用户验证可用。
问题58:千万级地类图斑数据的数据服务相交查询耗时10秒以上,无法满足项目页面点击查询图斑的性能要求。
11.3.0
【问题原因 】千万级图斑数据查询中执行SELECT CAST(MAX("smarea") AS double precision)获取面积最大值的语句耗时极长,数据集smarea字段缺少索引。【解决办法】在iDesktopX中为矢量数据集smarea字段创建字段索引,查询从6.9s优化至50ms。产品侧已上报缺陷ISVJ-12325推动优化。
问题59:工作空间发布到iServer后预览三维场景什么都看不到,WebGL3D预览报错,但在iDesktopX中可正常浏览,需排查发布后场景不显示原因
11.3.0

【问题原因 】直接发布含场景的工作空间方式不正确,且场景未生成场景缓存。【解决办法】需先生成场景缓存,再将生成场景缓存文件中的工作空间发布为三维服务;iDesktopX端预览还需开启地下模式、LOD缩放比例设置100
问题60:用户反馈iServer存在一个安全漏洞,发送漏洞截图请求超图技术支持协助查看漏洞原因及处理方式,需消除安全隐患
11.3.0
【问题原因 】该漏洞由iServer内置Tomcat版本过低(9.0.93)导致。【解决办法】需将Tomcat升级到9.0.109以上,建议直接升级iServer至最新11.3.0版本(内置Tomcat版本为9.0.115),最新版iServer可通过官方网盘地址获取:https://pan.baidu.com/s/1xbv6s5vlbqw_uMg9J9hgJw?pwd=6655
问题61:用户反馈项目原有SQL查询请求中属性过滤条件带换行符\n,导致iServer数据服务featureResults查询批量报错,需确认服务端兼容处理方案
11.3.0
【问题原因 】请求体queryParameter的attributeFilter中包含\n换行符,导致iServer数据服务SQL查询解析失败报错。【解决办法】前端代码中去除属性过滤条件里的换行符后请求恢复正常;后续同类调用均需保证attributeFilter为单行合法表达式。
问题62:12.0.1版本云GIS套件发布PostgreSQL数据库型工作空间,classic与leaflet两种渲染方式结果不一致,classic方式部分图形缺失,拖动缩放均无法显示,业务系统一张图内容显示不全
12.0.0
【问题原因 】数据集更新后数据集范围不正常导致未正常出图;同时开启了iServer缓存,数据更新后缓存未完全清理。【解决办法】1、更新后的数据集需重新计算数据集范围;2、清理iServer和云套件缓存,可通过按钮清理,也可通过文件管理清理output目录下对应地图名称的缓存(推荐);3、经常更新的数据对应地图服务需关闭缓存
问题63:业务系统实时更新数据库型数据源数据集后数据集范围不会自动更新导致出图不全,客户不接受手动重算范围方案,希望iServer能自动检查更新数据集范围
12.0.0
【解决办法】支持工程师提供四种方案:1、清除地图服务缓存触发iServer自动更新范围;2、iDesktopX中右键数据集重新计算范围;3、构建GPA模型发布GIS服务在数据更新后自动执行重算范围算子;4、iObjects Java调用DatasetVector.computeBounds()方法。客户希望产品侧自动更新,建议客户在业务系统更新数据逻辑后调用计算范围接口,无需用户手动操作。
问题64:用户请求iServer WFS服务GetFeature接口带cql_filter参数,UAT环境请求正常,部署到生产环境后报错,确认WFS1.0.0标准参数无cql_filter,需定位生产环境报错原因
11.3.0
【问题原因 】生产环境数据ID主键设置及缓存异常导致WFS请求报错,UAT环境参数可生效但生产环境数据异常。【解决办法】修改ID主键、清除缓存并重新发布服务后请求恢复正常;注意iServer的WFS不支持cql_filter参数,筛选参数需按帮助文档规则构建
二、SuperMap iDesktopX
问题1:在iDesktopX中,数据集的"创建空间索引"按钮是灰色的,无法点击,咨询如何解决。
11.3.0
【解决办法】数据库写的权限未开放导致的,开放该权限给用户即可创建空间索引
问题2:正射影像DOM(135GB)使用镶嵌数据集-保存地图-生成地图瓦片,缓存了2T数据如何解决
12.1.0
【问题原因 】客户实际需求是生成二维瓦片(全球剖分)和三维瓦片
【解决办法 】
1.影像为投影坐标系,加入经纬度坐标系的地图中开启动态投影
2.生成地图瓦片(全球剖分),瓦片范围需在-180到180范围内
3.使用"地图瓦片转三维影像瓦片"功能,用二维瓦片生成三维瓦片
问题3:iDesktopX 中使用镶嵌数据集在影像全幅显示情况下不展示,放大才展示
11.3.0
【解决办法 】
方法一:对镶嵌数据集构建概视图
方法二:修改SmMaxPS、SmMinPS
镶嵌数据集在小比例尺下看不见,是因为显示受轮廓属性表中 SmMinPS 和 SmMaxPS 字段控制。当显示栅格的分辨率大于 SmMaxPS 值时,影像将不显示;当分辨率小于 SmMinPS 值时,影像也不再显示。
修改步骤如下:
在 iDesktopX 工作空间管理器中,右键点击镶嵌数据集,选择 浏览轮廓属性表。
在属性表中找到 SmMinPS 和 SmMaxPS 两个字段。
将 SmMinPS 值调小(例如改为 0),将 SmMaxPS 值调大(例如改为 10 或更大)。
保存修改后,缩小地图即可看到影像显示。
需要注意:
若坐标系为经纬度,数值单位为度;若为投影坐标系,数值单位为米。
修改后若仍不显示,可将 SmMaxPS 继续调大,直到小比例尺下能正常显示为止。
问题4:线数据集中名称相同的两条线按 name 字段融合无结果,另存数据集后同样条件和容限却能融合
12.1.0
【问题原因 】数据中存在大量重复线对象,导致融合失败
【解决办法 】用最新双周包对数据做拓扑检查-线内无重叠,去除重复线对象后即可融合成功
链接: https://pan.baidu.com/s/1FtXdb_obXVYgVV_BRZxVOA?pwd=6yew 提取码: 6yew
问题5:iDesktopX"点外挂模型生成缓存"执行后经常没有.spc,需生成两三遍才成功
12.0.0

【问题原因 】瓦片边长参数设置5000太大了
【解决办法】模型为单段防撞围栏预计5-10米,设置瓦片边长200即可显示
问题6:GPA自动制图执行报错,咨询解决方案
11.3.0

【问题原因 】用户提供的是图层风格模板。【解决办法】自动制图需要提供图层属性模板,调整模板后执行正常
问题7:桌面里根据DEM数据提取高度、为二维房屋面赋予高度字段应使用哪个功能;功能入口找不到
11.3.0

【解决办法 】使用【空间分析】→【表面分析】→【提取三维数据】功能,将生成的高程字段通过属性更新功能更新到二维房屋面;功能找不到【问题原因】许可没有选择空间分析模块所以没有【提取三维数据】功能
问题8:iDesktopX的AI助理功能在2025版本中能否使用,用户在界面未找到功能入口且搜索无结果,需确认功能可用性及启用方法
11.3.0
【解决办法】需配置AI助理环境后使用,具体参考官方文档 https://help.supermap.com/iDesktopX/zh/tutorial/AIAsistant/AIAsistantConfiManagement.html ;此外推荐配置使用iDesktopX Skills
问题9:咨询桌面产品内置Python版本是否仅支持3.5、3.6和3.7,能否导入使用Python 3.10的外置环境
11.3.0
【解决办法】可以配置Python3.10。
问题10:iDesktopX 12版本桌面浏览管线数据时不停放大,到达一定高度后地图发生偏移现象,需解决放大浏览偏移问题
12.0.0
【问题原因 】管线数据漂浮在空中,鼠标缩放时,鼠标锚点没有落在具体的管线模型上,导致相机快速缩放到管线下方【解决办法】当管线漂浮在空中时,将鼠标放置在模型上进行缩放,或者向场景添加对应的地形数据
问题11:数据集和图层均已做透明色设置,加载到三维场景后仍显示白边,需定位透明色设置未生效的原因
11.3.0

【问题原因 】在地图中设置的无值透明,在场景中加载不会保留
【解决办法】场景中的图层属性也支持设置无值透明,如果后续要生成影像缓存,可以在缓存界面设置下透明色或者直接使用影像轮廓设置瓦片范围。
问题12:用户有DEM数据,想要知道某个坐标相比周边是低洼还是高地,咨询超图组件或桌面产品是否有对应的地形分析能力
11.3.0
【解决办法】可以使用桌面的邻域统计功能进行分析,参考帮助文档:https://help.supermap.com/iDesktopX/zh/Tools/RasterAnalyst/Rasterstatistics/Neighbourstatistics.html
问题13:用户使用热力专题图时提示不能输出专题图模板,不清楚原因及正确的模板导出入口
11.3.0

【解决办法】热力专题图属性在图层属性中,通过图层属性中的导出图层属性模板即可,专题图模板与图层属性模板是同一个东西
问题14:用户咨询iDesktopX硬件网络狗购买五套基础版许可与一套空间分析扩展模块许可条件下的许可占用机制:谁先占用扩展模块、占用后退出机制是关闭释放还是可被挤掉
11.3.0
【问题原因 】客户购买了五套基础版许可与一套空间分析扩展模块许可。一个开启的桌面的用户会占用空间分析扩展模块,如何只退出模块许可占用,而不退出基础版本许可占用。
【解决办法】客户启动iDesktopX后打开 文件->许可信息->切换许可,取消空间分析模块勾选。
问题15:用户使用SuperMap水文分析提取山脊线时,咨询博客中正地形的生成方式,确认其是否就是原始地形数据
11.3.0
【解决办法】确认正地形就是原始地形数据,可直接用原始DEM地形数据按博客流程提取山脊线
问题16:用户咨询CAD数据集是否支持拓扑检查,以及点线面数据集做拓扑检查后能否对检查出的结果进行自动修正
11.3.0
【解决办法】CAD数据集不支持拓扑检查,需转为简单数据集。目前支持指定修复的项:https://help.supermap.com/iDesktopX/zh/tutorial/DataProcessing/Topology/TopoCheck.html
问题17:用户咨询是否支持ArcGIS Pro的stylx格式符号库文件导入超图桌面
11.3.0
【解决办法】stylx格式不支持直接导入,可以在ArcMap里将符号库导出为style格式,再导入超图桌面使用
问题18:用户咨询在桌面中如何去除重叠数据,需要数据处理操作方法
11.3.0
【问题原因 】客户需求为更新数据,并且更新数据前需要将更新区域的老数据进行删除,客户提供的数据有原始数据,更新数据的行政区面数据,更新数据。
【解决办法】使用空间查询功能,对更新数据的行政区面数据和需要更新的数据进行相交查询,将查询出的数据选中后删除。然后再追加更新数据完成更新。
问题19:用户咨询Oracle数据库的空间数据转存到PostgreSQL数据库的空间数据,这种跨库空间数据转换是否有实现方式
11.3.0
【当前进展】不支持直接操作数据库,可以通过桌面的批量复制数据集的功能进行转存
问题20:用户咨询超图软件有没有办法生产和导出OSM数据
11.3.0

【解决办法】桌面支持导入OSM数据为点、线、面数据集,但不支持生产和导出OSM数据
问题21:用户咨询产品报价中"三维地质建模-基础插件"的相关介绍和使用说明
11.3.0
【解决办法】该插件支持构造建模,建立地质体空间结构框架,包括地层界面、断层、褶皱等主要地质边界几何形态;支持岩溶溶洞空间形态建模及与整体地质模型做布尔运算实现溶洞仿真;详见三维地质建模扩展模块帮助文档:https://help.supermap.com/iDesktopX/zh/GettingStarted/ProductIntro/LicenseIntro.html
问题22:用户咨询iDesktop启动时的图标是否可以自定义修改
12.1.0

【解决办法】修改产品目录\resources\Frame\StartupIcon\Startup_Left.svg
问题23:用户执行擦除分析显示100%,详细信息什么也没有,也不自动关闭,咨询是什么情况?
11.3.0
【问题原因 】写入数据源为只读数据源;
【解决办法】修改写入数据源为独占数据源后正常进行擦除分析。
问题24:用户咨询龙芯桌面最新版本应该找哪位申请,及所提供版本是否为稳定版
12.0.0
【解决办法】已提供12.1.0.0龙芯版本下载链接(https://pan.baidu.com/s/1goZCGEpbo-eWg_mUlc5eDQ 提取码: xk71);deb包可下载最新12.1.0双周版本:https://pan.baidu.com/s/1r45GpBItgLbP90LEg67g?pwd=6655
问题25:用户咨询超图是否支持批量BIM导出FBX,桌面或组件哪种方式都可以
11.3.0
【解决办法】可以使用桌面的模型数据集批量导出工具
问题26:用户咨询导出的FBX是否会保留坐标信息
11.3.0
【解决办法】导出的FBX会保留坐标,详见帮助文档:https://help.supermap.com/iDesktopX/zh/Tools/3DData/Modeleditor/Batchexport.html
问题27:用户使用12.1的iDesktopX生成高斯泼溅数据三维瓦片,两个高斯泼溅瓦片目录合计约1.57G,生成用了约1小时,想确认该体量耗时是否正常及有无优化压缩切片时间的方法
12.0.0
【解决办法】正常,客户数据过于精细,对于精细数据生成需要一定时间,耗时除了数据大小,更多的影响因素为数据是否密集。
问题28:用户有一个TIF地形数据,想要知道地形里面哪些是洼地,咨询操作方法及分析结果形式
11.3.0
【解决办法】可以使用"填充伪洼地"功能进行分析,分析结果也是栅格数据集,对比原始DEM与填洼后的数据,即可识别出哪些区域是洼地
问题29:非EPSG:3857原始数据需切瓦片发布服务,Web客户端仅支持加载3857,咨询推荐做法(是否切3857瓦片或动态投影)。
11.3.0
【解决办法】推荐在桌面端对原始数据做投影转换为3857后再切瓦片发服务
问题30:iDesktopX配置值域咨询:值域设置分导入值域和逐数据集字段绑定两步,咨询字段值域信息存储位置及如何将一个数据源的值域设置应用到另一个数据源。
11.3.0

【解决办法】值域及字段与值域ID的绑定信息均存储在数据源中;可通过复制数据集方式将值域带到另一数据源;跨数据源同名数据集可通过复制空数据集(带值域设置)到新数据源后追加行导入新数据实现。
问题31:用户咨询配图数据源由在线库_public切换至_ipms时原配图文件和数据文件是否会丢失及快捷迁移方法,支持人员说明需重新指定数据集并提供工作空间XML批量替换方案
11.3.0

【解决办法】断开public模式数据库连接后需在地图中重新指定ipms模式下的对应数据集;快捷迁移可将工作空间保存为sxwu文件,查找节点下各图层中将_public的数据库连接信息批量替换为_ipms,重新打开即可完成迁移。
问题32:12.1多任务切图时不按级别顺序执行,期望先切完前几级级别优先发布使用。
11.3.0
【问题原因 】多任务切图会根据设置的比例尺和地理范围将任务预先拆分为多个独立子任务随机领取执行,本身不按级别顺序切;【解决办法】在任务列表中需要右键需要优先执行的任务,点击右键列表中的优先执行即可
问题33:多任务切图中单个任务执行时间过长,咨询是否可以杀掉进程改用继续执行多任务功能。
11.3.0
【解决办法】建议通过关闭按钮正常关闭多进程,重新启动桌面端后使用继续执行多任务切图功能恢复任务,不建议直接杀进程,避免任务状态异常。
问题34:生成专题图后在右侧专题图自定义中修改风格,左侧图层管理器中各图层样式统一变成最后修改的样式,符号为ArcGIS迁移导入。
12.0.0

【问题原因 】ArcGIS迁移后的点符号使用固定画刷设置填充颜色时,不会同步到图层管理器预览中。【解决办法】1.升级到2026版本桌面即可;2.绕行办法:取消固定画刷颜色,改用符号颜色进行设置。
问题35:用户咨询在投影设置界面如何将数据坐标系切换为EPSG:4326,支持人员指导在投影转换对话框中设置目标坐标系完成转换
11.3.0
【解决办法】在软件功能区的投影转换对话框中,将目标坐标系设置为EPSG:4326(地理坐标系WGS1984),执行投影转换即可完成坐标系切换。
问题36:镶嵌数据集执行裁剪操作失败,经支持侧本地反复测试复现,需定位裁剪失败原因
11.3.0
【问题原因 】镶嵌数据集中部分tif数据拿不到(数据位置改变或已不存在),导致裁剪失败。【解决办法】检查并修复镶嵌数据集中所有tif数据的路径,确保路径全部正确可访问后裁剪即可成功裁剪
问题37:用户咨询高程TIF数据如何发布为三维地形服务,支持人员指导先将TIF导入为栅格数据集再切TIN瓦片,并说明sct直接发布或通过场景发布工作空间两种方式,用户操作中确认文件路径参数后完成配置
11.3.0
【解决办法】在iDesktopX中先将TIF高程数据导入为栅格数据集,再对栅格数据集切TIN瓦片(12i版本可直接使用"栅格文件生成缓存(TIN)"算子,功能界面需选择栅格文件路径与瓦片存储路径,开始层默认即可);生成sct后有两种发布方式:1.直接发布sct为三维服务;2.新建场景将sct添加到场景中,保存场景及工作空间后把工作空间发布为三维服务。
问题38:用户执行数据集追加行时报错invalid byte sequence for encoding "UTF8": 0x00,数据集ipms@tb_condensate_drain_pipe追加记录集失败,排查为属性中包含空字节导致
11.3.0

【问题原因 】数据集属性字段值中包含空字节(0x00),导致追加行时UTF8编码校验失败。【解决办法】将属性中的空字节替换为空字符串后重新追加;可通过查看对应日志定位含空字节的异常字段。
问题39:iDesktopX 11.3中对坐标系执行重设、转换操作后epsg code均为空,导致入库后数据库srid不对,需解决epsg code无法写入问题
11.3.0
【问题原因 】桌面端判断两个坐标系一致时未执行重设或投影转换操作去更换坐标系,导致epsg code为空【解决办法】先切换为其他坐标系(如4490)应用成功后再改回目标坐标系(如4326),epsg code即可正常写入
问题40:执行某功能处理时报错,咨询报错原因及对源数据的要求,涉及栅格数据是否支持该操作。
11.3.0

【问题原因 】该功能不支持栅格数据作为源数据。【解决办法】更换为矢量数据源执行相应功能,栅格数据需先做其他相应处理。
问题41:咨询栅格数据如何转换到CGCS2000(大地2000)坐标系。
11.3.0
【解决办法】使用菜单"数据处理-栅格-投影转换"功能,对栅格数据执行投影转换至CGCS2000坐标系。
问题42:将DAE模型导入数据源后显示质量非常差,咨询如何判断是模型本身质量问题还是导入过程出错。
11.3.0

【问题原因 】该DAE文件为类似切片(分层瓦片)格式,导入时加载了粗糙层级导致模型显示质量差。【解决办法 】参考相关文档https://blog.csdn.net/gitblog_09792/article/details/143299497
将DAE转换为OSGB格式后再导入数据源,可保留精细层级提升显示质量。
问题43:矢量裁剪咨询:已默认开启新算法,但不同坐标系数据集裁剪结果不对,确认哪些叠加分析支持不同坐标系。
11.3.0
【问题原因 】目前仅面面叠加分析支持不同坐标系运算,线面叠加暂不支持,导致结果异常。【解决办法】线面叠加分析前需先将数据转换到相同坐标系再执行裁剪;12.1.0默认开启新算法,之前版本可在桌面目录Bin文件夹中的SuperMap.xml中修改<IsUseNewAnalysisAlgorithm参数为TRUE开启。
问题44:用户咨询线数据ZM值相关问题:如何判断线数据是否含ZM值、无ZM值能否后期补充、数据库线数据导出至本地ZM值是否丢失,支持人员逐项解答操作方法
11.3.0
【解决办法】1.Z值:三维线数据集有Z值,二维线数据集没有,二维线转三维线即可增加Z值;M值:线数据集右键属性-矢量中查看是否有M值;2.M值仅能在创建数据集时勾选,后期需新建勾选M值的数据集(属性结构相同),用追加行将对象追加过去;3.数据库复制数据集到本地udbx数据源时ZM值不会丢失。
问题45:用户反馈2025版iDesktopX(Linux)使用对象平移工具后含M值的线数据M值丢失,确认2025版本(Windows/Linux)均存在该问题,2026官网版12.1.0已修复
12.0.1

【问题原因 】2025版本对象平移工具存在缺陷,平移后对象M值丢失。【解决办法】升级至官网2026版本12.1.0,该版本已修复对象平移后M值丢失问题,数据处理同事统一升级版本即可。
问题46:将614条记录的GeoJSON文件(QGIS制作的第三方三维建模配置框文件合并而成)导入超图后,属性表仅剩544条记录,数据缺失无规律,QGIS中显示619条,需排查导入丢数原因
11.3.0
【问题原因 】原始数据为第三方三维建模配置框文件在QGIS中合并生成,QGIS导出该数据本身存在失败记录,数据源质量存在问题。【解决办法】提供json数据经支持侧导入验证格式正确,按正确json直接导入即可获得完整数据
问题47:咨询KMZ格式的文件能否加载进GIS系统中,数据来自管网项目,需要确认平台加载能力
11.3.0
【解决办法】KMZ格式文件可以直接在三维场景里面加载;若为其他平台GIS底座,需找对应平台售后支持确认,超图平台支持加载
问题48:iDesktopX添加达梦DM数据库数据源时程序闪退,打开数据库连接、另存为DM工作空间均闪退,bin目录下dm相关dll删除后不闪退但无法连接,需解决DM库连接闪退问题
11.3.0
【问题原因 】原有的dm.dll驱动库文件异常导致iDesktopX连接达梦数据库时崩溃闪退。【解决办法】删除原bin目录下dm.dll,将新dm驱动包(dm8_20230524_x86_win_64_ent_8.1.3.12_pack6_dmdci.zip)中dmocci文件夹内所有文件拷贝到iDesktopX的bin目录下后重启即可正常另存和打开DM工作空间
问题49:桌面端需连接达梦数据库并导入数据实现前端可修改地图数据,但新建数据库型数据源选项为灰色无法操作,咨询如何连接达梦数据库
11.3.0

【解决办法】创建DM Spatial数据源需两个前提:1、达梦数据库安装DM空间扩展模块(DMGEO);2、配置环境变量,将达梦提供的dmdpi及其依赖库路径加入windows的path或linux的LD_LIBRARY_PATH。第一次使用建议用【新建数据库型数据源】,之后可用【打开数据库型数据源】,参考https://help.supermap.com/iDesktopX/zh/tutorial/TechDocument/DMSpatialUseGuide/DMSpatialUseGuide.html
问题50:更新许可后Revit插件导出BIM模型仍然报错,无法完成模型导出
11.3.0

【问题原因 】重装系统导致Revit插件部署文件可能丢失,且插件版本与组件bin包版本不配套。
【解决办法】11.3.0版本iDesktopX已支持直接导入RVT文件,项目验证直接导入成功可先用该功能过渡;Revit插件方面下载最新版本插件(进入Revit 2018目录同步下载配套组件bin目录、addin文件及部署文档),将SuperMapExporter.addin拷贝至C:\Users\Administrator\AppData\Roaming\Autodesk\Revit\Addins\201X目录重新部署;插件下载地址:https://pan.baidu.com/s/1h6Vj5rVICaN-ejb-Jfu5zw 密码:ngfd
问题51:达梦数据库中数据的非空间字段如何创建索引以优化查询
12.0.0
【解决办法】在需要查询的非空间字段上创建字段索引;空间索引方面小数据量创建R树索引,数据量大于100万创建图库索引
问题52:ArcGIS的shp数据EPSG4527导入到udbx,用复制数据集算子后结果数据集没有坐标系。
11.3.0
【问题原因 】导入shp丢失EPSG编码为已修复缺陷
【解决办法】更新到12.1.0版本解决,链接:https://pan.baidu.com/e/13bqIcDQo9Vo3O1SkhJhJww
问题53:标注在指定比例尺下显示多个的设置方法;不理解0.1毫米参数含义;设置后部分区域密集部分稀疏
11.3.0
【解决办法】1.在iDesktopX"修改专题图→高级→周期间距单位、沿线周期间距"中设置;2.0.1毫米是屏幕渲染的间距尺寸;3.出现疏密不均时可改用"坐标系单位"设置(避免按毫米屏幕单位计算);4.需检查密的地方是否有多段小道路叠加。疏密异常的根本原因是密的地方可能存在多段小道路,按坐标系单位设置可避免该问题
问题54:咨询iDesktopX与数聚红芯HI7258 AI一体机工作站(鲲鹏920S、RTX PRO2000显卡)的适配情况,需确认桌面产品在该硬件环境下的兼容性
11.3.0
【解决办法】提供iDesktopX帮助文档系统配置要求链接(https://help.supermap.com/iDesktopX/zh/Illumination/EnvironmentRequest.html),其中包含支持的CPU架构、操作系统及最低配置说明,可据此核对工作站硬件兼容性
问题55:iDesktopX定制开发环境下打开数据集报错,该功能为默认功能非定制功能,需定位是缓存问题还是扩展jar与桌面jar版本冲突
11.3.0

【问题原因 】客户自行打包的扩展jar中commons-io等依赖包版本与iDesktopX自带版本冲突,类加载时优先加载了外部引入版本导致打开数据集报错。【解决办法】找到报错的commons-io jar包,确认优先使用了外部引入版本后,将其版本与iDesktopX lib目录下保持一致,即可避免冲突
问题56:咨询彻底清除iDesktopX缓存的方法,确认configuration\cache目录是否为缓存路径,用于排除扩展开发不生效等异常
11.3.0

【解决办法】扩展开发不生效时,可删除安装目录下configuration\cache缓存文件夹后重启iDesktopX,即可重新加载扩展配置
问题57:Windows平台iDesktopX需要注入GaussDB数据库连接依赖,不清楚桌面端注入高斯依赖的具体操作步骤和依赖文件获取途径
11.3.0
【解决办法】使用gaussdbwindow依赖库(网盘链接:https://pan.baidu.com/s/1fDBDFDLhWzciZ-UZ40nB9Q?pwd=2i23 提取码: 2i23),将三个文件拷贝到iDesktopX的bin目录下替换原有同名文件,重启iDesktopX后连接GaussDB
问题58:VCT文件在Windows下可正常打开,但在Linux操作系统下打开失败,需定位跨平台打开VCT文件失败的原因
11.3.0
【问题原因 】VCT文件原始编码非UTF-8,Linux环境下组件对该编码的识别与Windows不同导致打开失败。【解决办法】手动将VCT文件编码转换为UTF-8后,在Linux环境中可正常导入
问题59:咨询11i的硬件狗许可能否用于12i版本,涉及性能优化方案中的版本升级可行性
11.3.0
【解决办法】11i的许可不能用于12i版本,两者许可是不同的,升级12i需重新采购许可
问题60:Linux(ARM)版iDesktopX桌面端需要连接达梦空间数据库,咨询是否需要注入依赖及依赖文件获取方式。
11.3.0
【问题原因 】ARM架构桌面端连接达梦需注入对应驱动依赖。【解决办法】需要注入依赖,提供达梦依赖包下载地址: https://pan.baidu.com/s/1JIcCoEjJBqUK7PMpt2gztw 提取码: ytaw,解压后将dmocci文件夹内文件拷贝到bin目录即可。
问题61:iDesktopX导入GDB数据提示导入失败?
11.3.0
【问题原因 】使用了数据迁移选项卡的"GDB数据库迁移"功能,该功能需要ArcGIS许可,机器上无对应许可信息导致失败。
【解决办法】导入GDB数据直接通过数据导入功能选择相应GDB文件夹即可,无需GDB数据库迁移功能;参数面板提供检查按钮可查看当前机器是否存在ArcGIS许可信息
问题62:用户咨询导入数据时"保留参数化"选项的含义,导入GDB、SHP数据时均遇到该选项,需理解该选项作用以便正确配置数据导入参数
11.3.0

【解决办法】该选项表示是否将源文件中的参数化对象(如圆、圆弧、块等)转换为参数化数据集或参数化对象,而不是打散成普通的点、线、面几何
三、SuperMap 其他
问题1:正式许可指定读取路径下的id文件被删,如何手动生成
11.3.0
【解决办法 】1、打开许可文件,提取signature标签中的id值;
2、在/opt/SuperMap/License目录下,新建一个文件名为上一步id值的空id文件;
3、再次执行清除许可命令即可正常执行并生成报告。
问题2:咨询一台电脑能否同时识别多个硬件加密锁许可,还是多个许可需要写入到同一个加密锁中
11.3.0
【解决办法】一台电脑上可以同时识别多个硬件加密锁许可
问题3:用户咨询超图产品网络软许可是否具有许可借入借出功能,现在是否还支持
11.3.0
【解决办法】11i产品开始没有网络软许可了
问题4:用户咨询Web许可的正式许可11和12版本是否可以统一用一个许可中心
11.3.0
【解决办法】一个web许可中心里面只能放一个许可文件,故没办法实现11i和12i版本统一用一个许可中心
问题5:用户咨询ActiveMap Desktop是否支持导入RVT格式数据
11.3.0
【解决办法】目前不支持导入RVT
问题6:用户咨询当前文件许可怎么换成Web许可
11.3.0
【解决办法】在许可配置界面点击切换按钮即可切换为Web许可配置
问题7:更新正式许可提示有不支持的模块,许可读取显示异常,许可为Web许可licc格式,需定位原因?
11.3.0
【解决办法】模块 ID 与平台不匹配,需联系商务重新出货。
问题8:咨询许可问题:同一服务器能否同时加载文件许可(iServer用)与私有云许可(iDesktopX借用),私有云许可后缀格式,以及能否同时用两个lic12正式许可。
11.3.0
【解决办法】同一服务器可同时加载文件许可和私有云许可;私有云许可后缀为licc;同一设备不能同时使用两个lic12文件许可;局域网内向其他设备分发(借用)许可必须使用licc的Web许可文件,文件型许可和许可中心不支持该操作。
问题9:客户服务器有两个MAC地址且第二网卡无法关闭,web许可中心生成的reportc文件基于第二个MAC,咨询如何指定第一个MAC地址生成许可申请文件。
11.3.0

【解决办法】手动改reportc文件中的mac地址和对应的ip
问题10:项目nginx响应头中X-Backend-Server取值为$upstream_addr直接暴露后端IP与端口,无法通过漏洞扫描,需优化配置。
11.3.0
【问题原因 】前期排查请求归属时新增的add_header X-Backend-Server $upstream_addr指令会泄露后端节点IP与端口信息。【解决办法】将该指令替换为header_filter_by_lua_block,通过节点别名拼接输出X-Backend-Server,避免泄露真实IP端口;先在76.111测试环境验证通过后再择机上线181生产环境,异常及时回退。
四、SuperMap iClient3D for WebGL
问题1:使用WebGL加载服务时指定了出图坐标系,缩放时数据会不显示
11.3.0
【问题原因】客户是使用的4326加的zxy格式瓦片,zxy瓦片不支持设置prjCoordSys动态投影,zxy服务只支持3857【解决方案】前端使用3857坐标系加载zxy瓦片数据
问题2:咨询代理后的天地图WMTS服务(浙江政务外网代理地址)如何在WebGL客户端中加载
11.3.0
【解决办法】使用接口:WebMapTileServiceImageryProvider,url添加jwt鉴权参数,加载代码可参考:https://blog.csdn.net/supermapsupport/article/details/147294870
问题3:用户有一个定点球机视频的实时视频流,相机会转动,咨询如何给该视频做空间化
11.3.0
【解决办法】可以参考官网的示例以及参数进行配准调试https://www.supermapol.com/webgl/examples/webgl/editor.html#RTSP
问题4:用户iServer 11.3正常访问可以使用,但加载到前端页面中报错,三维场景出不来,已确认无转发和网络问题
11.3.0

【问题原因 】网页报错请求不到瓦片,排查发现前端访问的是https的页面
【解决办法】需要配置代理,可参考博客https://blog.csdn.net/supermapsupport/article/details/141896415
问题5:TIN地形叠加海洋效果在Web端是否有效、能否叠加在线底图:桌面端添加在线底图后海洋效果被盖住。
11.3.0

【解决办法】Web端有效,使用SuperMapTerrainProvider添加地形时设置requestWaterMask为true即可显示海洋效果;支持验证叠加在线底图场景效果正常,桌面端被盖住属图层顺序问题,调整图层顺序即可。
问题6:Web端默认水面填充颜色桌面显示较深、web端偏浅,咨询能否用waterLayer.color调整加深水面颜色。
11.3.0
【问题原因 】waterLayer.color接口不支持直接修改水面颜色。【解决办法】通过新建三维符号(水面符号)设置新颜色,或在水面对应符号中修改颜色实现,改色需在符号层面操作。
问题7:iClient3D for WebGL使用cloudAndSky模板加载水面,出现很多块状斑点效果,关闭水面设置仍无法消除,多种水面样式均调不好。
11.3.0

【问题原因 】水面图层底部高程为0,模型碰撞产生浪花块状效果。【解决办法】将图层底部高程由0设置为1,块状斑点即不明显;如需调整水面颜色,通过新建三维符号设置新颜色实现。
问题8:实景三维数据(S3M 2.0切片,服务非本人发布)在客户端加载不出来,但iServer服务预览正常,咨询原因
11.3.0

【问题原因 】所用客户端开发示例版本太低(30163版Cesium示例),不兼容S3M 2.0数据。【解决办法】升级使用4开头的新版本客户端加载即正常显示
问题9:咨询iClient前端是否自带比例尺控件功能,希望在三维场景中实现类似传统二维地图的比例尺显示效果
11.3.0

【解决办法】iClient3D暂无内置比例尺控件,可通过开源社区搜索免费比例尺组件集成,或根据三维场景当前相机高度和分辨率自行计算并绘制比例尺,该方式会存在一定误差
问题10:iClient3D for WebGL场景开启地下模式后查看影像出现碎面现象,咨询是否因开启地下模式导致
11.3.0
【问题原因 】开启地下模式后相机容易穿透到地下,从地下往上看影像出现碎面;若地形做了裁剪或开挖但未设置开挖侧边也会出现该效果。【解决办法】不查看地下场景时建议先不开启地下模式;对地形裁剪或开挖后从地下观察时建议设置开挖侧边。
五、SuperMap iDesktop
问题1:需将数据中的负值修改为-9999,使用代数运算后结果完全没变化,代数运算不生效,需定位原因并协助处理
11.3.0

【解决办法】代数运算功能的运算表达式,不支持手动输入< > =,需要通过功能面板点击选择。
问题2:校准路由场景下,如何将公里桩号、百米桩号点数据与线数据进行校准关联,请求操作指导
11.3.0
【解决办法】客户的校准参考点数据为公里桩和百米桩的刻度值,在【校准路由】时,需要选择校准方法为"按刻度值校准";此外,根据桩距离路由的距离,需要将容限设为0.0001-0.0002左右,即可完成路由刻度的校准。
问题3:用户麒麟V10系统首次打开iDesktop报错,咨询报错原因及处理方式
11.3.0

【问题原因 】客户的iDesktopX包是从其他服务器拷贝的,不是原始包,这个包被解压使用过
【解决办法】重新下载原始包再解压使用,不能直接拷贝其他服务器的包
问题4:用户使用iDesktop生成点云瓦片(三维数据-点云生成瓦片),在球面场景中点云变成围着球体由点组成的一个圈,怀疑坐标系设置问题,数据非4528坐标系为默认测试坐标
11.3.0

【问题原因 】点云坐标系未正确设置所致,并且数据坐标参数xyz格式排列。导致生成瓦片后加载到球面场景错误。
【解决办法】使用正确坐标系,并且修改了点云数据中的xyz排列格式后,生成瓦片显示正确。
问题5:二元分类训练数据生成时选择512×512尺寸参数,生成的成果尺寸却为256,影响AI样本生产,问题紧急。
11.3.0
【问题原因 】设置的512单位为像素而非距离,影像分辨率0.5米,512像素×0.5米=256米,成果实际正确。【解决办法】确认参数含义后无需处理,若需指定距离尺寸需按分辨率换算像素值。
问题6:iDesktop需要按照截图中各颜色画框区域制作专题图,以及如何设置分值分组实现不同区域配色
11.3.0

【解决办法】使用单值专题图实现:新建一个字段,根据截图中希望配置不同颜色的画框区域分别赋予不同单值(如1、2、3),再基于该字段创建单值专题图,各单值分别设置对应颜色即可
问题7:桌面端放样功能中放样模型两端如何挖空(端头封闭无法形成通道),需要操作方法指导
11.3.0
【问题原因 】放样功能的截面是二维平面,放样中心点必须位于0,0点并使用投影坐标系的面数据集才能保证放样位置正确。【解决办法】新建投影坐标系的面数据集,在地图0,0点位置绘制两个同心圆,选中制作岛洞多边形得到圆环面,放样时选择该圆环面数据集,即可实现放样两端挖空。
问题8:按指导制作圆环面数据集进行放样后模型两端仍是封闭的,未实现挖空效果
11.3.0
【问题原因 】用户先前使用地理坐标系数据集且圆心不在0,0点,导致放样位置不正确无法得到挖空效果。【解决办法】改用投影坐标系的面数据集并将圆心置于0,0点位置制作岛洞多边形圆环面后,放样两端挖空生效
六、SuperMap iObjects Java
问题1:用户supermap-iobjectsjava-2026的SuperMap_Trial_License.v2c许可文件更新时提示已更新过该文件,但首页及许可状态中都查不到该许可
12.0.0

【问题原因 】.v2c不是许可文件,所以部署后不能读取到许可信息。
【解决办法】.lic12是许可文件,将许可文件放到C:\Program Files\Common Files\SuperMap\License文件目录下可自动读取许可
问题2:咨询iObjects Java中实现二维数据转三维功能的对应类,需要将二维点、线、面数据集转换为三维数据集
12.0.1
【解决办法】二维转三维无直接转换类:二维点可遍历后构造三维点Point3D并指定Z值;二维线或面数据集需遍历几何对象每个节点,将每个Point2D转换为Point3D,再重新构造三维几何对象
问题3:咨询使用OSGBVectorCacheBuilder类生成缓存时能否设置专题图
11.3.0
【解决办法】生成三维专题图需先制作三维单值专题图Theme3DUnique或三维标签专题图Theme3DLabel,再使用SceneCacheBuilder生成场景缓存
问题4:iObjects Java使用SceneCacheBuilder生成场景缓存索引文件为scv而非scp(iDesktopX生成的是scp),确认应使用的缓存生成类及生成scp的方法
12.0.0
【解决办法】生成OSGB场景缓存需设置layer3Ddataset.setIsBuildOSGBCache(true),设置后本地测试生成的缓存索引即为scp
问题5:iObjects Java 12.0.1-SNAPSHOT组件生成三维管线场景缓存后,管线不显示只能看到管点、缓存引用的三维点线符号丢失、管点无样式,且缓存瓦片多出scvd文件,与iDesktopX生成缓存异常表现一致
12.0.0

【问题原因 】用户所用12.0.1-SNAPSHOT版本组件存在问题,支持侧使用12.1.0版本组件切出的缓存正常(s3md+s3mb、无scvd)。
【解决办法】建议更新产品至12.1.0版本组件和桌面(https://support.supermap.com/DownloadCenter/ProductPlatform.aspx)
七、SuperMap iPortal
问题1:咨询SuperMap iPortal产品的角色权限信息具体存储在后端数据库的哪张表中,以便进行数据查询或管理。
11.3.0
【解决办法】角色权限信息存储在SuperMap iPortal安装目录/webapps/iportal/WEB-INF/ iserver-security.db中的user_roles表中。
问题2:iPortal中新增用户后如何用REST API修改用户角色为PORTAL_USER,官网帮助文档只有iServer的接口示例
11.3.0

【解决办法】对users资源执行PUT请求(http://IP:8190/iportal/manager/security/portalusers/User1.json?token={Token}),请求体中name、password(不改密码留空)、roles(如\["PORTAL_USER","DATA_CENTER"\])、type(CREATOR/VIEWER等)字段按需设置即可
问题3:iPortal 11.3的索引不更新,相关列表索引内容无法正常刷新
11.3.0

【解决办法】磁盘空间超过ES上限,官方FAQ处理方案:按文档修改esConfig相关配置(https://help.supermap.com/iPortal/iP/FAQ/ip_FAQ.htm#esConfig)
八、SuperMap Unreal Engine
问题1:HiFi for Unreal 5.2插件(2026版本)在Unreal 5.2.1中按安装教程部署编译后,控制界面文件选择按钮点击无反应,手动输入本地S3M瓦片路径添加也无效果,需定位原因
12.0.0

【问题原因 】默认UE关卡无超图插件,无法添加超图数据
【解决办法】需要新建或者打开示例关卡(带有超图插件的)
问题2:咨询HiFi 3D for UE的开发许可和运行许可有什么区别
11.3.0
【解决办法】开发许可面向开发用户,包含所有功能;运行许可用于产品的分发与部署,二次开发用户需要通过运行许可按需进行授权
九、SuperMap iClient for JavaScript
问题1:用户使用iClient for OpenLayers加载iServer 12i发布的REST地图服务,按属性条件过滤出图的displayFilters新接口报错not function,临时图层技术路线已走通但性能不行
12.0.0
【解决办法】参考技术博客自己在前端拼接displayFilters请求,并且同步上报iclient需求:https://blog.csdn.net/Carlo_paipai/article/details/164811535
十、SuperMap mDesktopX
问题1:桌面端ARM包(Ubuntu系统、rk3588 arm64 CPU)安装后启动失败闪退,请求指导排查
11.3.0

【解决办法】在军用桌面软件里,选"高级模式"启动。
十一、SuperMap iEdge
问题1:用户咨询iEdge是否可以发布自己的数据而不全是代理iServer服务,若要发网络分析服务是否需iServer采购网络分析服务模块
11.3.0
【解决办法】可以发布自己的数据,只有iServer服务提供方需要采购网络分析服务模块,iEdge使用方不需要采购
十二、SuperMap 库管系统
问题1:桌面无法打开,许可清除不掉(许可类型未知)
10.0.0

【问题原因 】许可无问题,查看程序日志得到程序启动失败原因是环境初始化失败,\WorkEnvironment\Default路径下环境文件损坏
【解决办法】重新解压软件包,替换路径下的环境文件
十三、SuperMap iManager
问题1:不动产服务器SuperMap iManager漏洞扫描发现Docker Registry API未授权访问漏洞,咨询处理方法。
11.3.0
【问题原因 】iManager使用的Docker镜像仓库5000端口无认证,可被未授权访问。【解决办法】方法一:搭建带用户认证的镜像仓库(如harbor),同步iManager镜像后修改iManager仓库配置;方法二:通过防火墙禁用k8s集群节点以外IP对仓库5000端口的访问。项目已选择先行添加防火墙策略。
平台产品线高频问题集合汇总表
https://lexiangla.com/teams/k100048/docs/ad346a06e82511ee87832effa0562057