宝塔安装nginx重启提示缺少libjemalloc.so.2

错误内容:

Nginx配置规则错误:

/www/server/nginx/sbin/nginx: error while loading shared libraries: libjemalloc.so.2: cannot open shared object file: No such file or directory

1.查看nginx启动命令需要哪些依赖:

ldd /www/server/nginx/sbin/nginx

2.缺少时,libjemalloc.so.2=>会指向空的,表示该依赖缺少,只要把libjemalloc.so.2文件加入到/lib64目录下即可。

网上会提示说将.so文件路径的目录添加到/etc/ld.so.conf 然后执行sudo /sbin/ldconfig。

阿里云服务器按照这个步骤处理后,会出现远程连接不上的问题,原因是/etc/ld.so.cache文件出现问题,将/etc/ld.so.cache文件重命名就可以继续远程连接了。

实战:腾讯云服务器使用

ldd /www/server/nginx/sbin/nginx #查看依赖

在其它同样的系统中用此命令查看,核实文件是否存在,如果没有,拷贝到相应目录即可。

sudo /sbin/ldconfig #生效

相关推荐
骇客野人2 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
比兔代理4 小时前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog5 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog5 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
蓝速科技5 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz5 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese6 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky6 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南7 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123457 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制