说说docker run的--detach

说说docker run的--detach

当我们使用了 docker的 run命令运行一个新容器,然后也发现他端端正正的呆在我们的容器列表中,但是就是无法使用 exec命令,这是什么原因呢?

复制代码
$docker docker ps -a
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS                      PORTS               NAMES
1c8a61e5e09b        php:latest          "docker-php-entrypoi..."   10 minutes ago      Up 10 minutes                                   php

如图我们看到,已经存在了这个容器,但如果这个时候使用exec就会报错,既没有启动这个容器。

复制代码
$docker start 1c8a61e5e09b
$docker exec -it 1c8a61e5e09b /bin/bash
Error response from daemon: www.smy1.com Container 1c8a61e5e09b is not running

但是如果我们继续使用start命令的话,他就会提示该容器已经启动了,那这又是什么原因呢?

因为我们单独的使用run只会启动容器,他会立即启动,相应然后就自动消失。你在这个时候使用exec命令已经太迟了。

所以,当我们启动容器的时候一定要加上--detach或者-d来保持容器在后台持续运行。那么我们重新来一次。

复制代码
$docker run -d -P php:latest
e63e06b3e66alasjdblqibeiqj1c8a61e5e09be7b996ec58a66438ee4e12db7f4d85189b21
# exec命令
$docker exec -it e63e06b3e66a /bin/bash -c "php --version"
PHP 7.2.12 (cli) (built: Nov 16 2018 03:17:59) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

这样就可以解决问题了。

相关推荐
YoungStudyAI4 小时前
QA的下一个自动化阶段,可能不是再写更多脚本,而是设计测试Agent
运维·自动化
分布式存储与RustFS5 小时前
纠删码到底吃掉了多少容量:EC:4、EC:8 的利用率与容错怎么算
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
遇见小修修5 小时前
3步解决打印机0x00000709报错 ,广州深圳程序员可自行排查
运维·打印机·维修·打印机报错·打印机运维·打印机故障自查
无序的浪6 小时前
测试博客-基于微服务的在线判题系统
java·spring cloud·docker·微服务·测试·在线判题
Huangjin007_7 小时前
【Linux 系统篇(二十五)】文件(二) 系统文件I/O详解
linux·运维·服务器
微小冷7 小时前
Mermaid画甘特图
运维·markdown·甘特图·mermaid·时间图
LBL12208 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器
志栋智能8 小时前
超自动化巡检:驱动持续改进的运维飞轮
运维·自动化
海宇大数据8 小时前
零信任架构实战:基于海宇学历核验版构建自动化风控审查网关
运维·人工智能·架构·自动化
NailiConveyor9 小时前
输送机系统与WMS仓储管理系统集成的5个关键技术点
大数据·运维·自动化·制造·业界资讯